+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Nat não funciona

    Minha rede não sai para internet fazendo NAT.
    Já configurei tudo certo como manda todos os tutoriais e nda.
    Só consigo copartilhar a internet usando o squid e sem regra de nat nenhuma. Mas me parece que as regras do iptables não adianta nada.
    alguém já passou por isso

  2. #2
    Cyberfred
    Visitante

    Padrão Nat não funciona

    mande as regras do iptables q vc estah utilizando



  3. #3
    paulogrifo
    Visitante

    Padrão Nat não funciona

    ((

    geralmente isso funciona....

    iptables -t nat -A POSTROUTING -o $REDE_LOCAL -j MASQUERADE
    iptables -t nat -A POSTROUTING -o $REDE_EXTERNA -j MASQUERADE

    porém cuidado que as demais regras podem atrapalhar o funcionamento

    ))

  4. #4
    Potiguar
    Visitante

    Padrão Nat não funciona

    Primeiro sugiro a vc verificar se o roteamento está habilitado, em seguida se vc está informando o gateway e os endereços de DNS do seu provedor.

    Com as opções conferidas tente fazer o seguinte:

    1- Elimine as regras do filtro iptables;
    # iptables -F
    # iptables -t nat -F

    2- Entre com as linhas
    # echo "1" > /proc/sys/net/ipv4/ip_forward
    Esta linha habilita o roteamento

    # iptables -t nat -A POSTROUTING -s 192.168.1.0/24 -o ppp0 -j MASQUERADE
    Esta linha ativa o mascaramento, cuidado com esta regra pois está mascarando todas as portas sendo assim mesmo sem o squid os usuários conseguirão navegar.

    ps.: Subistitua o endereço 192.168.1.0/24 pelo endereço de sua rede e o ppp0 pela interface adequada.

    Boa sorte!