+ Responder ao Tópico



  1. #1
    marcfee
    Visitante

    Padrão Amavis - Postfix

    Galera,

    Preciso de ajuda?

    Eu consegui com muito sacrificio instalar o Uvscan e o amavis, só que assim que aciono algumas linha nos arquivos de configuração do POSTFIX o meu servidor para de entregar as mensagens para os meu usuários, ou seja eu não consigo receber nadinha.

    As linhas que eu adicionei nos arquivos "main.cf" e "master.cf" são:


    #main.cf

    content_filter=vscan


    #master.cf


    vscan unix - n n - 10 pipe user=amavis argv=/usr/sbin/amavis ${sender} ${recipient} localhost:10025 inet n - n - - smtpd -o content_filter=



    <IMG SRC="images/forum/icons/icon21.gif">

  2. #2
    marcfee
    Visitante

    Padrão Amavis - Postfix

    Alguém sabe o que eu posso fazer?

    Será que o amavis esta disviando as mensagens para outro diretorio?



  3. #3
    marcfee
    Visitante

    Padrão Amavis - Postfix

    Galera,

    Dá uma luz ai, Please

  4. #4
    marcfee
    Visitante

    Padrão Amavis - Postfix

    Alguém me ajude.......



  5. #5

    Padrão Amavis - Postfix

    manda uma msgs e olha oq ele vai te mostrar no /var/log/messages

  6. #6
    Visitante

    Padrão Amavis - Postfix

    Olhei no /var/log/messages e não tinha nada.
    Mas eu discobri uma coisa e acho que o problema esta no arquivo main.cf
    Olha que engraçado, se a linha abaixo estiver descomentada no arquivo main.cf eu não recebo os emails.

    #main.cf

    content_filter=vscan


    Mas se eu comentar ela o meu servidor funciona normalmente, o que será que esta acontecendo.


    #main.cf

    #content_filter=vscan



  7. #7
    marcfee
    Visitante

    Padrão Amavis - Postfix

    Olhei no /var/log/messages e não tinha nada.
    Mas eu discobri uma coisa e acho que o problema esta no arquivo main.cf
    Olha que engraçado, se a linha abaixo estiver descomentada no arquivo main.cf eu não recebo os emails.

    #main.cf

    content_filter=vscan


    Mas se eu comentar ela o meu servidor funciona normalmente, o que será que esta acontecendo.


    #main.cf

    #content_filter=vscan

  8. #8

    Padrão Amavis - Postfix

    foi mal eu escrevi errado eh no maillog e naum no messages



  9. #9
    marcfee
    Visitante

    Padrão Amavis - Postfix

    Eu chequei o arquivo /var/log/maillog e ele me apresentou o seguinte:


    n 7 16:59:31 ns1 postfix/smtpd[4465]: connect from unknown[192.168.1.16]
    Jan 7 16:59:31 ns1 postfix/smtpd[4465]: D54F0FFACC: client=unknown[192.168.1.16
    ]
    Jan 7 16:59:32 ns1 postfix/cleanup[4466]: D54F0FFACC: message-id=<001301c2b67d$
    [email protected]>
    Jan 7 16:59:32 ns1 postfix/smtpd[4465]: disconnect from unknown[192.168.1.16]
    Jan 7 16:59:32 ns1 postfix/qmgr[4412]: D54F0FFACC: from=<[email protected]
    uetas.com.br>, size=1439, nrcpt=1 (queue active)
    Jan 7 16:59:32 ns1 postfix/pipe[4476]: fatal: get_service_attr: unknown usernam
    e: amavis
    Jan 7 16:59:33 ns1 postfix/qmgr[4412]: warning: end of input while receiving st
    ring data from service private/vscan
    Jan 7 16:59:33 ns1 postfix/qmgr[4412]: warning: private/vscan: malformed respon
    se
    Jan 7 16:59:33 ns1 postfix/master[4410]: warning: process /usr/lib/postfix/pipe
    pid 4476 exit status 1
    Jan 7 16:59:33 ns1 postfix/master[4410]: warning: /usr/lib/postfix/pipe: bad co
    mmand startup -- throttling

  10. #10
    marcfee
    Visitante

    Padrão Amavis - Postfix

    1c3_m4n,

    Eu naum consegui entender as mensagens que o log gerou....



  11. #11
    marcfee
    Visitante

    Padrão Amavis - Postfix

    To pirando com essa droga,

    Fou um parto para eu conseguir instalar o Uvscan e o Amavis, depois que eu consigo esta porcaria naum funciona direito


  12. #12

    Padrão Amavis - Postfix

    olha esse aki:
    Jan 7 16:59:32 ns1 postfix/pipe[4476]: fatal: get_service_attr: unknown usernam
    e: amavis

    vc criou o usuario amavis?



  13. #13
    marcfee
    Visitante

    Padrão Amavis - Postfix

    1c3_m4n,
    Eu criei o usuário vscan, mas o amavis naum.

  14. #14

    Padrão Amavis - Postfix

    entaum cria e tenta denovo



  15. #15
    marcfee
    Visitante

    Padrão Amavis - Postfix

    Eu criei o usuário amavis e mesmo assim naum funcionou, chequei o log novamente

    LOG:

    Jan 7 17:59:39 ns1 ipop3d[6108]: pop3 service init from 192.168.1.14
    Jan 7 17:59:40 ns1 ipop3d[6108]: Login user=vendas host=[192.168.1.14] nmsgs=0/
    0
    Jan 7 17:59:40 ns1 ipop3d[6108]: Logout user=vendas host=[192.168.1.14] nmsgs=0
    ndele=0
    Jan 7 18:00:01 ns1 postfix/smtpd[6115]: connect from unknown[192.168.1.16]
    Jan 7 18:00:02 ns1 postfix/smtpd[6115]: B0790FFACF: client=unknown[192.168.1.16
    ]
    Jan 7 18:00:02 ns1 postfix/cleanup[6116]: B0790FFACF: message-id=<004601c2b686$
    [email protected]as.com.br>
    Jan 7 18:00:03 ns1 postfix/smtpd[6115]: disconnect from unknown[192.168.1.16]
    Jan 7 18:00:03 ns1 postfix/qmgr[6053]: B0790FFACF: from=<[email protected]
    uetas.com.br>, size=1883, nrcpt=1 (queue active)



  16. #16

    Padrão Amavis - Postfix

    bom ai num tem erro nenhum.....
    agora deve ser um problema de relay....
    como esta configurado o relay?



  17. #17
    Visitante

    Padrão Amavis - Postfix

    na linha

    content_filter=vscan

    vc tem que colocar um : no final

    tem que ficar assim

    content_filter=vscan:

    []s
    <IMG SRC="images/forum/icons/icon_wink.gif">