+ Responder ao Tópico



  1. #1
    Ritchie
    estou tendo problemas com autenticação de usuário.
    Eu crio o arquivo de senhas e grupo, coloco as diretivas no httpd.conf e
    quando vou colocar a senha no browser e ele não entra na pagina..........

    alguem tem alguma ideia?

  2. Imagino que a configuração no apache esteja OK... então observe abaixo:

    .htaccess: Arquivo que deve estar no diretório ao qual se deseja a proteção. Neste arquivo estão descritos os vários parâmetros para a autenticação de usuário, como pro exemplo, onde encontra-se o arquivo de senhas. Segue um exemplo:

    AuthUserFile /home/books/.htpass
    AuthGroupFile /dev/null
    AuthName "Acesso Restrito "
    AuthType Basic
    <Limit GET POST PUT DELETE>
    require user fulano
    </Limi

    .htpass: Arquivo que contém o nome e senha dos usuários que terão acesso ao diretório. Pode ser dado outro nome a este arquivo, só que tem que especificar no .htaccess

    htpasswd: programa utilitário do Linux para a criação dos arquivos com senha. Ex:

    htpasswd –bc /home/book/.htpass usuer1 senha1
    htpasswd –b /home/book/.htpass usuer2 senha2
    htpasswd –b /home/book/.htpass usuer3 senha3

    -c -> Cria o arquivo .htpass
    -b -> adicina login e senha.

    Obs – Caso o arquivo .htpass já exista não posso adicionar a opção –c, do contrário ele substituirá o arquivo em questão.

    É por ai...

    [];



  3. poste seu httpd.conf (parte respectiva ao <Directory> que voce esta tendo problemas) e as linhas que voce usou para criar seu htaccess file.

  4. #4
    Ritchie
    valeu cara..........jã funcionou






Tópicos Similares

  1. Continua o problema com rota
    Por redoctober no fórum Servidores de Rede
    Respostas: 13
    Último Post: 08-11-2002, 13:04
  2. Problema com os log do Apache
    Por Good_speed no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-10-2002, 08:51
  3. Problemas com Perl
    Por adcorp no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-08-2002, 11:52
  4. Problema com o ssh pelo windows !!!
    Por embbr no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-07-2002, 18:10
  5. problemas com o IMP
    Por marlonfuchs no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-06-2002, 08:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L