+ Responder ao Tópico



  1. #1
    Visitante

    Padrão VirtualHost nao esta 100%

    Finalmente o Squirrelmail esta rodando OK aqui.
    O empasse eh o seguinte.
    quero que role agora como webmail.dominio.com.br
    Alterei o DNS, e o apontamento esta feito.
    No httpd.conf inseri as linhas abaixo, mas que ocorre eh:
    Quando entro no www.dominio.com.br a pagina esta normal.
    Em webmail.dominio.com.br tb esta normal.
    Mas se entro em um subdiretorio, por exemplo, www.dominio.com.br/qqlugar ele indica pagina nao existente, nem mesmo www.dominio.com.br/webmail entra direto, agora so pelo virtual.
    Se comento as linhas abaixo, o VirtualHost para de funcionar, mas as paginas voltam ao normal.
    Alquem pode me ajudar ??


    NameVirtualHost 200.XXX.YYY.ZZZ
    <VirtualHost 200.XXX.YYY.ZZZ>
    ServerAdmin [email protected]
    DocumentRoot /var/www/html/
    ServerName dominio.com.br
    </VirtualHost>

    <VirtualHost 200.XXX.YYY.ZZZ>
    ServerAdmin [email protected]
    DocumentRoot /var/www/html/webmail
    ServerName webmail.dominio.com.br
    </VirtualHost>


    []&acute;s
    Mateus Reis

  2. #2

    Padrão VirtualHost nao esta 100%

    Bom.

    voce pode tambem usar <VirtualHost *> mas nao eh o caso.

    tente colocar ServerName www.dominio.com.br
    deve resolver <IMG SRC="images/forum/icons/icon_smile.gif">

    qual versao do apache voce usa <IMG SRC="images/forum/icons/icon_smile.gif">? ah eh serio bom tambem voce logar as entradas <IMG SRC="images/forum/icons/icon_smile.gif">



  3. #3
    Visitante

    Padrão VirtualHost nao esta 100%

    Aparentemente funcionou com essa alteracao de www.dominio.com.br.

    Grato pela ajuda.
    Mateus Reis