+ Responder ao Tópico



  1. #1
    Apos configurar samba redondo ele funciona blz.. tudo acontece como deve
    acontecer...

    só que isto acontece apenas na primeira ves que eu me logo na segunda os
    volumes mapeados pelo w2k(netlogon) não estão mais acessíveis.O servidor
    fica incessivel, pede senha e mesmo assim não funciona...

    alguem tem idéia do que pode estar acontecendo??

    Segue abaixo meu smb.conf

    [global]
    null passwords = yes
    workgroup = MEDITEC
    log file = /var/log/samba/log.%m
    max log size = 50
    debug level = 1
    security = user
    password level = 8
    username level = 8
    encrypt passwords = no
    smb passwd file = /etc/smbpasswd
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n
    *passwd:*all*authentication*tokens*updated*successfully*
    username map = /etc/smbusers
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    local master = yes
    os level = 100
    domain master = yes
    preferred master = yes
    domain controller = Server
    domain logons = yes
    logon script = %U.bat
    logon path =
    ;name resolve order = wins lmhosts bcast
    wins support = yes
    ; wins server = w.x.y.z
    wins proxy = no
    dns proxy = no
    unix password sync = yes
    netbios name = Server
    map to guest = never
    ; preserve case = no
    ; short preserve case = no
    ; default case = lower
    ; case sensitive = no
    logon drive = t:
    #============================ Share Definitions
    ==============================
    [homes]
    comment = Home Directories
    browseable = yes
    writable = yes
    available = yes
    only user = no

    # Un-comment the following and create the netlogon directory for Domain
    Logons
    [netlogon]
    comment = Network Logon Service
    path = /files/net
    writable = no
    browseable = no

    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    guest ok = no
    writable = no
    printable = yes

    [meditec]
    comment = med
    path = /files/med
    writable = yes
    browseable = yes

    [tox]
    comment = tox
    path = /files/tox
    writable = yes
    browseable = yes
    write list = @users
    [rs]
    comment = rs
    path = /files/rs
    writable = yes
    browseable = yes

    [lukra]
    comment = lukra
    path = /files/lukra
    writable = yes
    browseable = yes
    force create mode = 777

    [publico]
    comment = pub
    path = /files/pub
    writable = yes
    browseable = yes
    force create mode = 777
    sync always = yes
    force directory mode = 777
    create mask = 777

    [catalogo]
    comment = cat
    path = /files/cat
    public = yes
    writable = yes
    browseable = yes
    create mask = 777




  2. Tenta pro um:

    valid users = user1, user2, user3...



  3. #3
    Todos os processos estão rodando normalmente...

    Consegui chegar a seguinte conclusão:

    Quando deixo no samba o "login script = %U.bat" ele funciona na primeira vez e na segundao script nem é executado na estação...e todos os caminhos já mapeados não funcionam...desta forma não consigo nem acesso ao server (pede senha, e nehuma funciona , nem root).

    Quando comento a linha (também comento tudo referente ao diretorio home do user) consigo acessar manualmente (mas só se eu desfazer os mapeamentos no w2k).

    Ou seja, quando o mapeamento existe no w2k ele parece fechar a conexão entre server/estação.

    è Estranho...

    Segue abaixo o smb.conf mais recente...

    [global]
    workgroup = MEDITEC
    server string = Samba Server
    ; hosts allow = 192.168.1. 192.168.2. 127.
    printcap name = /etc/printcap
    load printers = yes
    printing = lprng
    guest account = root
    log file = /var/log/samba/log.%U
    max log size = 50
    debug level = 1
    security = user
    ; password server = <NT-Server-Name>
    password level = 8
    username level = 8
    encrypt passwords = no
    smb passwd file = /etc/smbpasswd
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
    username map = /etc/smbusers
    ; include = /etc/smb.conf.%m
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    ; interfaces = 192.168.12.2/24 192.168.13.2/24
    ; remote browse sync = 192.168.3.25 192.168.5.255
    ; remote announce = 192.168.1.255 192.168.2.44
    local master = yes
    os level = 99
    domain master = yes
    preferred master = yes
    ; domain controller = <NT-Domain-Controller-SMBName>
    domain logons = yes
    ; logon script = %m.bat
    logon script = %U.bat
    logon path =
    logon home =
    name resolve order = wins lmhosts bcast
    wins support = yes
    ; wins server = w.x.y.z
    ; wins proxy = yes
    dns proxy = no
    ; unix password sync = yes
    netbios name = SERVER
    preserve case = no
    short preserve case = no
    default case = lower
    case sensitive = no
    admin users = root, osni
    valid users = osni, teste, andrea, administrador, root
    ;logon drive = t:
    remote browse sync = 192.168.0.255
    remote announce = 192.168.0.255
    create mask = 0777
    time server = yes
    domain admin group = root
    #============================ Share Definitions ==============================
    ;[homes]
    ; comment = Home Directories
    ; browseable = yes
    ; writable = yes
    ; available = yes
    ; public = yes

    [netlogon]
    comment = Network Logon Service
    path = /files/netlogon
    guest ok = yes
    writable = yes
    browseable = yes

    [meditec]
    comment = meditec
    path = /files/med
    public = yes
    writable = yes
    browseable = yes

    [tox]
    comment = tox
    path = /files/tox
    public = yes
    writable = yes
    browseable = yes

    [rs]
    comment = rs
    path = /files/rs
    public = yes
    writable = yes
    browseable = yes

    [lukra]
    comment = lukra
    path = /files/lukra
    public = yes
    writable = yes
    browseable = yes


    [publico]
    comment = publico
    path = /files/pub
    public = yes
    writable = yes
    browseable = yes

    [catalog]
    comment = catalogos
    path = /files/cat
    public = yes
    writable = yes
    browseable = yes

    [IPC$]
    path = /files/ipc
    public = yes
    writable = yes
    browseable = no

    [admin$]
    path = /files/winnt
    public = yes
    writable = yes
    browseable = no
    [C$]
    path = /files/c
    public = yes
    writable = yes
    browseable = no

  4. Se vc tem 2k/XP na rede como fez para entrar no dominio?
    Como esta o seu script de logon?

    veja se isto aqui funciona:
    @echo off
    rem Logon script padrão para a rede.
    net time /domain:SEUDOMINIO
    if %OS%.==Windows_NT. goto WinNT
    :Win95
    net use M: \\NETBIOS_NAME_SEU_SERVER\public /yes
    net use L: \\NETBIOS_NAME_SEU_SERVER\HOMES /yes
    goto end
    :WinNT
    net use M: \\NETBIOS_NAME_SEU_SERVER\public /persistent:no
    :end

    Marcos Amorim

    [ Esta mensagem foi editada por: marcosmamorim em 25-02-2003 10:16 ]



  5. #5
    navarro
    tenta efetuar um logoff antes de logar novamente pode ser que para o samba ele ainda esteja logado, pois ele mantem a conexão ativa mesmo após o seu uso por um bom tempo






Tópicos Similares

  1. netlogon - samba
    Por rcsousa no fórum Servidores de Rede
    Respostas: 5
    Último Post: 28-03-2011, 12:29
  2. problema samba/netlogon
    Por mpf11 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 15-09-2008, 09:37
  3. Samba no Windows XP com netlogon ????
    Por martello no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-04-2006, 16:41
  4. Usando netlogon no Samba sem ser PDC
    Por souzafo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 31-08-2005, 08:36
  5. Samba + Netlogon
    Por pilantrox no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-06-2005, 08:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L