Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Dae pessoas!

    Coloquei meu servidor no ar esta semana (iptables/squid/samba). Estava tudo muito legal, até que um cabra tentou fazer um FTP via browser e não conseguiu. Eu já pesquisei um monte, ví algumas dicas e testei-as, mas até agora nada de FTP via Browser. Na janela do IE aparece apenas uma lanterna iluminado uma pasta (procurando) e depois diz que o ftp://... não foi encontrado. Bloqueie a porta de FTP no squid (para ver se dava algum erro) e não apareceu nada além da bendita lanterna.
    Ah! já estava esquecendo, o FTP via software (ex.: aceftp) funciona.
    O que eu tenho que fazer para abilitar FTP via browser?
    Destaco que no meu squid.conf não há nenhuma configuração para o FTP (21) além da Safe_ports, e no iptables também não.

    Agradeço desde já!

    Dominum

  2. #2
    Futuremax
    Sei que existe um problema com o Squid e sites de ftp, principalmente os que pedem autenticação, mas esse problema só ocorre se vc se autentica via Squid, se não, tenta dar uma olhada ne como estão as Safe_Ports que o Squid usa no firewall, pode ser que vc tenha fechado alguma e por isso ele não encontre, pelo que vc disse a porta 21 está aberta pois programas funcionam normalmente, porém às vezes, volto a repetir "às vezes" o IE tenta se conectar pela porta 20, dá uma olhada como esta tá e tb eu ouvi boatos de que certos FTP´s não funcionam com o Speedy, não tenho muita certeza dessa informação, mas vale a pena verificar se vc usa Speedy. Se continuar dando erros aí, e essas soluções de nada valeram, posta aí pra gente dar uma pesquisada melhor...



  3. #3
    Dominum
    É Futuremax!
    a bagaça não fungou...
    Eu utilizo ADSL Brasil Telecom ao invés da Speedy.
    Limpei minhas regras do firewall (mantendo apenas as necessesárias para a conexão - nat), mas mesmo assim as estações não fazem o bendito FTP browseano.
    Caso tenha mais alguma sugestão, pode mandar.
    Contudo, agradeço pela tentativa... hehehe

    Dominum

  4. #4
    Danilo_Montagna
    seu iptables esta carregando esses modulos?

    /sbin/modprobe ip_conntrack_ftp
    /sbin/modprobe ip_nat_ftp

    =================================
    Danilo Montagna
    Analista de Suporte / Consultor Técnico
    Netowork Security Engineer
    Microsoft Certified Professional
    admin@mcpdomain.com
    http://www.mcpdomain.com
    =================================

    [ Esta mensagem foi editada por: Danilo_Montagna em 26-02-2003 08:34 ]



  5. Se vc naum estiver entrando em um site ftp autenticado vi proxy vc pode configurar o IE para que ele exiba conteudo de pastas FTP, o problema fica com relação ao passive mode, tente isso

    Ferramentas/Opções - Guia Avançado, existe duas opções q não me recordo agora que vc tem q habilitar para exibir o conteudo de FTP.


    Marcos Amorim






Tópicos Similares

  1. RB Só fica reiniciando depois de Downgrad!
    Por claudinhohw no fórum Redes
    Respostas: 4
    Último Post: 24-09-2012, 15:03
  2. Respostas: 3
    Último Post: 14-07-2011, 07:43
  3. Servidor FTP só conecta por WINSCP
    Por cristhianbini no fórum Servidores de Rede
    Respostas: 0
    Último Post: 25-02-2010, 16:21
  4. so fica um cliente conectado
    Por renatinhocm32 no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 26-02-2009, 22:41
  5. (xrdp xvnc) problema com color depth o trem só fica com 256 cores
    Por arium no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 02-02-2009, 08:49

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L