+ Responder ao Tópico



  1. #1

    Padrão SAMBA+WINDOWS XP

    Pessoal,

    Vou descrever o meu problema abaixo e depois de dois dias batendo cabeça com um problema peço encarecidamente a ajuda de vc´s:

    Samba-2.2.7a - PDC
    Kernel-2.4.18
    Red Hat 7.3Total de Maquinas (win98/me) na rede 80 e uma tão somente uma XP!!!!

    Configurado o samba e funcionando beleza, depois de 2 meses o cliente me liga para instalar um XP na rede, com toda a calma do mundo fui até o cliente e fiz os passos abaixo:

    groupadd estacoes
    useradd -s /bin/false -d /dev/null -g estacoes -u maquina$
    smbpasswd -a -m -n maquina$

    Legal né? Fui até o meu computador.... adicionei a máquina no dominio certo? certissimos....
    Para varia e q naum pode faltar no win "reiniciei".

    Vamos fazer logon no sistema e a mer... do XP manda essa msg "O servidor de dominio primário naum esta ativo ou esta inoperante" só que na rede tem mais 79 maquinas logadas no servidor, é um filho da mãe vc não acham?

    Loguei como administrador na maquina local e vamos adicionar usuários, vejo todos os usuário que estão cadastrados no SAMBA e seleciono um fulano qualquer e a mer... do XP manda outra mensagem "Falha de relação de confiança entre a estação de trabalho e o servidor primário, Se o problema persistir consulte o administrado da rede (esse sou eu!!!)", e agora o q fazer? Tudo o que foi escrito em um post com o mesmo problema que o meu foi feito e nada de resolver o problema, dentre outras pesquisas.

    Depois posso até postar o smb.conf aqui para vc verem mais naum acho conveniente, pois a mesma configuração que esta na minha casa esta no cliente (samba-2.2.7a) então eu naum acho que a minha configuração esteja errada, ja fiz outras vezes a mesma configuração com maquina win2000 e até hoje nem me ligam para dar um oi, hehehehe

    Pessoal novamente peço encarecidamente a ajuda de todos, alguém que ja passou pelo mesmo problema que o meu ou parecido.

    Naum me peça para mudar para EnabledPlainTextPassword naum dá para fazer isso.


    Marcos Amorim

  2. #2
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão SAMBA+WINDOWS XP

    Nao custa nada, cola ai seu conf, nao que esteja errado, mas por ai talvez possamos dar uma analizada geral do problema..



  3. #3

    Padrão SAMBA+WINDOWS XP

    [global]

    workgroup = SISTEMAS
    netbios name = samba
    server string = Samba Server
    log file = /var/log/samba.%m
    max log size = 50
    security = user
    encrypt passwords = yes
    null passwords = yes
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    interfaces = 192.168.10.1/24
    local master = yes
    os level = 33
    domain master = yes
    preferred master = yes
    domain logons = yes
    logon script = netlogon.bat
    wins support = yes
    dns proxy = no
    logon drive = H:

    [homes]
    comment = Home Directories
    browseable = no
    writable = yes

    [netlogon]
    comment = Network Logon Service
    path = /home/netlogon
    guest ok = yes
    writable = no
    share modes = no

    Ai esta o meu smb.conf existem mais share mais naum coloquei o q interessa é a sessão Global


    Marcos Amorim

    [ Esta mensagem foi editada por: marcosmamorim em 25-02-2003 23:58 ]

  4. #4



  5. #5
    cantisan
    Visitante

    Padrão SAMBA+WINDOWS XP

    O Windows XP não loga diretamente em um servidor Linux rodando Samba sem antes alterar a seguinte configuração. Vá em Iniciar/Executar e digite "gpedit.msc". Vá em Diretiva do Computador Local/Configuração do Computador/Configurações do Windows/Configurações de Segurança/Opções de Segurança e procure pelo item "Membro do Domínio: criptografar ou assinar digitalmente os dados do canal seguro (sempre)". Coloque-o desabilitado e o logon passará a funcionar.

  6. #6

    Padrão SAMBA+WINDOWS XP

    Cantisan,

    Como foi dito anteriormente eu utilizei todos os recursos em um tópico que tem relação com o meu problema, este e outros parametros foram desabilitados.

    inclusive este: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters]
    "requiresignorseal"=dword:00000000
    Conforme segue na documentação do Samba,

    Mais alguma sugestão?


    Marcos Amorim



  7. #7

    Padrão SAMBA+WINDOWS XP

    Bom jah q voce aplicou todos os patches ...
    e mudou as diretivas de seguranca de dominio todas para disabled.
    Nao tem mais nada para fazer de configuracao.

    entretanto voce prescisa de uma diretiva no seu smb.conf
    domain admins = @adm

    group adm , eh um dos grupos pertecente ao root. eh necesasrio esas linha para XP logarem. e win2k tbm. (apesar de os seus nao logarem a principio)

    va no seu XP, e de um net use * /d
    para que ele nao faca nenhuma conexao, senao isso mata o processo todo... fikei 2 dias com essa frescura.

    bom, va la e na hora de entrar em um dominio.
    ponha la seu dominio, e logue como root.

    depois de cerca de uns 30-60s devera aparecer bem vindo ao DOMAIN.

    Deve funcionar, se nao funcionar... paciencia, eu posso te mandar meu smb.conf depois, mas basicamente o q eu lembre esses são os passos. <IMG SRC="images/forum/icons/icon_smile.gif">

  8. #8
    Visitante

    Padrão SAMBA+WINDOWS XP

    Para adicionar estações WinXP não precisa fazer muita coisa, primeiramente seu arquivo está correto precisando melhorar apenas seu "os level" para um número maior tipo "os level=100" e crie a linha "announce as = NT Server" para frizar que seu Samba é um Server.

    Sem mais, basta vc fazer o que o cantisan mencionou apenas o que ele disse não precisa entrar em registro nada disso basta executar a operação que ele mencionou, faço isso pelo menos umas 15 vezes ao dia.

    Não esqueça de criar as contas de computador e informar o servidor linux na lista de servidores wins do protocolo TCP/IP.

    Con certeza vc está fazendo algo errado, reveja suas configurações.

    com certeza vc esta realizando um dos processos errados, tenha várias máquinas com Windows XP e
    os level = 100
    announce as = NT Server



  9. #9

    Padrão SAMBA+WINDOWS XP

    Anonimo,

    Concordo com vc em todos os pontos pode ser aquela virgula OK?, eu tb ja configurei outras redes com XP e 2000 na rede e essa ta me dando um baile.

    O os level naum para concorrência entre servidores na mesma rede, aumentando vc fara com q o samba seja eleito o PDC? Só que nessa rede só existe um server PDC existe um outro linux configurado o SAMBA mais este é para o serviço de telefonia.....

    Ja o announce posso tentar depois qualquer coisa manda uma resposta tanto positiva quanto negatica do assunto.....


    Valeu pela dica,



    Marcos Amorim

  10. #10

    Padrão SAMBA+WINDOWS XP

    mistymst,

    Naum vejo um pq de colocar no smb.conf domain admin = user, pq eu ja fiz outras configurações com XP na rede e naum precisei de nada disso, quanto a maquina esta no dominio ela é aceita no dominio

    Ja utlizei este comando e net session * /delete e tantos os outros comandos....

    No estágio em que eu estou vou tentar a sua dica,

    Valeu pela ajuda,


    Marcos Amorim