+ Responder ao Tópico



  1. #1
    rEsEtbnu
    Visitante

    Padrão roteamento - gateway

    Olá pessoal.

    Estou fazendo um servidor para compartilhar o acesso internet, mais tarde pretendo colocar um firewall.

    Tenho um router 3Com 812.
    Abaixo segue o desenho de como esta montado.

    Router 3Com 812 Server_Linux Estacao 1
    | | | |
    V V V V
    IP eth0 eth1 IP
    192.168.0.254 <-> 192.168.0.1 192.168.1.1 <-> 192.168.1.2

    Não consigo pingar o router ADSL da Estacao 1.
    O que devo fazer?



  2. #2
    fereggert
    Visitante

    Padrão roteamento - gateway

    ÐÆ rEsEt... blz véio?????


    Cara, num deu pra intende esse desenho!!!!!

    Tem como explicar melhor???

    QQER coisa dá uma ligada aki na tele...

    Valew.

    <IMG SRC="images/forum/icons/icon21.gif">



  3. #3

    Padrão roteamento - gateway

    coloca o modem direto na eth0

    coloca a eth1 no hub

    seu modem tem o ip 192.168.200.254

    seu ip na eth0 tem q ser 192.168.200.x
    seu gateway é o modem (192.168.200.254)
    seus dns vc pega com o provedor

    o ip da eth1 vai estar na sua rede

    poe no rc.local:

    echo 1 > /proc/sys/net/ipv4/ip_forward

    prontinhu.... agora soh falta a firewall

    t+

  4. #4
    Danilo_Montagna
    Visitante

    Padrão roteamento - gateway

    seguinte Resetbnu..

    para o pacote de ping conseguiur voltar.. o router 812 teria que ter como gateway padrao o ip da eth0 do linux.. como isso nao pode acontecer pelo fato do router quem ter o default gateway para a Brasil Telecon..

    entao vc tem que fazer o seguinte...

    # ativar o roteamento dinamico
    echo "1" > /proc/sys/net/ipv4/ip_forward

    # mascarar a conexao..
    iptables -A POSTROUTING -t nat -s sua_rede -o eth0 -j MASQUERADE

    se fosse um roteador entre duas redes internas.. apeans com o ip_forward aj funcionaria.. pois cada ponta teria como default gateway o proprio linux.. ou seja. assim o pacote voltaria sem problemas..




  5. #5
    rEsEtbnu
    Visitante

    Padrão roteamento - gateway

    Olá pessoal, tudo em cima?

    Bom, fiz tudo mas nao consigo pingar o router ainda. Vou colocar todos os dados abaixo.

    router 192.168.0.254

    Linux: eth0 192.168.0.1
    : eth1 192.168.1.1

    lan_win: 192.168.1.166

    #digitei os seguintes comandos:
    echo "1" > /proc/sys/net/ipv4/ip_forward
    iptables -A POSTROUTING -t nat -s 192.168.1.0 -o eth0 -j MASQUERADE

    #dei o command route e me mostrou os seguintes dados:
    Destination - Gateway - Genmask - Use Iface
    192.168.1.1 - * - 255.255.255.0 - eth1
    192.168.0.0 - * - 255.255.255.0 - eth0

    Se tento pingar a eth0 da Lan_win, eu consigo sem problemas. Mas se tento pingar o 192.168.0.254(ip do modem) da "Esgotado tempo limite do pedido", E não ping de jeito nenhum.

    Não esta faltando setar algum gateway no linux? Mas se for como faço isso?

    Abraços galera.

  6. #6
    Maiko
    Visitante

    Padrão roteamento - gateway

    seguinte brother

    Em qual interface está ligada o router?

    se for na eth0

    faca assim

    route add 192.168.0.254 gw (ip da eth0)

    ser foi na eth1

    route add 192.168.0.254 gw (ip da eth1)

    e abilite a repassagem dos pacotes
    echo "1" > /proc/sys/net/ipv4/ip_forward

    fui...



  7. #7

    Padrão roteamento - gateway

    Olha, esse seu modem nao esta ligado direito na eth0 do seu linux? ele deveria estar. voce verificou qual netmask voce esta usando na eth0 do seu linux e do seu modem? tem que ser a mesma. se nao for nao vai pingar nunca sem uma rota especifica, caso ele nao esteja na mesma subnet.
    eu nunca mechi com esses modems entao nao vou dar piteco. primeiro faca os 2 se enxergarem, depois mecha com o acesso a internet para o resto da rede. ah sim, eh para adicionar na mao um gateway basta voce digitar:
    route add default ip (ou eh route add default gw ip..) nao lembro hehe <IMG SRC="images/forum/icons/icon_smile.gif"> mas parece que eh a primeira. ou na hora que voce configura a interface de rede voce pode por la... muitas utilitarios fazem isso, do tipo, como linuxconf, YaST, netconf, etc etc ...

  8. #8
    rEsEtbnu
    Visitante

    Padrão roteamento - gateway

    Galera, a mascara esta ok: 255.255.255.0
    dai executei:

    route add -net default gw 192.168.0.254

    E não pinga o router.

    Tem algum lugar que eu possa verificar se esta tudo ok?



  9. #9
    Danilo_Montagna
    Visitante

    Padrão roteamento - gateway

    faz o seguinte..

    vi /etc/sysconfig/network

    acrescente essas linhas..

    GATEWAY="192.168.0.254"
    GATEWAYDEV="eth0"

    vi /etc/resolv.conf

    nameserver = 200.xx.xxx.xxx (DNS PRimario do provedor)
    nameserver = 200.xx.xxx.xxx (DNS Secundario do provedor)

    verifique se o NAT do roteador esta ativado...

    feito isso etm que funcionar..

  10. #10
    Maiko
    Visitante

    Padrão roteamento - gateway

    amigo, vc tem duas classes de ip

    192.168.0.
    192.168.1.

    se vc nao criar um rota entre elas, nao vai funfar de jeito nenhum.



  11. #11
    Danilo_Montagna
    Visitante

    Padrão roteamento - gateway

    Maiko,

    nao precisa.. as rotas de todas as interfaces de uma maquina sao criadas por default..

  12. #12
    rEsEtbnu
    Visitante

    Padrão roteamento - gateway

    Pronto galera, finalmente consegui.

    Graças a ajuda de vocês, do pessoal do irc.debian.org #debian-br, e da minha insistencia. Obrigado a todos.

    Abaixo vai todos os passos para realizar esta tarefa.
    Ate parece um mini-howto <IMG SRC="images/forum/icons/icon_biggrin.gif">

    Linux: Debian 3.0r1 - Woody

    No Router ADSL
    IP 192.168.0.254

    No Server Linux
    eth1 192.168.0.1
    eth0 192.168.1.1

    Na REDE
    IP´s 192.168.1.x (x é numero quelquer de 2 a 254, significando o numero da maquina)
    Mascara 255.255.255.0
    Gateway 192.168.1.1
    DNS 200.215.1.35 (ou qualquer servidor DNS que você quiser)

    No SERVER_LINUX

    Configurar as placas de rede:

    /etc/network/interfaces

    #----------------------------------------------------------------------#
    #Interface Loopback
    auto lo
    iface lo inet loopback

    #Lan conectada no Routeador ADSL
    auto eth0
    iface eth0 inet static
    address 192.168.1.1
    network 192.168.1.0
    netmask 255.255.255.0
    gateway 192.168.1.1

    #Lan conectada na Rede Interna
    auto eth1
    iface eth1 inet static
    address 192.168.0.1
    network 192.168.0.0
    netmaks 255.255.255.0
    gateway 192.168.0.254
    #----------------------------------------------------------------------#

    #digite no console:
    echo 1 > /proc/sys/net/ipv4/ip_forward

    #em /etc/network/options
    ip_forward=yes

    #agora as regrinhas do iptables:
    iptables -F
    iptables -t nat -F
    iptables -t nat -A POSTROUTING -s 192.168.1.0/24 -j MASQUERADE
    iptables -P FORWARD ACCEPT
    iptables -P INPUT ACCEPT
    iptables -P OUTPUT ACCEPT
    /etc/init.d/iptables save_active # Este comando salva e ativa as configurações do iptables

    PRONTO.
    Agora é só testar.

    Abraços.
    ^rEsEt <IMG SRC="images/forum/icons/icon21.gif">



  13. #13
    Danilo_Montagna
    Visitante

    Padrão roteamento - gateway

    mais cara.. eu acho que tem furo nisso ae que vc fez..

    pq vc esta usando o modem no mesmo barramento da rede interna??

    desse jeito vc fica vulneravel do mesmo jeito...

    qual a finalidade da placa eth0 ter o gateway apontado para ele mesmo??

    sinceramente. eu nao saquei pq vc ta usando assim..

    bom eu to achando que vc so trocou as bolas ae no mini-howto.. pois analisando o iptables.. as regras estao corretas.. porem.. o gateway apontando para ele mesmo.. eu nao vejo poq estar sendo usado..

    ===============================
    #Lan conectada no Routeador ADSL
    auto eth0
    iface eth0 inet static
    address 192.168.1.1
    network 192.168.1.0
    netmask 255.255.255.0
    gateway 192.168.1.1

    #Lan conectada na Rede Interna
    auto eth1
    iface eth1 inet static
    address 192.168.0.1
    network 192.168.0.0
    netmaks 255.255.255.0
    gateway 192.168.0.254


    [ Esta mensagem foi editada por: Danilo_Montagna em 28-03-2003 12:43 ]