Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    rEsEtbnu
    Olá pessoal.

    Estou fazendo um servidor para compartilhar o acesso internet, mais tarde pretendo colocar um firewall.

    Tenho um router 3Com 812.
    Abaixo segue o desenho de como esta montado.

    Router 3Com 812 Server_Linux Estacao 1
    | | | |
    V V V V
    IP eth0 eth1 IP
    192.168.0.254 <-> 192.168.0.1 192.168.1.1 <-> 192.168.1.2

    Não consigo pingar o router ADSL da Estacao 1.
    O que devo fazer?



  2. #2
    fereggert
    ÐÆ rEsEt... blz véio?????


    Cara, num deu pra intende esse desenho!!!!!

    Tem como explicar melhor???

    QQER coisa dá uma ligada aki na tele...

    Valew.

    <IMG SRC="images/forum/icons/icon21.gif">



  3. coloca o modem direto na eth0

    coloca a eth1 no hub

    seu modem tem o ip 192.168.200.254

    seu ip na eth0 tem q ser 192.168.200.x
    seu gateway é o modem (192.168.200.254)
    seus dns vc pega com o provedor

    o ip da eth1 vai estar na sua rede

    poe no rc.local:

    echo 1 > /proc/sys/net/ipv4/ip_forward

    prontinhu.... agora soh falta a firewall

    t+

  4. #4
    Danilo_Montagna
    seguinte Resetbnu..

    para o pacote de ping conseguiur voltar.. o router 812 teria que ter como gateway padrao o ip da eth0 do linux.. como isso nao pode acontecer pelo fato do router quem ter o default gateway para a Brasil Telecon..

    entao vc tem que fazer o seguinte...

    # ativar o roteamento dinamico
    echo "1" > /proc/sys/net/ipv4/ip_forward

    # mascarar a conexao..
    iptables -A POSTROUTING -t nat -s sua_rede -o eth0 -j MASQUERADE

    se fosse um roteador entre duas redes internas.. apeans com o ip_forward aj funcionaria.. pois cada ponta teria como default gateway o proprio linux.. ou seja. assim o pacote voltaria sem problemas..




  5. #5
    rEsEtbnu
    Olá pessoal, tudo em cima?

    Bom, fiz tudo mas nao consigo pingar o router ainda. Vou colocar todos os dados abaixo.

    router 192.168.0.254

    Linux: eth0 192.168.0.1
    : eth1 192.168.1.1

    lan_win: 192.168.1.166

    #digitei os seguintes comandos:
    echo "1" > /proc/sys/net/ipv4/ip_forward
    iptables -A POSTROUTING -t nat -s 192.168.1.0 -o eth0 -j MASQUERADE

    #dei o command route e me mostrou os seguintes dados:
    Destination - Gateway - Genmask - Use Iface
    192.168.1.1 - * - 255.255.255.0 - eth1
    192.168.0.0 - * - 255.255.255.0 - eth0

    Se tento pingar a eth0 da Lan_win, eu consigo sem problemas. Mas se tento pingar o 192.168.0.254(ip do modem) da "Esgotado tempo limite do pedido", E não ping de jeito nenhum.

    Não esta faltando setar algum gateway no linux? Mas se for como faço isso?

    Abraços galera.






Tópicos Similares

  1. Respostas: 2
    Último Post: 20-05-2009, 10:43
  2. Respostas: 16
    Último Post: 30-05-2007, 10:28
  3. Roteamento duas redes diferentes conectadas ao mesmo gateway
    Por gsiena no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-11-2005, 11:22
  4. Possível problema com roteamento em um gateway
    Por André L. Melim no fórum Servidores de Rede
    Respostas: 9
    Último Post: 17-05-2004, 10:54
  5. gateway, roteamento
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 18-08-2003, 17:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L