+ Responder ao Tópico



  1. #1
    ALguem ai pode me ajudar?

    Configurei o nagios de forma a utilizar o apache para visualizacao. Adicionei as linhas ao httpd.conf,
    criei o .htaccess e criei os usuarios no .htpasswd.users. No arquivo cgi.cfg habilitei todas as permissoes ao ususario em questao,
    qd acesso o nagios pelo apache, clico por exemplo na monitoracao do host, ele me pede a autenticacao. Entro com o usuario que crie no htpasswd.user e
    cujo diretios de monitoracao estao completos de acordo com o cgi.cfg, porem el;e me retorna Authentication FAiled??Porque
    ???
    Agradeco se alguem estiver alguma ideia do que possa estar acontecendo.

    VAleu!!!

  2. pode ser q ele num esteja conseguindo ler o arquivo de senhas.......
    da uma olhada no q ele mostra no seu /var/log/apache/error_log qdo vc tenta entrar ae no nagios



  3. #3
    Olhei a log e realmente deve estar acontecendo algum problema na hora de buscar o arquivo ,
    o apache busca no dir /nagios/cgi-bin/tac.cfg
    mas esse arquivo nao se encontra neste caminho(o que fornecer um erro user xxx not found) :. Porem existe um alis para tal caminho que aponta pro caminho correto /usr/local/nagios/sbin/
    sera que ele nao esta conseguindo resolver isso??
    Alem disso na log ele diz que nao consegue abrir o .htpasswd.users , acho que deve ser pq ele nao acha o usuario!! O intrigante e que ja refiz tal configuracao varias vezes e continua o mesmo erro!!
    VALEU!!

  4. #4
    Olhei a log e realmente deve estar acontecendo algum problema na hora de buscar o arquivo ,
    o apache busca no dir /nagios/cgi-bin/tac.cfg
    mas esse arquivo nao se encontra neste caminho(o que fornecer um erro user xxx not found) :. Porem existe um alis para tal caminho que aponta pro caminho correto /usr/local/nagios/sbin/
    sera que ele nao esta conseguindo resolver isso??
    Alem disso na log ele diz que nao consegue abrir o .htpasswd.users , acho que deve ser pq ele nao acha o usuario!! O intrigante e que ja refiz tal configuracao varias vezes e continua o mesmo erro!!
    VALEU!!



  5. sevc fez um link pra ele vc deve ativar a opção FollowSynlinks no diretorio






Tópicos Similares

  1. Respostas: 19
    Último Post: 28-01-2016, 03:18
  2. problema para instalar Nagios junto com mk-auth
    Por robertopc95 no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 05-10-2014, 10:35
  3. AUTH no sendmail
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 15-01-2003, 09:11
  4. SMTP-AUTH
    Por Seijuurou no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-12-2002, 10:29
  5. nagios - help
    Por SnifferSp no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-08-2002, 11:31

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L