+ Responder ao Tópico



  1. #1
    juniox
    Visitante

    Padrão Slackware e Lilo

    ae, eu tava com o red hat 7.3 na minha máquina, usando o grub ao invés do lilo...

    fui instalar o slackware 8.0, daí, na instalação disse pra formatar a partição onde estava o redhat (/dev/hda6) e preservei a do winxp (/dev/hda1).

    terminei a instalãção numa boa, porém eu só consigo carregar o linux com o disco de boot, digo.. ele não abre mais a tela do lilo..

    se eu deixar ele iniciando sem o disco de boot, ele vai parar somente numa tela assim:

    grub>

    ou

    grup>

    (não to lembrado agora exatamente)

    e daí.. tem poucos comandos disponíveis...

    se eu iniciar com o disco de boot, dá certo, porém ele entra direto.. sem me dar a opção de entrar no win...

    como resolver isso ?

    valew

  2. #2
    cyrix
    Visitante

    Padrão Slackware e Lilo

    Na minha maquina, eu uso o lilo ao inves do grub (pra falar a verdade, nunca usei o grub). Tente algo assim:

    No linux, edite o arquivo /etc/lilo.conf (configuração do lilo). WinXP (/dev/hda1) Linux (/dev/hda2)

    boot=/dev/hda
    map=/boot/map
    install=/boot/boot.b
    prompt
    timeout=50
    message=/boot/message
    lba32
    default=linux

    image=/boot/vmlinuz-2.4.0-0.43.6
    label=linux
    initrd=/boot/initrd-2.4.0-0.43.6.img
    read-only
    root=/dev/hda2

    other=/dev/hda1
    label=winxp

    Apos isso, salve o arquivo e digite no prompt como root:

    # lilo

    Pronto, se nenhum erro ocorrer, reinicie o computador e escolha entre o linux e winxp na hora da inicialização.



  3. #3
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Slackware e Lilo

    Voce pode realmente fazer a configuracao do XP no /etc/lilo.conf, usando o utilitario grafico, liloconfig, ou manual, editando o arquivo acima referido, e acrescentando:

    other = "/dev/hdaX"
    label = "windows xp"
    table = "/dev/hda"

    Onde hdaX eh a particao referente a seu windows. Supondo, eh claro, que ela esteja no HD 1, /dev/hda.

    Feito isso, salve e faca: lilo -M /dev/hda

    (Soh lembrando, no Slackware, a imagem de boot do linux fica em /boot/vmlinuz.)

  4. #4
    Beto
    Visitante

    Padrão Slackware e Lilo

    Blz Juniox,

    Tive um problema desse tb, dei boot com o disquete do win98, apaguei a MBR
    < fdisk\MBR >, outro boot para entrar no Linux e instalei novamente o Grub (ou instale o Lilo), depois de instalado, siga as dicas do Cyrix e Psy, estão perfeitas.

    Não esquecendo de salvar as alterações e digitar no prompt como root < #lilo > para carregar as alterações.

    ()´s

    Beto