Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    juniox
    Olá, seguinte, to com o slackware 8.0 aqui, e baixei o xawtv-3.76, porém to com uns problemas quando vou compilá-lo.

    eu estava usando a versão mais atual do xawtv, e estava dando problema no ´make´ , então peguei uma versão mais antiga, e o problema veio antes, no ./configure

    quando rodo: ./configure, ele começa a configurar e tal... daí.. começa a aparecer linhas assim:

    x11/wmhooks.c:64 warning: pointer of type `void *´ used in arithmetic
    x11/wmhooks.c:64 warning: pointer of type `void *´ used in arithmetic
    x11/wmhooks.c:64 warning: pointer of type `void *´ used in arithmetic
    x11/wmhooks.c:64 warning: pointer of type `void *´ used in arithmetic

    repetidas vezes... e em várias linhas diferentes...

    x11/xawtv.c:877: warning: pointer of type `void *´ used in arithimetic
    x11/xawtv.c:877: warning: pointer of type `void *´ used in arithimetic
    x11/xawtv.c:877: warning: pointer of type `void *´ used in arithimetic
    x11/xawtv.c:877: warning: pointer of type `void *´ used in arithimetic
    ...

    /usr/include/bits/string2.h:443 warning: pointer of type `void *´ used in arithimetic
    /usr/include/bits/string2.h:443 warning: pointer of type `void *´ used in arithimetic
    /usr/include/bits/string2.h:443 warning: pointer of type `void *´ used in arithimetic
    /usr/include/bits/string2.h:443 warning: pointer of type `void *´ used in arithimetic

    etc.. etc.. etc...

    não sei se isso está normal ou se é algum problema, porém no final.. ele exibe alguns erros, entre eles:

    x11/motv.c:34 Xm/Protocols.h: No such file or directory
    X11/motv.c:35 Xm/Display.h: No such file or directory
    etc...

    make: *** [x11/motv.o] Error 1

    -------------------------

    o que pode ser isso ? alguma incompatibilidade ? seria a versão do gcc antiga ? ou ignorância minha ?

    sei lá.. to mexendo no slackware há dois dias... , já configurei no conectiva e red hat... mas nem tem comparação, lá era tudo "semi-automático"...

    bom, obrigado desde já


  2. Bom, eh soh um aviso. dizendo que um ponteiro que nao possui retorno foi utilizado em uma operacao aritmetica... nao se preocupe. entretanto o que da erro e que ele nao encontra algumas bibliotecas como a protocols.h ... verifique se voce tem todas as depedencias necessarias para compilar o programa, deve ter isso na pagina ou no readme do source <IMG SRC="images/forum/icons/icon_smile.gif">



  3. #3
    juniox
    ae...

    soube que eu tenho que pegar o pacote lesstif-devel pra compilar o xawtv... porém eu só encontro em rpm...

    alguém tería em tgz ? ou sabe onde arrumo ?


    valew

  4. #4
    juniox
    ae gente...

    não dá certo!!

    quando vou rodar o "make" ele dá aquele erro..

    alguém me ajudae!!!???



  5. #5
    juniox
    pouts...

    TODA HORA DÁ UMA DROGA DE ERRO NISSO AQUI!!! <IMG SRC="images/forum/icons/icon_eek.gif">

    PELO AMOR DE DEUS..... ALGUÉM QUE USE SLACKWARE JÁ CONFIGUROU A PLACA DE TV ??? <IMG SRC="images/forum/icons/icon27.gif">






Tópicos Similares

  1. Menssagem de erro no qmail
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-02-2005, 20:41
  2. erro no ./configure
    Por daniell no fórum Servidores de Rede
    Respostas: 4
    Último Post: 13-05-2003, 12:54
  3. erro no WINE
    Por 1c3m4n no fórum Servidores de Rede
    Respostas: 3
    Último Post: 02-11-2002, 06:52
  4. Erro no INIT
    Por aryjr no fórum Servidores de Rede
    Respostas: 3
    Último Post: 01-11-2002, 19:33
  5. re: erro no linux
    Por haysar no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-06-2002, 17:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L