+ Responder ao Tópico



  1. #1
    Neerlan_Amorim
    Ae pessoal, estou tendo alguns problemas com o squid
    entendo pouco o squid, as configurações que fiz foi lendo tutoriais

    Minha "/etc/squid/squid.conf":
    http_port 3128
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    cache_mem 8 MB
    cache_dir ufs /var/cache/squid 400 16 256
    auth_param basic children 5
    auth_param basic realm Squid proxy-caching web server
    auth_param basic credentialsttl 2 hours
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    acl minharede src 192.167.20.0/24
    acl blockedsites url_regex -i /var/cache/squid/bloqueados/block.txt
    acl unblockedsites url_regex -i /var/cache/squid/bloqueados/unblock.txt
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow minharede
    http_access deny blockedsites !unblockedsites
    http_access deny all
    http_reply_access allow all
    icp_access allow all
    cache_mgr neerlan@x-linux.org
    cache_effective_user proxy
    cache_effective_group proxy
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    error_directory /usr/share/squid/errors/English
    coredump_dir /var/cache/squid

    "/etc/rc.d/rc.local":
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -s 0/0 -j MASQUERADE
    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

    Eu configurei como proxy transparente só que se eu nao colocar o endereço do proxy na configuração do navegador nao funciona.
    E os sites que bloquiei no arquivo block.txt , nao estao sendo bloqueados

    Como resolvo esse problema? <IMG SRC="images/forum/icons/icon27.gif">

  2. #2
    RCM
    Neerlan, é o seguinte, relamente vc tem que configurar o navegador para força-lo a passar pelo proxy, pelo menos foi assim que eu aprendi.
    De uma olhada neste site, lá vc vai encontrar umas boas dicas de como resolver seu problema.

    http:\web.onda.com.br\orso.
    Aqui vc vai encontrar um programa chamado SARG, ele monta relatórios com os dados gerados no access.log do squid, é bem bacana e tem outros programas também.

    espero ter ajudado.
    []&acute;s
    RCM <IMG SRC="images/forum/icons/icon_razz.gif">



  3. #3
    ftmiranda
    Tenta assim:

    http_port 192.168.1.1:3128 #IP do seu servidor
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    Isso dai deve colocar o proxy transparente LIGADO.

    Tente isso primeiro, depois vc implementa as ACLs

    Blz?

  4. #4
    Pessoal,

    Tentei configurar o squid aqui na empresa, mas parece que tem algo de errado. Não sai nada no arquivo de log ( /var/log/squid/access.log) mas todos os usuários estão acessando a internet normalmente. Tem um problema, a rede estar sem proxy, mas eu configurei o squid.conf como me orientaram e o firewall também estar normal, com redirecionamento da porta 80 para a 3128.

    iptables -t nat -A PREROUTING -s ! xxx.xxx.x.x/xx -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

    no squid.conf coloquei o seguinte:

    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    No browser do Rwindows não esta ativado a opção de proxy..

    O que está errado...

    Valeu






Tópicos Similares

  1. erro squid
    Por Phrix no fórum Servidores de Rede
    Respostas: 1
    Último Post: 08-10-2004, 11:17
  2. ERRO - Squid autenticando via SMB - ERRO
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 11-08-2004, 10:40
  3. ERRO - Squid autenticando via SMB - ERRO
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-04-2004, 09:18
  4. ERRO - Squid autenticando via SMB - ERRO
    Por Beto no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-03-2004, 16:10
  5. erro squid conectiva 8.0
    Por bouncer no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-08-2003, 14:21

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L