+ Responder ao Tópico



  1. #1
    Neerlan_Amorim
    Visitante

    Padrão Sarg!!

    Seguinte....
    Eu montei a conf do sarg só q nao ta montando o relatório
    sarg.conf:
    # Relatório Squid por: Dia
    language Portuguese
    access_log /var/log/squid/access.log
    title "Relatório Diário do Proxy"
    font_face Arial
    header_color darkblue
    header_bgcolor blanchedalmond
    header_font_size -1
    background_color white
    text_color black
    text_bgcolor beige
    title_color green
    temporary_dir /tmp
    output_dir /var/www/default/squid/daily
    topuser_sort_field BYTES reverse
    user_sort_field BYTES reverse
    exclude_users /etc/sarg/exclude.users
    exclude_hosts /etc/sarg/exclude.hosts
    date_format e
    lastlog 0
    remove_temp_files yes
    index yes
    overwrite_report yes
    records_without_userid ignore
    use_comma no
    topsites_num 100
    topsites_sort_order BYTES D
    exclude_codes /etc/sarg/exclude_codes
    max_elapsed 28800000
    report_typie topsites users_sites sites_users date_time denied auth_failures site_user_time_date
    long_url no
    exclude_string /etc/sarg/exclude.strings
    show_successful_message no
    topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE
    topuser_num 0
    ########

    Quando eu executo:
    [[email protected] sarg]# /usr/sbin/sarg -f /etc/sarg/sarg.conf -d 23/05/2003-23/05/2003
    SARG: Nao ha registros
    SARG: Fim

    Quando eu fui olha o arquivo access.log do squid, tinha registros

    Alguem pode me ajudar? <IMG SRC="images/forum/icons/icon27.gif">

  2. #2
    escambau
    Visitante

    Padrão Sarg!!

    verifique no squid.conf aonde que ele esta gravando os logs.



  3. #3
    Neerlan_Amorim
    Visitante

    Padrão Sarg!!

    o squid ta funcionando beleza
    os logs do squid tao em /var/log/squid
    quando entro la e abro o arquivo access.log , mostra os acessos
    Alguem ae pode ajudar? <IMG SRC="images/forum/icons/icon27.gif">

  4. #4

    Padrão Sarg!!

    tente mandar gerar de um arquivo. ou creio eu, se voce usar -d e informa a data voce ainda tem que informa o arquivo no qual ele se encontra, tente adicionar a sua execucao o parameto -l /var/log/squid/access.log