Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    dirceuBF
    Salve pessoal,

    Sistema:
    RH8;
    php-4.3.1
    httpd-2.0.45

    Ha algum tempo tenho funcionando esse sistema sem problemas. Hoje resolvi dar uma "pedalada" no meu projeto e o apache não estava interpretando o php. Após procedimentos normais (restart, reboot e outros re´s) resolvi recompilar tudo. Infelizmente sem sucesso.

    Parando para analizar, lembrei que tinha instalado java para estudá-lo. Não sei se teve alguma influência, contudo não custa fazer a referência.

    Dicas serão bem vindas. Aliás até as mais "inocentes", pois sei que estou errando em algo e pode ser besteira mesmo.

    [ ]
    Dirceu

  2. Temos que ver o seu apache.conf (antes era httpd.conf agora mudou neh ? <IMG SRC="images/forum/icons/icon_smile.gif">) verifique se tem algo do tipo

    include conf/php.conf no seu apache.conf ou as diretivas de AddModule ou LoadModule no modulo do php4 <IMG SRC="images/forum/icons/icon_smile.gif">



  3. #3
    dirceuBF
    Obrigado, mistymst.

    O http.conf (continua com esse nome) não possui um include php. Dê uma olhada neste link:
    http://www.php.net/manual/en/install.apache2.php

    Como havia dito, estava tudo funcionando direito já algum tempo. O php.ini está configurado e foi tudo instalado de forma que o php fosse um módulo dinâmico. Mas continuemos a pesquisa, por favor.
    Como sou meio pavio curto é provável que volte à instalação antiga com apache1.3.1 e php estático tudo via RPM. Fazer o que... O que não dá é parar o projeto.

    [ ]&acute;s
    Dirceu

  4. Bom...
    Vamos começar pelo básico... O que estava funcionando antes da "pedalada" ?
    Essa "pedalada" consiste em que ? Quais as mudanças que você fez ?
    Qual a última situação em que ambos funcionavam corretamente ?
    Quando instalou o Java, você recompilou o Apache ?
    No Linux, ao contrário do Ruindows, as coisas não param de funcionar espontaneamente... risos...
    Comece da última situação ok, e veja quais as mudanças...
    <IMG SRC="images/forum/icons/icon21.gif">



  5. #5
    glasswalk3r
    o php não tem que ser carregado como módulo no apache 2.0 ? o que diz o log do apache ao tentar carregar uma página em php?

    acho que vc deu um tiro no pé. eu abri a url que vc dá como referência para configuração e olha o tinha lá, bem grandão:

    "Warning
    Do not use Apache 2.0 and PHP in a production environment neither on Unix nor on Windows."

    Se eles mesmos avisam para vc não usar em sistemas em produção, pq vc tenta?






Tópicos Similares

  1. Parou de funcionar
    Por Perdigao no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-05-2004, 07:00
  2. touchpad parou de funcionar depois de atualizacao de kernel
    Por luisoft no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 26-04-2004, 08:03
  3. PROFTPD parou de pegar do nada
    Por Vaza no fórum Servidores de Rede
    Respostas: 4
    Último Post: 05-01-2004, 17:24
  4. phpnuke parou de vez
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-03-2003, 09:10
  5. Socorro - Squid parou de autenticar após atualização de paco
    Por Ganymede no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-02-2003, 13:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L