+ Responder ao Tópico



  1. #1
    Visitante

    Padrão PHP 4.3.1 não passa variáveis

    Bom dia.

    Estou com um probleminha...
    O PHP versão 4.3.1 não está passando as variáveis dos meus formulários! Estou usando o Conectiva 9. Acredito que seja problema no php.ini, mas onde?

    att.

    Marcelo Estanislau.

  2. #2
    Visitante

    Padrão PHP 4.3.1 não passa variáveis

    Instala o PHP 4.3.2 e ve se o problema continua...



  3. #3

    Padrão PHP 4.3.1 não passa variáveis

    Como você está passando as variáveis ? Por referência ou por sessão ?

  4. #4
    Visitante

    Padrão PHP 4.3.1 não passa variáveis

    Das duas maneiras.
    O Script está funcionando 100%, pois eu tinha o conectiva 8 na minha máquina. Acontece que instalei a nova versão e configurei todos os serviços. Agora o único problema é esse PHP.
    Lembrando que estou usando APACHE 2.x e PHP 4.3.1

    Marcelo Estanislau.



  5. #5

    Padrão PHP 4.3.1 não passa variáveis

    Ah, você acabou de dizer qual o problema...
    O Apache 2.0 NÃO funciona direito com o PHP.
    Instale o Apache 1.3
    <IMG SRC="images/forum/icons/icon21.gif">

  6. #6

    Padrão PHP 4.3.1 não passa variáveis

    Hehehe calma calma, eu jah usei uma 2 vezes o apache 2 e nao tive problemas com o php... verifique no php.ini o parametro
    register_globals = On
    certifique-se que ele esta On porque se estiver off voce nao vai poder receber variaveis entre formularios via GET POST ...

    ou voce pode usar tambem $_GET["var"] ou nao lembro se eh $_HTTP_GET
    mas eh isso ai, veja se o register globals esta ligado, voce pode verifificar isso tambem criando o seguinte script php.

    <?

    phpinfo();

    ?>