Galera é o seguinte!!!

Estou tendo problemas para conseguir uma versão do postgresql que se adeque ao Sagu e numa dessas tentativas de instalar, meu Slackware 9 começou a dar um erro na hora de usar o installpkg e quando tento instalar qualquer .tgz gera o erro abaixo! (Obs. É qualquer .TGZ)

[email protected]:/mnt/cdrom/slackware/a# installpkg gzip-1.3.3-i386-2.tgz
Cannot install gzip-1.3.3-i386-2.tgz: package is corrupt (failed ´gzip -l gzip-1.3.3-i386-2.tgz&acute

Será que vou ter que reinstalar meu slackware por causa disto!! <IMG SRC="images/forum/icons/icon_frown.gif">