+ Responder ao Tópico



  1. #1
    juniox
    Visitante

    Padrão Duvidas simples

    ae..., quando abro o terminal ele aparece assim:

    bash-2.05a$

    pra eu alterar, uso o comando

    PS1=´\[email protected]\h:\w$´

    porem... quando fecho e abro novamente o terminal, ele retorna como "bash-2.05a$"

    o mesmo acontece para o comando

    alias ls="ls --color=auto" , para deixar colorido os arquivos...

    como faco pra nao ter que ficar digitando esses comandos sempre que abrir o terminal ?

    valew

  2. #2
    surf3r
    Visitante

    Padrão Duvidas simples

    dae juniorx


    depende da tua distro, existem arquivos que são executados sempre que um login eh feito na máquina...

    tente colocar estes comandos no /etc/profile

    se for redhat, conectiva no /etc/bashrc (melhor)


    surf3r



  3. #3
    juniox
    Visitante

    Padrão Duvidas simples

    ae, valew.. isso funciona legal em modo texto...

    mas eu queria usar no terminal... dentro do X..

    pois quando abro o terminal, continua aparecendo da forma antiga...

    valew

  4. #4
    surf3r
    Visitante

    Padrão Duvidas simples

    dae meu amigo...

    qual distro vc tah usando?

    independente disto, siga algumas recomendações para identificar o problema:

    1. lah no terminal q esta com problema, veja o q tem na variavel PS1:
    # echo $PS1
    2. inclua no /etc/profile a linha:
    # export PS1=´\[email protected]\h:\w$´

    Se isso não funcionar, eh por que alguma linha no /etc/profile esta interrompendo a execução completa do arquivo, a maneira mais fácil eh debugar sua execução, inclua linhas com "echo alguma coisa" em várias partes do arquivo para ver onde esta parando...

    Outra coisa, veja se quando você se loga, ele não dah permissão negada... ai ele não consegue executar o profile


    surf3r



  5. #5
    juniox
    Visitante

    Padrão Duvidas simples

    ae cara... ateh funciona.. mas em modo texto... no modo terminal.. ele continua exibindo:

    bash-2.05a#

  6. #6
    surf3r
    Visitante

    Padrão Duvidas simples

    dae juniorx

    vc fez a ultima recomendação para debugar o arquivo?

    vc jah tentou executar outro terminal ? aterm, xterm, gnome-terminal , etc ?

    surf3r