Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Galera, é o seguinte, eu tenho um servidor Conectiva 8.0 rodando MySQL 3.23.46 e php4 4.1.1 perfeitamente, bom... instalei o Conectiva 9.0 com todos os pacotes que eu precisava, inclusive o novo MySQL 3.23.54 e php4 4.3.1, bom... no servidor antigo, eu rodo um script simples de INSERT e ele funciona beleza, criei o banco de dados no servidor novo, criei as tabelas tudo certinho, criei o usuario com permissão total, quando executo o script, ele da sinal de OK, mas quando vou olhar nas tabelas no MySQL, o registro foi inserido, mas os dados não foram repassados para seus respectivos campos, lembro novamente que o script deu sinal de OK... muito extranho não? o mais extranho é que eu pus um sistema PHPNUKE no mesmo servidor novo e ele esta funcionando perfeitamente... eu preciso muito dessa ajuda, enquanto não resolver isso, vou estar ocupando uma máquina a mais, que é a do servidor antigo e ela ja tem destino, agradeço a ajuda desde ja! falow feras.

  2. Se eu entendi corretamente, o processo inseriu uma linha em branco, correto ?
    Se sim, mande mostrar a linha de comando que esta sendo executada, o insert com os devidos parêmetros, pois tenho certeza que ao passar as variáveis com seus respectivos conteudos algo está se perdendo e está vindo tudo em branco.
    <IMG SRC="images/forum/icons/icon_wink.gif">



  3. Amigo, o INSERT esta assim:
    $sql = "INSERT into noticias (nome, email) values (&acute;$nome&acute;,&acute;$email&acute";

    São apenas dois campos, fiz isso apenas para testar, um campo no formulario com o nome &acute;nome&acute; e outro com o nome &acute;email&acute;, os mesmos setados na tabela do BD... estou entrando em desespero, nao vejo erro :/

    tente me ajudar, grato...!

  4. Opa, de uma olhada nisso:
    http://luiz.objetivonet.com/bd.gif



  5. faça o seguinte teste :
    na hora que for dar o execute, mande mostrar na tela o conteúdo do campo $sql via comando echo para ver o que está indo no insert.
    o conteúdo deveria ser algo como
    "INSERT into noticias (nome, email) values (&acute;Márcio&acute;, &acute;marcio68almeida@netscape.net&acute"
    se não vier assim, é por que o conteúdo das variáveis estão vazios (o que é bem provável)
    <IMG SRC="images/forum/icons/icon_smile.gif">






Tópicos Similares

  1. Problema MySQL-5.1.32 no Slackware
    Por gustavo_marcon no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-04-2009, 18:09
  2. Problemas Mysql Slack
    Por ww no fórum Servidores de Rede
    Respostas: 5
    Último Post: 04-03-2006, 13:22
  3. Problemas MYSQL
    Por Paulo Egidio no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-05-2005, 20:56
  4. Problema MySql
    Por rosauro no fórum Servidores de Rede
    Respostas: 7
    Último Post: 20-01-2004, 10:40
  5. Problemas ao conectar php com mysql
    Por Lili no fórum Servidores de Rede
    Respostas: 44
    Último Post: 12-11-2002, 09:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L