+ Responder ao Tópico



  1. #1
    lessandronp
    Visitante

    Padrão Erro ao atualizar Kernel versão 2.4.18-14 para 2.4.19

    Cara comunidade Linux,
    estou obtendo a seguinte mensagem ao compilar o kernel, já tentei até mesmo apagar a pasta do kernel, e copiar os arquivos novamente do backup para tentar recompilar e o mesmo erro vem acontecendo, olhe abaixo:


    gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2 -march=i686 -nostdinc -I /usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=iodebug -c -o iodebug.o iodebug.c
    rm -f lib.aar rcs lib.a checksum.o old-checksum.o delay.o usercopy.o getuser.o memcpy.o strstr.o dec_and_lock.o iodebug.o
    make[2]: Saindo do diretório `/usr/src/linux-2.4.19/arch/i386/lib´
    make[1]: Saindo do diretório `/usr/src/linux-2.4.19/arch/i386/lib´
    ld -m elf_i386 -T /usr/src/linux-2.4.19/arch/i386/vmlinux.lds -e stext arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o init/version.o init/do_mounts.o \ --start-group \
    arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o \
    drivers/char/char.o drivers/block/block.o drivers/misc/misc.o drivers/net/net.o drivers/media/media.o drivers/char/agp/agp.o drivers/char/drm/drm.o drivers/atm/atm.o drivers/ide/idedriver.o drivers/scsi/scsidrv.o drivers/cdrom/driver.o drivers/sound/sounddrivers.o drivers/pci/driver.o drivers/pcmcia/pcmcia.o drivers/net/pcmcia/pcmcia_net.o drivers/pnp/pnp.o drivers/video/video.o drivers/net/hamradio/hamradio.o drivers/usb/usbdrv.o drivers/md/mddev.o drivers/hotplug/vmlinux-obj.o \
    net/network.o \
    /usr/src/linux-2.4.19/arch/i386/lib/lib.a /usr/src/linux-2.4.19/lib/lib.a /usr/src/linux-2.4.19/arch/i386/lib/lib.a \
    --end-group \
    -o vmlinux
    drivers/sound/sounddrivers.o: In function `es1371_probe´:
    drivers/sound/sounddrivers.o(.text+0xa7aa): undefined reference to `gameport_register_port´
    drivers/sound/sounddrivers.o: In function `es1371_remove´:
    drivers/sound/sounddrivers.o(.text+0xabcc): undefined reference to `gameport_unregister_port´
    make: ** [vmlinux] Erro 1
    [[email protected] linux]#

    Ficarei super agradecido com a colaboração de todos, um grande abraço para toda a comunidade
    <IMG SRC="images/forum/icons/icon_smile.gif">
    Atenciosamente,
    Lessandro Notaroberto Pyrâmides

  2. #2
    Pedrinha
    Visitante

    Padrão Erro ao atualizar Kernel versão 2.4.18-14 para 2.4.19

    Amigo veja 1 se vc possui esses pacotes make, dialog, binutils, gcc e glibc-devel eles são usados para a compilação ok
    analise com o que está colocando se é exatamente para ser hardware pq se não dá pal...
    bom é só uma dica pq compilar kernel não é simples como parece as vezes flw....
    boa sorte <IMG SRC="images/forum/icons/icon_wink.gif">



  3. #3
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Erro ao atualizar Kernel versão 2.4.18-14 para 2.4.19

    De o make menuconfig (xconfig), selecione Sound, e desmarque (N) os drivers da Creative Ensoniq ES1371.

    Salve, e continue com o procedimento de compilacao

  4. #4

    Padrão Erro ao atualizar Kernel versão 2.4.18-14 para 2.4.19

    Ah, claro se voce realmente prescisa do drivers do es1317, coloque <M> que la ira compilar como modulo , ou se voce nao prescisar tire-a do kernel como falou o nosso amigo psy, tire outras coisas que voce nao prescisa tambem, quanto mais enxuto melhor.