+ Responder ao Tópico



  1. #1
    Zayfer
    Visitante

    Padrão Internet/squid/iptables sppeed

    E ai pessoal beleza!!!!

    Estou com seguinte problema tenho uma conexão speedy antiga com IP FIXO!!

    Conf O Linux para compartilhar a conexão.
    eth0=200.***.***.***
    eth1=192.168.0.100

    Na maquina linux ping na internet e tudo mais.
    Na estação pinga no IP da eth1 e no eth0
    Mas não pinga na Internet.
    E tambem não mostra nenhuma mensagem do squid no navegador

    carreguei todos os modulos do iptables

    regra de masq iptables -A POSTROROUTING -I eth0 -j MASQ

    conf estações
    ip 192.168.0.**
    Gateway 192.168.0.100
    dns os mesmos do servidor
    proxy 192.168.0.100:3128

    Ja coloquei o RED HAT 7.2 e conectiva 8 e a mesma coisa nos dois.

  2. #2
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Internet/squid/iptables sppeed

    Faca assim:

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE



  3. #3

    Padrão Internet/squid/iptables sppeed

    a sua linha esta errada, siga a dica do psy que vai funcionar legal, caso voce deseje squid como proxy transparente voce tem que redir o trafego da 80 para 3128 assim

    iptables -t nat -A PREROUTING -i eth1 --dport 80 -j REDIRECT --to 3128

  4. #4
    Zayfer
    Visitante

    Padrão Internet/squid/iptables sppeed

    IF_EXT=eth0
    $IPT -t nat -A POSTROUTING -o $IF_EXT -j MASQUERADE

    A regra que vcs me indicam já foi colocada.

    Eu tenho outro problema atualmente a conexão esta sendo compartilhada com win ME.
    A maquina Me recebe IP dinamico do modem e libera o acesso para todo Mundo.
    Tudo Beleza até ai a unica coiza ruim que um WIN mas ta funcinando.

    Com linux eu não consigo fazer o o ip dinamico o linux não consegue reber o ip do Modem.( e com win vai).

    Com linux so com ip Fixo colocado na mão mas mesmo assim acontece o problema que eu citei antes.

    O modem que estou usando E um 3COM ( so não lembro o modelo agora)

    Detalhe se ligar linux na rede para receber ip do win ele funciona beleza mas so modem que ele não recebe IP.
    Já troquei a placa e não resolveu.
    Existe um comando que força o dhcp , eu acho que dhpcd `algum parametro eth0 sei lá não lembro.

    Alguem já usou esse comando o que pode ser na minha conf que esta dando errado.