+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Transferindo usuarios

    Alguem sabe um jeito facil de transferir usuários de um micro para outro, com suas senhas e diretorios home corretamente?

  2. #2
    sergiovl
    Visitante

    Padrão Transferindo usuarios

    Aqui no trampo, usamos um servidor Conectiva 8 com o NIS e NFS, onde os usuários ficam somente no servidor e nas estações, só mapeamos o diretório home para o servidor e a autenticação do mesmo é feita somente em um lugar.
    Agora para transferir vc teria que conectar as máquina por um mapeamento em NFS ou FTP, realizar as cópias. Para os usuários vc teria que editar ma unha os arquivos "group", "gshadow", "shadow" e "passwd", pegar todos os usuários e copiar para a outra máquina.
    Espero ter ajudado.



  3. #3
    replicante
    Visitante

    Padrão Transferindo usuarios

    vc quer tipo mudar de hd? vc pode copiar a estrutura de diretorio /home e os arquivos:

    /est/passwd*
    /etc/shadow*

    imagino q possa funcionar...

    falow,


  4. #4
    RegisCwb
    Visitante

    Padrão Transferindo usuarios

    A maneira mais rápida e fácil seria vc colocar o disco do novo micro como slave no micro atual e copiar para ele os arquivos:

    /etc/passwd
    /etc/shadow

    Depois copie todo o diretório home do disco atual para dentro do diretório home do novo disco usando a opção cp -Rp que faz copia recursivas de subdiretórios e mantem as permissões e os proprietários dos arquivos.



  5. #5
    RafaelMonteiro
    Visitante

    Padrão Transferindo usuarios

    Bom pessoal agora fiquei decepcionado em saber que não existe ( ou pelo menos ninguem conhece ) uma ferramenta para migrar usuarios...
    no windows 2000 ( favor não xingar minha mãe!) temos varias ferramentas para fazer esse serviço mantendo tudo desde permissoes, memberships, senhas...

    tai uma boa oportunidade para desenvolver uma ferramenta dessas... tentei copiar aqui os dirs que vcs falaram mas em alguns usuarios perdeu-se a senha e em outros perdeu os grupos... talvez tenha sido algum problema de uid e guid não sei
    <IMG SRC="images/forum/icons/icon_wink.gif">