+ Responder ao Tópico



  1. Estou apanhando para fazer uma VPN entre SP e Santos, utilizo speedy - empresarial nas duas pontas, já desabilitei o iptables, já habilitei os protocolos 50 e 51, mas nada de funfar.
    Deixei com left SP e right Santos, quando tento inicializar por SP: ipsec auto --up spo_sts, acontece o seguinte:
    104 "spo_sts" #1: STATE_MAIN_I1: initiate
    010 "spo_sts" #1: STATE_MAIN_I1: retransmition; will wait 20s for response
    010 "spo_sts" #1: STATE_MAIN_I1: retransmition; will wait 40s for response
    .
    .
    .
    010 "spo_sts" #1: STATE_MAIN_I1: retransmition; will wait 40s for response

    E quando tento inicializar de Santos, está aparecendo a seguinte mensagem:
    022 "spo_sts": we have no ipsecN interface for either end of this connection

    Alguém poderia me ajudar? Desde já agradeço qq. ajuda,
    []s,
    <IMG SRC="images/forum/icons/icon_biggrin.gif">

  2. #2
    devlinmaxx
    Bom dia, bro... Vcee poderia passar o ipsec.conf? Pode ser que voce tenha errado na hr de colocar o interfaces=%defaultroute ou na conexao tenha esquecido de colocar o GW.
    Esse server VPN esta atras de algum servidor, ou ele ja sai pra Internet? Existe 1 roteador na frente dele, mesmo que seja da telefonica?



  3. As máquinas saem direto para internet, ou seja, os modems da telefônica estão nestas máquinas, que são os meus firewalls. Qto. ao roteador da telefônica como faço para saber se tem ou não? A seguir sec meu ipsec.conf.

    ========= inicio ===========
    # /etc/freeswan/ipsec.conf - FreeS/WAN IPsec configuration file

    # More elaborate and more varied sample configurations can be found
    # in FreeS/WAN&acute;s doc/examples file, and in the HTML documentation.

    # basic configuration
    config setup
    # THIS SETTING MUST BE CORRECT or almost nothing will work;
    # %defaultroute is okay for most simple cases.
    interfaces=%defaultroute
    # Debug-logging controls: "none" for (almost) none, "all" for lots.
    klipsdebug=none
    plutodebug=none
    # Use auto= parameters in conn descriptions to control startup actions.
    plutoload=%search
    plutostart=%search
    # Close down old connection when new one using same ID shows up.
    uniqueids=yes


    # defaults for subsequent connection descriptions
    # (these defaults will soon go away)
    conn %default
    keyingtries=0
    disablearrivalcheck=no
    authby=rsasig
    leftrsasigkey=%dnsondemand
    rightrsasigkey=%dnsondemand


    # connection description for opportunistic encryption
    # (requires KEY record in your DNS reverse map; see doc/opportunism.howto)
    conn me-to-anyone
    left=%defaultroute
    right=%opportunistic
    keylife=1h
    rekey=no
    # for initiator only OE, uncomment and uncomment this
    # after putting your key in your forward map
    #leftid=@myhostname.example.com
    # uncomment this next line to enable it
    #auto=route

    # sample VPN connection
    conn spo_sts
    type=tunnel
    leftrsasigkey=chave gerada em SP
    rightrsasigkey=chave gerada em Santos
    # Left security gateway, subnet behind it, next hop toward right.
    left=200.x.x.x # ip do server SP
    leftsubnet=
    leftnexthop=
    # Right security gateway, subnet behind it, next hop toward left.
    right=200.x.x.x # ip do server Santos
    rightsubnet=
    rightnexthop=
    # To authorize this connection, but not actually start it, at startup,
    # uncomment this.
    auto=add
    ======= fim ===========

    Abraço,

  4. #4
    devlinmaxx
    Brother, da uma olhada nas modificaçoes que eu fiz.... Pode ajudar em algo.
    cara, outra coisa: tenta gerar as chaves e coloca-las no ipsec.secrets e no ipsec.conf OK? Sabe como? melhor, cara.. MUITO melhor, pois usar as chaves do DNS pode dar uns erros e etc. Voce tem DNS?
    Geralmente o GW da telefonica e o numero do seu IP interno com final 1:
    200.187.0.23 (interno valido)
    200.187.0.1 (GW da telefonica pra voce)
    OK?

    ========= inicio ===========
    # /etc/freeswan/ipsec.conf - FreeS/WAN IPsec configuration file

    # More elaborate and more varied sample configurations can be found
    # in FreeS/WAN&acute;s doc/examples file, and in the HTML documentation.

    # basic configuration
    config setup
    # THIS SETTING MUST BE CORRECT or almost nothing will work;
    # %defaultroute is okay for most simple cases.
    interfaces=%defaultroute
    # Debug-logging controls: "none" for (almost) none, "all" for lots.
    klipsdebug=none
    plutodebug=none
    # Use auto= parameters in conn descriptions to control startup actions.
    plutoload=%search
    plutostart=%search
    # Close down old connection when new one using same ID shows up.
    uniqueids=yes


    # defaults for subsequent connection descriptions
    # (these defaults will soon go away)
    conn %default
    keyingtries=0
    disablearrivalcheck=no
    authby=rsasig
    #leftrsasigkey=%dnsondemand (Comenta isso que vc naum vai usar)
    #rightrsasigkey=%dnsondemand (E aqui)

    ------>(Comenta tudo, porque voce ainda nao vai usar)<-------
    # connection description for opportunistic encryption
    # (requires KEY record in your DNS reverse map; see doc/opportunism.howto)
    #conn me-to-anyone
    #left=%defaultroute
    #right=%opportunistic
    #keylife=1h
    #rekey=no
    # for initiator only OE, uncomment and uncomment this
    # after putting your key in your forward map
    #leftid=@myhostname.example.com
    # uncomment this next line to enable it
    #auto=route

    # sample VPN connection
    conn spo_sts
    type=tunnel
    leftrsasigkey=chave gerada em SP
    rightrsasigkey=chave gerada em Santos
    # Left security gateway, subnet behind it, next hop toward right.
    left=200.x.x.x # ip do server SP
    leftsubnet=(Bro, aqui vai o Range de IP da subnet que vc vai rotear.. Esqueceu? ex: 10.0.0.0/24
    #leftnexthop=
    # Right security gateway, subnet behind it, next hop toward left.
    right=200.x.x.x # ip do server Santos
    rightsubnet= (mesma coisa) ex: 10.1.0.0/24 (Tem de ser um range diferente do outro)
    #rightnexthop=
    # To authorize this connection, but not actually start it, at startup,
    # uncomment this.
    auto=add
    ======= fim ===========

    OK???? Tenta isso, qualquer pau me manda mensagem....
    Nao tem erro, inicialize com
    # ipsec auto --up spo_sts
    Se nao conseguir, entra por ssh no site de sts e tenta levantar por la ok?






Tópicos Similares

  1. MOUSE NAO FUNFA
    Por Fabinho no fórum Servidores de Rede
    Respostas: 12
    Último Post: 02-04-2003, 13:36
  2. PPP Não funfa
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 21-03-2003, 23:42
  3. NVIDIA GeForce 4 DDR não funfa!
    Por NoiseMaster no fórum Servidores de Rede
    Respostas: 7
    Último Post: 09-03-2003, 22:49
  4. Iptables não funfa
    Por lrezende no fórum Servidores de Rede
    Respostas: 4
    Último Post: 10-02-2003, 12:56
  5. Impressora não funciona help me!!!
    Por maacnet no fórum Servidores de Rede
    Respostas: 10
    Último Post: 06-01-2003, 19:54

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L