+ Responder ao Tópico



  1. #1
    LinuxAthos
    Olá pessoal, estou ficando louco com essa placa AC97 onboard que segundo o meu Conectiva faz parte da ALSA project. Entrei no site peguei o driver mas apanhei mto para instalá-lo, até que vi que dentro do meu cd do Conectiva havia os rpms da ALSA e os instalei, mas qndo pensei q tinha conseguido fui configurar através do comando "alsaconf" e escolhi minha placa mas na final da configuração pelo "alsaconf" parece que ele não conseguiu iniciar o alsamixer e na saida do programa ele disse que, mais o menos, que eu não tenho o hardware, que ele não foi propriamente detectado, e quando tento iniciar o alsamixer ele não consegue. Um cara me disse que trocando o meu kernel 2.4.5 pelo 2.4.21 seria a solução. Atualmente estou com o Conectiva 7, não me lembro quais foram os resultados no Conectiva 8, amas acho que foram os mesmos e me parece que o conectiva 8 usa o kernel 2.4.20 e como o sndconfig diz no 7 e deve dizer no 8, não há suporte para esse tipo de hardware, não instalei o CL9 até agora, porque não consigo finalizar a instalação do mesmo. Mas acho que um novo kernel seria o caminho mais viável, pois acho que, realmente, se eu o fizesse eu teria suporte a esse tipo de hardware (ALSA) pois me lembro que no processo de compilação dele, mais precisamente na parte em que se abre qndo digito "make menuconfig", há um lugar onde se marca as placas que se deseja ativar, e a minha constava lá. Sendo assim, a ativando, eu não precisaria do rpm do driver. Estou certo enquanto a essa última afirmação???
    Isso é tudo que quero saber, pois estou tão louco com essa placa que até penso em comprar um Creative Awe 128 PCI, mas vou deixar isso em ultimo caso.
    Alguém aí me de um mão, por favor!!! <IMG SRC="images/forum/icons/icon27.gif">

    OBRIGADO!! <IMG SRC="images/forum/icons/icon_wink.gif">

  2. #2
    LinuxAthos
    Alguém me da uma mão?



  3. #3
    voce precisa compilar o oss ... depois compilar o alsa .. na hora de funcionar o som vc da o comando soundon (do oss) entra no ~/alsa/utils
    executa o alsaconf depois da um soundoff
    digita alsasound start depois executa o rexima ou aumix pra ajustar o volume <IMG SRC="images/forum/icons/icon_smile.gif">

  4. #4
    - Opa, depois de tambem muito sofrimento consegui rodar no slack 8.1 com kernel 2.4.18 e alsa-driver-0.9.0rc2 mas acho que voce nao tera problemas com o Conectiva (altere o que for necessario).
    - No kernel, certifique-se de que o suporte de som esteja compilado como módulo (CONFIG_SOUND=m, CONFIG_SOUND_OSS=m, etc).
    - Compile os drivers para a sua placa seguindo o "Install", que acompanha o alsa-drivers. Logo apos, faca o seguinte:

    1. modprobe soundcore
    2. ./configure --with-cards=via686
    3. make install
    4. ./snddevices

    - O módulo deve ser criado em /lib/modules/2.4.18/kernel/sound/pci (snd-via686.o).
    - Se tudo ocorrer bem, adicione ao rc.modules:

    /sbin/modprobe soundcore
    /sbin/modprobe snd-via686
    /sbin/modprobe snd-pcm-oss

    - Da forma acima os modulos sempre ficarao ativos no sistema.
    - Ajuste o volume com alsa-mixer (vem junto ao pacote alsa-utils).
    - Teste com qualquer player (Ex.: o mpg123).
    Remova as entradas do rc.modules e adicione em seu /etc/modules.conf. Os modulos serao carregados somente quando forem solicitados:

    # ALSA portion
    alias char-major-116 snd

    # VIA
    alias snd-card-0 snd-via686

    # OSS/Free setup
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss

    - Se o kmod detectar acesso ao char-major-14, que eh a placa de som (/usr/src/Documentation/devices.txt), o modulo soundcore sera iniciado, e assim por diante.
    - Se ainda nao funcionar, verifique com dmesg. Provavelmente, o problema esta na configuracao do kernel. Recompile-o, recrie os modulos, e reinicie o sistema pelo novo kernel.

    Falow.
    Yam






Tópicos Similares

  1. Estou sendo invadido por favor me ajudem!!
    Por ByADM no fórum Redes
    Respostas: 5
    Último Post: 02-05-2013, 19:27
  2. Estou encucado com isso!!MSN e https:// me ajudem!
    Por HypertecNet no fórum Redes
    Respostas: 5
    Último Post: 11-04-2007, 09:07
  3. Por favor me ajudem a criar um redirect que não estou ...
    Por wellesximenes no fórum Servidores de Rede
    Respostas: 4
    Último Post: 21-06-2005, 11:22
  4. me ajudem com o Kernel 2.4.26
    Por Bravo no fórum Servidores de Rede
    Respostas: 6
    Último Post: 22-07-2004, 01:34
  5. Iniciação em Linux me ajudem!!!
    Por Raie no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 03-11-2002, 06:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L