+ Responder ao Tópico



  1. #1
    Abutre
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    Galera,
    Troquei o conectiva 8.0, pelo Red Hat 9.0 e reconfigurei o meu squid com autenticação de usuário.
    Quando a tela de logon aparece no navegador, eu coloco o usuário e a senha cadastrada no meu arquivo /etc/htpasswd, mas o mesmo nunca reconhece a senha e usuário, como se não estivesse cadastrado e não deixa eu entrar, ao menos se eu desabilitar a opção de autenticação no squid.
    alguém já teve este problema !??!
    Quem puder me ajudar, valeu mesmo !!!

    ]Abutre... <IMG SRC="images/forum/icons/icon_biggrin.gif">

  2. #2
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    Cara, tô com o mesmo problema, porem com maior gravidade:
    Configurei o squid pra liberar acesso só com o nome do usuario e senha, mas nao ta aparecendo a caixa de senha no explorer e dá acesso negado a qualquer pag.
    coloquei no squid a linha:
    auth_param basic program /etc/bin/ncsa_auth /etc/squid/squid_passwd
    e fiz as acls e nada.
    No conectiva 8 eu habilitei o authenticate_program e funcionou beleza. No red 9 mudaram a coisa e agora nao sei como fazer. Se alguem souber nos ajude.
    Valeu!



  3. #3
    muganga
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    pessoal ...tambem estou tendo esse mesmo problema....configurei o squid adicionei um usuario (htpasswd -c /etc/squid/passwd muganga)
    beleza o squid cria um usuario e eu consigo autenticar...mas quando eu restarto o squid nao funciona mais...

    valeu

    Muganga
    ICQ: 170117636

  4. #4
    Abutre
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    Anônimo,
    Troque o authenticate program, por, auth param basic program...O meu tava funcionando assim, mas quando reiniciei, não funcionou mais !!
    A minha caixa de senha aparece, mas ele não reconhece os usuários e senhas, mesmo estando cadastrados !

    Qualquer novidade, posta ae !



  5. #5

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    E aí Abutre? Blz?

    Tô pensando em mudar o meu server CL8 proxy-firewall para RH9:
    - vc teve muita dificuldade?, vc achou que o servidor ficou melhor e mais rápido?

    Também tenho uma dúvida:
    -> A configuração das placas de rede eu sei fazer; subir o squi tb......a minha dúvida é a seguinte....como eu ativo o roteamento...tipo...lá no conectiva 8 eu uso o LinuxConf e através dele coloco o meu router default e marca para habilitar o roteamento...como eu faço isto no RH9, pois eu tenho que habilitar este esquema para os users da minha rede interna enchergarem a net, certo?
    Também utilizo autenticação e como vou migrar provavelmente enfrente os mesmos problemas que vc .....se se conseguir a solução com certeza eu posto aqui...
    Obrigado!



  6. #6
    Abutre
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    Wal, se liga...
    Eu instalaei ele completo e fui desabilitando o que eu não preciso.
    Existe em /Configurações do sistema/Rede, o mesmo que o linuxconf, p/ vc mudar os endereços e tal....molezinha !
    O squid vem, rodando blz, mas tem que editar e jogar o q vc quer a mais, mas até agora, não consegui rotear meus pacotes pop e smtp.
    Será que serei obrigado a especificar o getway na estação ?!?!

    Qualquer coisa, posta ae !

    Abutre



  7. #7
    Abutre
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    Aos poucos os problemas são desvendados...
    A senha não está funcionando, pq tenho regras de proxy tranparente e isso não pode acontecer, ok ?
    Ou proxy transparente ou com autenticação.

    Falous,

    Abutre

    Ps...Nunca deixe de postar uma resposta pra um amigo, caso vc tenha ela na mente.

  8. #8
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2003-09-12 11:23, Wal wrote:
    E aí Abutre? Blz?

    Tô pensando em mudar o meu server CL8 proxy-firewall para RH9:
    - vc teve muita dificuldade?, vc achou que o servidor ficou melhor e mais rápido?

    Também tenho uma dúvida:
    -> A configuração das placas de rede eu sei fazer; subir o squi tb......a minha dúvida é a seguinte....como eu ativo o roteamento...tipo...lá no conectiva 8 eu uso o LinuxConf e através dele coloco o meu router default e marca para habilitar o roteamento...como eu faço isto no RH9, pois eu tenho que habilitar este esquema para os users da minha rede interna enchergarem a net, certo?
    Também utilizo autenticação e como vou migrar provavelmente enfrente os mesmos problemas que vc .....se se conseguir a solução com certeza eu posto aqui...
    Obrigado!



    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>

    Ae veio para adicionar o gateway faça o seguinte "route add default gw ip_do_gat dev ethx"



  9. #9
    Abutre
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    Wal, Blz ?
    Se liga...
    Eu estou tendo trabalho com o iptables, pq ainda não consegui colocar correio pros usuários atravès do proxy.
    O squid e o sarg, rodam na boa.
    Quanto a definir rotas e tudo mais, o Red Hat tem um esquema fácil na interface gráfica, além não ser difícil declarar isso tudo por linha de comando. Não lembro como faz, mas se a gente procurar um pouco, fica fácil.
    Então, o único empecílio que tô tendo, é o iptables.
    Mesmo definido as regras pela linha de comando, elas não estão tendo efeito.
    Quanto a velocidade, basta desabilitar serviços que a gente não usa e sair do modo gráfico. O kernel define isso pra gente.

    Se optar pelo Red Hat 9.0, que é uma boa escolha e vc ter mais sucesso que eu, ,posta ae, valeu ?!?!

    Abraço,

    Abutre

  10. #10
    Gnuser
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    Para você criar os usuários para se autenticarem no SQUID
    é necessário que você salve no diretório /etc/squid ?

    Mas afinal de contas... O Brasil importa ou exporta energia?
    Pergunta que não quer calar! <IMG SRC="images/forum/icons/icon_frown.gif">

    [ Esta mensagem foi editada por: Gnuser em 16-09-2003 09:37 ]



  11. #11
    TicoLima
    Visitante

    Padrão Amigos do Abutre, ajude no SQUID - Autenticação não funciona

    bom dia

    estou tendo o mesmo problema de autenticacao no rh9, e nao tenho regras de proxy transparente. alguem conseguiu algo alem desta solucao?

    para configurar na mao o gateway no rh9, altere o arquivo /etc/sysconfig/network (ha uma linha GATEWAY).

    grato