Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    guardian_metal
    Segui as dicas de: https://under-linux.org/modules.php?name=Sections&op=viewarticle&artid=96 e também li os outros artigos, meu squid.conf esta assim:

    "
    http_port 8080
    icp_port 0
    cache_mem 100 MB
    maximum_object_size 4096 KB
    cache_dir ufs /var/spool/squid 3000 16 256
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log none
    emulate_httpd_log off
    connect_timeout 120 seconds
    acl logname proxy_auth REQUIRED
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 444 447 563 7443
    acl Safe_ports port 80 21 443 444 447 563 70 210 7443 1024-65535
    acl CONNECT method CONNECT
    acl download urlpath_regex .exe$ .zip$ .arj$ .tar.gz$ .tgz$ .rpm$ .mp3$
    acl blacklist url_regex "/etc/squid/blacklist"
    acl whitelist url_regex "/etc/squid/whitelist"
    acl all src 192.168.1.1/255.255.255.0
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow all !blacklist
    http_access allow whitelist
    icp_access allow all
    miss_access allow all
    cache_mgr root@localhost
    cache_effective_user nobody
    cache_effective_group nobody
    visible_hostname localhost
    store_avg_object_size 4 KB
    "

    Quando vou ao terminal e digito "service squid start" aparece a seguinte mensagem de erro: "init_cache_dir /var/spool/squid... /etc/init.d/squid: line 162: 1629 Aborted $SQUID -z -F -D 2>/dev/null
    Starting squid: .................... [FAILED]
    "

    Como eu resolvo isso, sendo que meu squid.conf não tem linha 162?

  2. #2
    DIVORAK
    PRESTE ATENÇÃO:

    VC TEM Q CRIAR O CACHE PRIMEIRO

    # squid -z

    MODIFIQUE ESTAS LINHAS ABAIXO

    cache_effective_user squid
    cache_effective_group squi

    se der algum problema poste logo q vou ficar por aqui!



  3. #3
    Pode parecer obvio mas sempre eh bom perguntar.
    Voce gerou o cache ?
    #squid -z

    Mateus Reis

  4. #4
    guardian_metal
    Mudei as linhas conforme vc falou e digitei "squid -z" no terminal e veja o que apareceu:

    "
    2003/09/29 12:29:51| aclParseAclLine: IGNORING: Proxy Auth ACL ´acl logname proxy_auth REQUIRED´ because no authentication schemes are fully configured.
    2003/09/29 12:29:51| aclParseAclLine: IGNORING invalid ACL: acl logname proxy_auth REQUIRED
    2003/09/29 12:29:51| aclParseIpData: WARNING: Netmask masks away part of the specified IP in ´192.168.1.1/255.255.255.0´
    2003/09/29 12:29:51| Creating Swap Directories
    FATAL: Failed to make swap directory /var/spool/squid/00: (13) Permission denied
    Squid Cache (Version 2.5.STABLE1): Terminated abnormally.
    CPU Usage: 0.000 seconds = 0.000 user + 0.000 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 10
    Aborted

    "



  5. #5
    Abutre
    Guardian...
    Use o q os nossos amigos te passou, mais isso abaixo e volta a postar ae...
    Se vc usou.... acl logname proxy_auth REQUIRED, precisará tb da linha...http_acces allow
    logname, mas coloque logo abaixo de INSERT YOUR OWN RULE....
    Quanto a esta linha, tenta usar sem a máscara...acl all src 192.168.1.1/255.255.255.0, a partir da barra.
    Falous,

    Abutre






Tópicos Similares

  1. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-10-2004, 17:14
  2. Squid não Inicia
    Por elton no fórum Servidores de Rede
    Respostas: 3
    Último Post: 27-08-2004, 12:34
  3. Compilação Squid - Não inicia !!!
    Por Beto no fórum Servidores de Rede
    Respostas: 6
    Último Post: 01-06-2004, 20:35
  4. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 11-06-2003, 14:02
  5. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-06-2003, 12:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L