+ Responder ao Tópico



  1. #1
    Olá Pessoal

    Estou com o seguinte problema...
    Quando ligo o meu servidor pela primeira vez, ele reconhece as pcmcia como sendo: eth0, eth1 e eth3. Quando preciso reiniciar ele novamente, ele já passa a reconhecer as pcmcia como sendo eth0, eth3 e eth4.
    Não estou sabendo como resolver isto.
    Utilizo Slackware 9.1 kernel 2.4.22 (recompilado) com pcmcia 3.2.5 (recompilado depois do kernel) as pcmcia são Lucent Orinoco (as 3) e na máquina ainda tenho mais 2 placas de rede......

    Me ajudem
    Fabrício
    CDMnet

  2. como vc estah confurando suas interfaces???

    tipow... posta mais detalhes sobre como vc estah fazendo ae

    []´s



  3. #3
    Mr_Mind
    vim /etc/modules.conf ou o ficheiro respectivo na tua distro e diz-lh q a eth1 é o alias para X o eth2 é o alias para Y e o eth3 é o alias para Z, tipo:

    alias eth0 orinoco
    alias eth1 orinoco
    alias eth2 orinoco
    alias eth3 3c59x # placa 3Com
    alias eth4 8139too # placa Realtek

    isto faz com q carregue os modulos e a cada um que carregue atribua o device na ordem q desejas! e isto é só um exemplo ...

  4. #4
    Vai mais detalhes....

    Tenho um servidor de rádio com 3 placas pcmcia orinoco v1.0.1 (com placas adaptadoras), e 2 placas de rede 3com 3c59x tornado.
    No slackware 9.1 a sequencia de inicialização é o seguinte:
    1º executa o rc.pcmcia start
    2º executar o rc.inet1
    ---
    Para configurar os ips das pcmcia e das placas de rede eu configuro o rc.inet1.conf (novidade no slack). E para configurar os ESSID das pcmcia utilizo o arquivo chamado /etc/pcmcia/wireless.opt, onde travo os ESSID e NICKNAME pelo mac address da pcmcia....
    Quando eu tinha somente 2 pcmcia o slack reconhecia a 1º pcmcia como sendo eth0 e a segunda como sendo eth1. Até ai tudo bem. E as outras 2 placas de rede como sendo eth2 e eth3... sem problemas até ai...
    Bom, aconteceu o seguinte....
    Adicionei mais uma pcmcia no slack e ele na 1º que liguei a máquina ele reconheceu as pcmcia como sendo eth0, eth1 e eth2. Até agora continua tudo bem, e as outras 2 placas de rede como sendo eth3 e eth4.
    Configuei o script rc.inet1.conf e wireless.opts.
    Reiniei a máquina e o reconhecimento ficou como estava, primeiro as pcmcia depois as placas de rede. Mas como sou desconfiado reiniciei a máquina pela terceira vez. E neste momento as pcmcia mudaram de ordem com as placas de rede.
    As pcmcia ficaram sendo eth0, eth3 eth4, e as placas de rede como sendo eth1 e eth2...
    Pronto danou-se tudo, pois os ips ficaram errado. E agora sempre que a máquina reinicia, ou preciso ajustar alguma configuração que precisa reiniciar o pcmcia ele mudar a ordem.
    No meu scrip rc.pcmcia o parâmetro pcic=i82365
    O kernel que estou utilizando é o 2.4.22 recompilado com o patch-o-matic do netfilter ( pois precisava dos módulos h323 e mms no meu servidor para deixar passar netmeeting com audio e video...)
    Nesta recompilação também desabilitei a opção de PCMCIA em General options para que quando eu recompilar os pcmcia-cs (3.2.5) ele compilasse todos os módulos que eu precisava......
    Acho que é isso....
    Qualquer outra informação é só pedir...

    Fabrício CDMNET






Tópicos Similares

  1. ping, que dor de cabeça...
    Por bola25a2008 no fórum Redes
    Respostas: 6
    Último Post: 19-06-2009, 23:43
  2. CPE ...dor de cabeça...mais tem que passar
    Por tuxbrasil no fórum Redes
    Respostas: 10
    Último Post: 05-10-2006, 20:54
  3. disquete dor de cabeca no red hat 8.0
    Por aspenbr no fórum Servidores de Rede
    Respostas: 3
    Último Post: 25-04-2003, 08:22
  4. Dor de Cabeça Com Php - Nuke
    Por hyperblade no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 31-03-2003, 15:35
  5. DNS é uma dor de cabeça!!
    Por Jhones no fórum Servidores de Rede
    Respostas: 4
    Último Post: 27-07-2002, 19:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L