Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Caros colegas!

    Tenho um servidor CL8 rodando firewall/proxy e hoje de manha simplesmente o serviço de proxy parou de funcionar; já verifiquei que o link está funcionado; nenhuma alteração foi feita nas configurações do servidor;verifiquei o seguinte:

    1)O cache está ok; ainda tem bastante espaço para armazenamento;
    2)A partição de /var/log/squid também tem bastante espaço para armazenar os meus access.log;
    3)Quando dou o comando:
    #service squid status (ele me retorna a seguinte mensagem)
    squid inativo mas seus subdiretorios trancados

    4)verifiquei o conteúdo do arquivo /var/log/messages e achei as seguintes mensagens lá sobre o squid:

    Oct 31 13:45:29 colpmc70 rc: Iniciando webmin: succeeded
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process 1163 started
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process 1163 exited due to signal 25
    Oct 31 13:45:34 colpmc70 squid[1053]: Squid Parent: child process 1171 started
    Oct 31 13:45:35 colpmc70 squid[1053]: Squid Parent: child process 1171 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process 1179 started
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process 1179 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Exiting due to repeated, frequent failures


    Alguém pode já viu este erro?
    Por favor alguém tem uma dica do que eu posso fazer para achar o erro?

    Obrigado turma!

    Abraços.

  2. #2
    beastie


    você tem certeza de que o user admin do squid (squid ou proxy no conectiva) tem os respectivos direitos nos diretórios que ele precisa? como o /var/log/squid e o /var/cache/squid ???



  3. Sim!

    tenho certeza!

    vou continuar a fuçar aqui e se eu conseguir a solução posta aqui no forúm!

    Obrigado.

  4. SOLUÇÃO PARA O PROBLEMA ABAIXO:
    ---------------->
    Caros colegas!

    Tenho um servidor CL8 rodando firewall/proxy e hoje de manha
    simplesmente o serviço de proxy parou de funcionar; já verifiquei que
    o link está funcionado; nenhuma alteração foi feita nas configurações
    do servidor;verifiquei o seguinte:

    1)O cache está ok; ainda tem bastante espaço para armazenamento;
    2)A partição de /var/log/squid também tem bastante espaço para
    armazenar os meus access.log;
    3)Quando dou o comando:
    #service squid status (ele me retorna a seguinte mensagem)
    squid inativo mas seus subdiretorios trancados

    4)verifiquei o conteúdo do arquivo /var/log/messages e achei as
    seguintes mensagens lá sobre o squid:

    Oct 31 13:45:29 colpmc70 rc: Iniciando webmin: succeeded
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process
    1163 started
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process
    1163 exited due to signal 25
    Oct 31 13:45:34 colpmc70 squid[1053]: Squid Parent: child process
    1171 started
    Oct 31 13:45:35 colpmc70 squid[1053]: Squid Parent: child process
    1171 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process
    1179 started
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process
    1179 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Exiting due to repeated,
    frequent failures


    Alguém pode já viu este erro?
    Por favor alguém tem uma dica do que eu posso fazer para achar o erro?

    Obrigado turma!

    Abraços.
    ---------------------------------------------------------->

    Solução:

    Verifique então o seguinte:
    abri outra tty e digitei:
    #top
    verifiquei que o comando vi estava utilizando 75% de processador e tb muita memória.

    finalizei o comando vi com #kill -9 <pid>

    Daí veriquei que o arquivo estava com mais de 2.0Gb.

    Exlui o mesmo, recriei um em branco, dei as permissões corretas e iniciei o serviço de proxy, daí tudo tá funcionando.

    VALEU COLEGAS!!

    É POR ISSO QUE ESTOU NESTA COMUNIDADE "LINUX"

    <IMG SRC="images/forum/icons/icon_smile.gif">



  5. #5
    replicante
    Wal,

    aqui no meu servidor eu criei um script para ele limpar esse arquivo diariamente (logo apos fazer o relatorio com o sarg).. ae vc adiciona no crontab e já era... <IMG SRC="images/forum/icons/icon_smile.gif">

    falow,






Tópicos Similares

  1. Squid com problemas
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 18-09-2005, 14:23
  2. squid com problema
    Por zeusguiga no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-07-2005, 12:54
  3. squid com problemas!!!
    Por rcar no fórum Servidores de Rede
    Respostas: 13
    Último Post: 20-04-2005, 19:17
  4. squid com problemas
    Por ocire no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-05-2004, 14:13
  5. PROXY, SQUID COM RELATORIO POR SETOR
    Por copynow no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-02-2004, 07:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L