+ Responder ao Tópico



  1. #1
    jamba
    Visitante

    Padrão authentication failed for user "postgres"

    Boa tarde underlinux;

    hj pela manha tive problemas com meu postgresql e precisei reinstalar
    de novo incluindo alguns pacotes a mais. Agora o problema eh quando dou
    o comando ´psql -U postgres template1´ acusa o erro abaixo.

    psql: FATAL 1: IDENT authentication failed for user "postgres"

    PQ??? nao tem senha estou logado como usuario, mas do um su - root e logo apos su - postgres
    entro no prompt od postgres mas nada acontece qdo ao comando acima citado.


    VALEU.
    <IMG SRC="images/forum/icons/icon21.gif">

  2. #2
    mueller
    Visitante

    Padrão authentication failed for user "postgres"

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    o comando &acute;psql -U postgres template1&acute; acusa o erro abaixo.

    psql: FATAL 1: IDENT authentication failed for user "postgres"
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>
    o correto não seria &acute;psql -U postgres -d template1&acute; ?

    caso o erro continue, de uma olhada em seu arquivo pg_hba.conf

    abraços



  3. #3
    jamba
    Visitante

    Padrão authentication failed for user "postgres"


    Meu pg_hba.conf esta assim:

    local all ident password
    localhost all ip_maquina password

    Se no lugar de password eu colocar sameuser consigo entrar no template1 ou qq outro banco ja criado, porem c mudo para md5, trust ou password continua no mesmo erro e mesmo com a opcao -d template1, ainda acusa o erro.

  4. #4

    Padrão authentication failed for user "postgres"

    Será que o problema que você teve com o postgres não afetou a tabela onde ele guardava a senha dos usuários????




  5. #5
    mueller
    Visitante

    Padrão authentication failed for user "postgres"

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    Meu pg_hba.conf esta assim:

    local all ident password
    localhost all ip_maquina password
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>

    tente criar algum usuario no postgres, e setar a senha dele, ou alterar a senha do usuario postgres (no banco, e nao no linux)
    talvez seja isso...

    abraços