+ Responder ao Tópico



  1. Galera...eu di novo!!!

    Nossa quanta coisa tá acontecendo estes dias. É porque to migrando um server (DNS/APACHE/FTP) da minha intranet para Slackware! To saindo de vez da RH. Ainda tenho um firewall no CL8 e tb vou migrar, mas isto fica pra depois.
    Bom vamos lá, olha que estranho:
    - localmente todas as teclas do teclado funcionam corretamente ;
    - agora via ssh as teclas insert e delete não fucionam, fica impossível editar alguma coisa pelo vi!
    Help-me!
    1) Tenho que adicionar alguma configuração a mais pro teclado rolar direitinho?
    2) alguém sabe me dar algumas dicas se eu realmente não conseguir utilizar a teclas insert e delete; tipo como eu faço isso no vi [inserir e deletar] palavras; tentei com as teclas "d" e "i" mas com a "d" não me dei muito bem....he..he..teclava uma vez e nada, teclava duas me apagava a linha inteira.

    Obrigado pelas dicas!
    Abraços.

  2. Eu enfrentei problema semelhante, ainda mais que depois de entrar pelo ssh apartir de um cliente windows (putty.exe) , no linux ainda disparava o minicom e entrava em um outro sistema unix (via serial como terminal burro) e nisso notei que mudava muita coisa... a solucao para o outro sistema unix foi remapear as teclas usando programa de configuracao proprio dele (tcap, no qnx 2.2).

    Mas, no caso do linux, quem sabe nao bastaria vc dar uma verificada nos layouts de teclado e linguagem utilizados no cliente e no server , e talves editar algo no .profile do usuario...???



  3. RoninDarkTemplar!!

    é exatamente isso..estou de um cliente Window$ utilizando o putty.exe.
    Depois vou dar uma olhada nisso; achei um manual do vi e estou me virando, tenho que terminar um server o mais rápido possível, depois volto pra fuçar nisto.

    Obrigado.


  4. #4
    Tente verificar o valor da variável TERM quando estiver na sessão SSH,
    dando um echo $TERM, se for linux, tente colocar xterm: export TERM=xterm
    Pode ser isso... eh um chute...
    Tente também copiar o arquivo /usr/share/vim/6.0/vmrc_example
    (acho que o path está correto) para o seu diretório $HOME,
    com o nome de .vimrc
    E o vi do slackware é o elvis, um editor tosco <IMG SRC="images/forum/icons/icon_razz.gif"> e não o vim,
    então, crie um alias para o comando vi chamar o vim. <IMG SRC="images/forum/icons/icon_wink.gif">

    []´s
    Espero ter ajudado
    Odair Beraldo Nunes






Tópicos Similares

  1. adsl via dhcp no slackware 10.2
    Por lucasrs no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-05-2006, 17:21
  2. SATA VIA VT8237 E RAID VT6410 no Slackware 10
    Por marcfee no fórum Sistemas Operacionais
    Respostas: 4
    Último Post: 10-08-2004, 07:25
  3. RAID via softaware no SLACKWARE 10
    Por marcfee no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-08-2004, 10:14
  4. Via ac 97 no slackware 9,1
    Por foxhound171 no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 08-04-2004, 11:10
  5. eth1 no Slackware
    Por Wins no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-09-2002, 11:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L