Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    estanisgeyer
    Boa tarde amigos...

    Estou compilando o kernel 2.6, já testei em duas máquinas e sempre o mesmo erro. Quero compilar ele com não built-in, mas com a maioria em módulo. Então faço:

    make mrproper
    make menuconfig (configure o kernel da melhor maneira para mim)
    make clean
    make bzImage
    make modules
    make modules_install

    Aqui é que mora o problema. No "make modules_install´, quando ele entra no stage 2 (que é o depmod -a", muitos módulos, ou praticamente todos, aparecem com erro!

    depmod: *** Unresolved symbols in /lib/modules/2.6.0/kernel/xxxx/xxxx/xxxx.ko

    []´s

    Marcelo Estanislau.

  2. #2
    estanisgeyer
    Bom dia, pessoal!!
    Será que ninguém compilou o novo kernel com módulos?
    Não gostaria de built-in, mas acho que vai ser meu caminho....
    Alguém tem uma dica de como posso resolver?

    Att.

    Marcelo Estanislau.



  3. #3
    HunTer
    Falai kamarada . . .

    Eu nunca usei o make mrproper, eu sempre fiz assim

    eu carrego o .config do kernel anterior no kernel novo e acrescento o q tem q acrescentar e tiro o q não vou usar

    make menuconfig
    make dep
    make bzImage
    make modules
    make modules_install

    espero ter ajudado

    té +

  4. #4
    estanisgeyer
    Bom dia, amigo.

    O make mrproper serve para limpar qualquer configuração anterior do kernel. Os comandos que vc mencionou são os mesmos passos que o meu, porém vc já compilou o kernel 2.6 com suporte a módulos? (Nada de built-in). Vc verá que irá gerar esse erro que coloquei acima. Já testei em um Conectiva 9 e no Red Hat 9.

    []'s

    Marcelo Estanislau.



  5. eh, make mrproper ou make clean..

    Ao que me parece o erro é no arquivo do modulo (.o), remove ele da config. do kernel e tenta compilar denovo






Tópicos Similares

  1. Resolvido problemas com módulos no kernel 2.6
    Por estanisgeyer no fórum Servidores de Rede
    Respostas: 7
    Último Post: 20-04-2006, 00:51
  2. problemas com módulo no debian
    Por stumm no fórum Servidores de Rede
    Respostas: 11
    Último Post: 07-03-2005, 13:55
  3. Problema com USB no Kernel 2.6.x
    Por guardian_metal no fórum Servidores de Rede
    Respostas: 0
    Último Post: 02-02-2005, 16:24
  4. problemas com dhcp no redhat 8
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-04-2003, 07:17
  5. Problemas com mouse no KDE
    Por Francisco no fórum Servidores de Rede
    Respostas: 12
    Último Post: 14-11-2002, 11:49

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L