Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    estanisgeyer
    Bom dia, pessoal....
    Resolvido a bronca da compilação dos módulos, que postei nesse fórum alguns dias atrás.

    O problema, realmente, é com o pacote modules-init-tools. Para quem usa Conectiva, Red Hat e assemelhados, terá que fazer a atualização deste pacote para uma versão mais nova. Estou usando o 3.0.

    baixe o pacote de ftp://ftp.kernel.org/pub/linux/kerne...rusty/modules/
    Descompacte o pacote.
    Entre no diretório do pacote descompactado e gere os comandos:

    ./configure --prefix=/
    make moveold
    make
    make install

    Esse paocote possui os novos comandos modprobe, lsmod, rmmod, etc. A estrutura de dependência de módulos mudou no kernel 2.6. O arquivo que gera a dependência é o /etc/modprobe.conf e não mais o /etc/modules.conf. Para "traduzir" seu modules.conf atual para o novo modprobe.conf, faça:

    ./generate-modprobe.conf /etc/modprobe.conf

    Agora sim, é só seguir os passos básicos para compilação do kernel:

    make mrproper (para iniciar uma configuração do zero);
    make menuconfig
    make clean
    make bzImage (após, copiar a imagem para /boot)
    make modules
    make modules_install
    mkinitrd /boot/initrd-2.6.0.img 2.6.0

    Após, configure o grub ou lilo.

    Att.

    Marcelo Estanislau Geyer.

  2. foi esse arquivo q vc instalou??

    module-init-tools-testsuite-3.0-pre1.tar.gz

    tem uma par lá... mas o único q tem 3.0 é esse... mas como ta o testsuite fiquei na duvida



  3. #3
    estanisgeyer
    Este mesmo. Usei este.

    []'s

    Marcelo Estanislau.

  4. Ótimo, parabéns cara, resolveu o problema de muitos :]



  5. #5
    estanisgeyer
    Obrigado, psy...
    Faço o possível para contribuir para a comunidade linux, que de uma forma ou de outra, me ajudou nos meus problemas.
    Todos da Underlinux está de parabéns.

    []'s

    Marcelo Estanislau.






Tópicos Similares

  1. problemas com módulo no debian
    Por stumm no fórum Servidores de Rede
    Respostas: 11
    Último Post: 07-03-2005, 13:55
  2. Problema com USB no Kernel 2.6.x
    Por guardian_metal no fórum Servidores de Rede
    Respostas: 0
    Último Post: 02-02-2005, 16:24
  3. Problemas com módulos no Kernel 2.6
    Por estanisgeyer no fórum Servidores de Rede
    Respostas: 8
    Último Post: 23-12-2003, 07:57
  4. problemas com dhcp no redhat 8
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-04-2003, 07:17
  5. Problemas com mouse no KDE
    Por Francisco no fórum Servidores de Rede
    Respostas: 12
    Último Post: 14-11-2002, 11:49

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L