+ Responder ao Tópico



  1. #1
    Lamss
    Visitante

    Padrão Wireless Dwl 520+

    Placa Dwl 520+

    Compilei e configurei o firmware no kernel 2.4.22 Fedora Core dessa placa D-Link520+ p/ acesso a um provedor internet blz!!!
    Porém quando digito www.google.com.br ou qualquer outro site, não navega!

    Já fiz:
    # route add default eth1 (a rota é adicionada mas não abre paginas. E a luz da placa pisca qualdo tento abrir alguma página)


    #iwconfig

    eth1 IEEE 802.11b+ ESSID:"PORTAL" Nickname:"acx100 v0.2.0pre6"
    Mode:Manager Channel:11 Cell: 6F:A1:EC:9R4:09
    Bit Rate=11Mb/s Tx-Power:20 dBm
    Retry min limit:5
    Encryption keyff
    * Link Quality:79/100 Signal level:21/100 Noise level:21/100
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    * linha Link indica que esta recebendo sinal da antena.

    Quando faço:

    #ifconfig eth1

    Retorna

    eth1 Encapsulamento do Link: Ethernet Endereço de HW 0A:10:G8:R2:B0:2D
    inet end.: 10.0.0.203 Bcast:10.0.0.255 Masc:255.255.255.0
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    * RX packets:0 errors:9 dropped:0 overruns:0 frame:0
    TX packets:2 errors:2 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:84 (84.0 b)
    IRQ:10 Endereço de E/S:0x9800


    * Linha RX packets:0 errors:9
    TX packets:2 errors:2

    Que será isso?
    O que estafaltando ainda? aguém pode me dá uma luz?
    Obrigado pela atenção...[/b]

  2. #2
    J_P
    Visitante

    Padrão Wireless Dwl 520+

    Seu dns tah correto ?

    veja num traceroute p um ip externo e v onde para...

    se dns e rota estao corretos pode ser q vc esteja ainda blokeado no seu ISP..


    falow



  3. #3
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Wireless Dwl 520+

    E seu IP eh esse mesmo?

  4. #4
    Lamss
    Visitante

    Padrão Respostas

    Parece mentira mas o ip que o provedor liberou é esse mesmo ops:

    Estou navegando com o Win2k Blz!, só que preciso mudar para linux !

    Outros detalhes com o iwconfig aparece configurações erradas não sei de onde são essas informações vou comentar:

    #iwconfig
    eth1 IEEE 802.11b+ ESSID:"PORTAL" Nickname:"server.intranet"
    Mode:Ad-Hoc Channel:11 Cell: 41:41:09:73:31:EC
    Bit Rate:11Mb/s Tx-Power:20 dBm
    Retry min limit:5
    Encryption keyff
    Link Quality:94/100 Signal level:22/100 Noise level:6/100
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    * ESSID:"PORTAL" (Esse igual do win2k)
    * Nickname:"server.intranet" (não sei se influi em alguma coisa, não sei onde mudar no linux)
    * Mode:Ad-Hoc (No win2k esta assim "wireless mode=Infrastructure)
    * Channel:11 (Esse igual do win2k)
    * Cell:41:41:09:73:31:EC (O endereço MAC do provedor não é esse. sempre mudam esses numeros)
    * Bit Rate:11Mb/s (no win2k Tx rate=11Mbps)
    * Tx-Power:20 dBm (no win2k Power mode=Continuous Access Mode)
    * Link Quality:94/100 Signal level:22/100 Noise level:6/100 (pelo menos indica que esta recebendo sinal da antena)

    Obrigado pela atenção!
    Lamss



  5. #5

    Padrão Wireless Dwl 520+

    Seu DNS esta ativo
    vc consegue pingar endereços
    tenta pingar 200.204.0.10 DNS Telefonica, ou qualquer outro IP real que conheça.


    Dê um service named restart
    vê se seu DNS esta correto

  6. #6
    lamss
    Visitante

    Padrão Resposta

    Só consigo pingar no meu ip 10.0.0.203.
    :?
    Tem alguma ferramente no linux, modo shell mesmo, que eu possa ver as torres de transmissão, como eu vejo no windows no programa da Placa Dwl-520+. Por exemplo:

    BSS/IBSSD SSID WEP AP Channel Strength
    00:02:78:E4:76:61 PORTAL No Yes 11 50
    02:65:R4:U9:65:00 BIPBIP No Yes 11 43

    Lamss



  7. #7
    Visitante

    Padrão Wireless Dwl 520+

    Se vc não consegue pingar nenhum IP externo, tentar rever a sua configuração de rotas
    - Verifique o Gateway que esta usando
    - O dns esta ativo;
    - Se você não conseguir pingar um endereço Ip externo provavelmente não ira navegar a não ser que tenha uma regra de firewall que bloqueie os pings.
    Qual a distro que vc usa,

    bom de um comando
    route -n
    (Verifique as rotas ativas)

    Depois de um service dns start

    Se estiver tudo certo com as rotas e o DNS, o seu problema esta em parte física, comunicação com a a Antena, ou o suporte do seu kernel para a placa que esta usando

    Detalhe mais o que vc tem ai, para que outras pessoas tb possam te ajudar.

  8. #8

    Padrão Wireless Dwl 520+

    Se vc não consegue pingar nenhum IP externo, tentar rever a sua configuração de rotas
    - Verifique o Gateway que esta usando
    - O dns esta ativo;
    - Se você não conseguir pingar um endereço Ip externo provavelmente não ira navegar a não ser que tenha uma regra de firewall que bloqueie os pings.
    Qual a distro que vc usa,

    bom de um comando
    route -n
    (Verifique as rotas ativas)

    Depois de um service dns start

    Se estiver tudo certo com as rotas e o DNS, o seu problema esta em parte física, comunicação com a a Antena, ou o suporte do seu kernel para a placa que esta usando

    Detalhe mais o que vc tem ai, para que outras pessoas tb possam te ajudar.
    Tinha esquecido de logar!



  9. #9
    lamss
    Visitante

    Padrão DWL 520+

    Fiz o seguinte:
    #route add default eth1

    depois

    # ping 200.254.175.130 (dns de um provedor)
    PING 200.254.175.130 (200.254.175.130) 56(84) bytes of data.
    From 10.0.0.203 icmp_seq=0 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=1 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=2 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=3 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=4 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=5 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=6 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=7 Destination Host Unreachable
    From 10.0.0.203 icmp_seq=8 Destination Host Unreachable

    --- 200.254.175.130 ping statistics ---
    10 packets transmitted, 0 received, +9 errors, 100% packet loss, time 9023ms
    , pipe 4

    Obrigado!
    Lamss

  10. #10
    Lamss
    Visitante

    Padrão Dwl 520+

    Minha distro é Fedora Core 1

    Minha configuração esta assim:
    /etc/sysconfig/network-script/ifcfg-eth1

    ONBOOT=yes
    DEVICE=eth1
    TYPE=Wireless
    USERCTL=yes
    PEERDNS=no
    GATEWAY=192.168.0.1
    BOOTPROTO=dhcp
    NETMASK=255.255.255.0
    IPADDR=10.0.0.203
    NETWORK=192.168.5.0
    BROADCAST=192.168.0.255
    WIRELESS=yes
    ESSID=PORTAL
    MODE=2
    DOMAIN=
    HWADDR=
    DHCP_HOSTNAME=
    KEY=
    RATE=11M
    CHANNEL=11

    Quando em modo shell faço:

    #network restart
    Desligando interface .... eth0 [ok]
    Desligando interface .... eth1 [ok]
    .... parametros de rede [ok]
    Iniciando interface eth0: [ok]
    Iniciando interface eth1: changing radio power level to 255 dbm (0xce)
    d11Completescan: matching station found (idx0), joing (00:02:78:E4:76:61)
    Sending association request, awaiting response! not associated yet.
    ASSOCIATED!

    Lamss



  11. #11
    Alguem se Abilita
    Visitante

    Padrão Dwl 520+

    Que sufoco... é ano novo!!!
    Espero que nesse ano novo tenhamos uma solução...!!!
    Feliz ano Novo para todos!!! :lol:

  12. #12
    SerAntSou
    Visitante

    Padrão DL520+

    Amigo,

    pelo que vi acima existe erros na sua configuração do driver acx100. No windows ele consegue reconhecer a rede do seu ISP pq tem o programinha da placa gerenciando tudo. Vc tem que configurar sua placa para mode = Managed e verificar se o ISP tah usando criptografia e se for o caso usar tb no seu script. O nickname nao tem nada a ver (meio que enfeite) mas se quiser usar eh soh digitar: iwconfig wlanX nickname NICK. Para mudar seu essid digite iwconfig wlanX essid SEUESSID mode managed.
    Caso não consiga me envie um e-mail: [email protected]

    Sergio



  13. #13
    Lamss
    Visitante

    Padrão Ufa sufoco pelo menos uma luz no fim do tunel...!!!

    Hoje finalmente estou navegando no Linux, "Que maravilha" :lol: .

    Estou só com alguma dúvidas é que quando digito:
    #iwconfig eth1 channel 11 mode Manager essid PORTAL nickname amss txpower auto

    O script não pega diretamente o endereço MAC do provedor pega de outros até que fico executando e pega o correto tem alguma maneira desse script pegar o correto sem que eu fique executando várias vezes?

    Sim, sem esquecer de contar o que eu fiz para ter acesso fiz o seguinte:
    #route add default eth1 # Só isso ainda não funciona
    #route add default gw 200.254.175.210 # agora sim funciona.

    Agradeço a colaboração de todos!
    Lamss

  14. #14
    was
    Visitante

    Padrão Driver

    Lamss,

    Q bom q conseguiu :-)
    Qual driver pra 520+ vc ta usando ?! Tem como me passar o link !?

    Abraco,
    -- was