+ Responder ao Tópico



  1. #1
    MRovari
    Visitante

    Padrão Problemas com drbd.conf

    Boa Tarde Pessoal,
    Estou com um problema, ficaria muito grato se alguém pudesse me dar uma mão...
    Meu drbd.conf encontra-se assim:
    ========
    resource drbd0 {
    protocol=B
    fsck-cmd=fsck.ext2 -p -y
    disk {
    do-panic
    disk-size=4096543
    }

    on slack1 {
    device=/dev/nb0 disk=/dev/hda2
    disk=/dev/hda2
    address=10.0.0.10
    port=7789
    }

    on slack2 {
    device=/dev/nb0
    disk=/dev/hda2
    address=10.0.0.20
    port=7789
    }
    }
    ========
    O script está idêntico nos 2 nodos.
    No entanto, quando executo /etc/rc.d/drbd start, aparecem as seguintes mensagens:

    [email protected]:/etc# rc.d/drbd start
    drbd: pre-parsed needs update, parsing /etc/drbd.conf
    ...

    last token read from </etc/drbd.conf> was
    3: fsck-cmd=fsck.ext2 -p -y
    ^^^^^^^^^^^^^^^^^^^^^^^^
    resource 'drbd': unknown option 'fsck-cmd'
    stopped at rc.d/drbd (parse_resource_section) line 758.

    CVSID Id: drbd,v 1.44 2003/09/30 11:37:50 phil Exp
    BASH_VERSINFO (2 05b 0 1 release i486-slackware-linux-gnu)

    If you feel this script is buggy, please report to
    Lars Ellenberg <[email protected]>, [email protected]

    [email protected]:/etc#

    Estou usando Slackware 9.1 K2.4.22 e drbd 0.6.8

    Agradeço desde já...
    Abraço
    Marco Aurelio

  2. #2
    visitante
    Visitante

    Padrão cluster - drbd

    cara, dá uma olhada no teu drbd.conf no nodo slack1 a tua linha tá listando duas vezes o parâmetro disk=/dev/hda2, também recomendo antes de inicar o drbd, tenta usar primeiro o drbdsetup, antes carregando o módulo drbd com #modprobe drbd dá uma olhada nas man pages do drbdsetup que tem um exemplo para inciar manualmente o cluster.....fica mais fácil de achar o bug.