+ Responder ao Tópico



  1. #1

    Padrão Problema MySql

    Pessoal estamos com problema na hora da conexão ao banco de dados mysql !! o erro q dá é o seguinte ?
    Fatal error: Call to undefined function: mysql_connect()
    nós usamos a função mysql_connect
    já tentei usar a função mysql_pconnect e o erro é o mesmo....

    alguém pode me dar uma luz ?

  2. #2

    Padrão Problema MySql

    a funcao nao existe ....

    qual distro voce esta usando? voce compilou ou instalou pacotes??


    supondo que voce tem Conectva ou Debian

    # apt-get install php4-mysql

    deve resolver seu problema.



  3. #3

    Padrão Problema MySql

    eh verdade cara....se vc instalo ele compilando...vc deve ter colocado --without-mysql ou nao ter colocado o --with-mysql, se vc instalo por pacotes, ta faltando o pacote do mysql :wink:

  4. #4
    Visitante

    Padrão Problema MySql

    eu uso o Red Hat 7.3, e instalei.. pelo RPM q vem no Cd do RedHat !!
    e depois atualizei para a versão 4 pelo RPM mas tb dá a mesma coisa !!
    o q eu poderia fazer para resolver ??



  5. #5

    Padrão Problema MySql

    E ai pessoal.. eu uso o Red Hat...
    eu eu teria de reinstalar/atualizar ?? mas tenho de atualizar o PHP ou o MYSQL ???

    Rosauro

  6. #6

    Padrão Problema MySql

    Citação Postado originalmente por Anonymous
    eu uso o Red Hat 7.3, e instalei.. pelo RPM q vem no Cd do RedHat !!
    e depois atualizei para a versão 4 pelo RPM mas tb dá a mesma coisa !!
    o q eu poderia fazer para resolver ??
    eu nao intendi o que vc quiz dizer, mas eu te recomendaria baixar o fonte do php e instalar assim:

    $ ./configure --with-mysql
    $ make
    $ su
    # make install

    :wink: ai eu acho q vai....



  7. #7

    Padrão Problema MySql

    amigos, baixei o php php-4.3.4 no arquivo TAR.Gz fiz exatamente o q foi dito acima .. ele instalo tudo normal.. mas não funcionou o erro continua o mesmo....

    Rosauro

  8. #8
    Mr_Mind
    Visitante

    Padrão Problema MySql

    já tentaste fazer um netstat -ant e ver que serviços tens a correr? ou mesmo um nmap localhost?
    possivelmente NEM configuraste o teu MySQL para correr numa socket TCP ... por isso deve estar a correr numa unix e o PHP não consegue ligação.
    e o engraçado é que já respondi umas dezenas d vezs a este problema neste fórum :<