+ Responder ao Tópico



  1. #1
    Zephirot
    galera... eu d novo....
    eu já configurei o meu squid d acordo com um howto q eu peguei no
    vivaolinux.com.br e o linuxit.com.br ...
    o meu squid me deixa navegar normalmente quando eu não deixo habilitado a
    opção "authenticate_program /etc/squid/ncsa_auth", mas quando eu habilito
    ele pede autenticação, não me deixa navegar e só da as seguintes msgs de
    erro:

    1075128992.890 4 192.168.1.37 TCP_DENIED/407 1452 GET
    http://www.linuxbsd.com.br/ - NONE/- -
    1075129008.668 4124 192.168.1.37 TCP_MISS/200 265 GET
    http://216.239.51.104/search? michel DIRECT/216.239.51.104 text/html

    alguém sabe oq acontece?

    PS:
    a versão do meu squid é a 2.4 e as linhas q estão habilitadas são:

    authenticate_program /etc/squid/ncsa_auth /etc/squid/pwsquid
    authenticate_children 2

  2. #2
    Abutre

    authenticate_program /diretório do autenticador
    acl password proxy_auth REQUIRED
    http_access allow password

    Acrescente mais estas, mas no local certo...
    Qualquer coisa volta ae...

    Abutre



  3. #3
    Zephirot
    funcionou... eu mudei o nome da acl que estava em maisculo para minisculo... e funfo tudo....


    mas sempre que eu autentico ele primeiro da uma tela de pagina não encontrada e depois se eu apertar F5 ele navega normal...

    e tb to tentando fazer ele pedir a tela de autenticaçào sempre que o cara abrir o navegador!!!

    vc sabe se tem como ?

  4. #4
    Abutre
    Quanto ao f5, isso é um bug da porra da Microsoft.
    Existe uma correção que vc terá que executar em todos os navegadores para sumir esta merda.
    Me passa o teu e-mail, que eu mando a correção pra vc !
    E o certo, é ele pedir senha toda vez que o navegador iniciar.
    Deve estar faltando algo.

    Manda as sua regras de autenticação que está no seu .conf do squid.

    Abutre



  5. #5
    Zephirot
    meu mail é michel@zeronet.com.br

    Agora eu consegui... eu estava listando minhas acl's e vi que faltava liberar umas coisas e bloquear outras.


    mas me passa essa correção o Ie pfavor.


    valeu






Tópicos Similares

  1. squid nao autentica user terra no speedy...
    Por frugoni no fórum Servidores de Rede
    Respostas: 0
    Último Post: 06-01-2006, 23:32
  2. Squid não autentica
    Por spikey no fórum Servidores de Rede
    Respostas: 4
    Último Post: 25-10-2005, 22:43
  3. squid não autentica pelo pam mais!!
    Por flipeexpl no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-03-2005, 16:13
  4. Squid não autentica
    Por jlbavaresco no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-11-2004, 23:10
  5. hierarquia squid não autentica...
    Por flipeexpl no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-06-2004, 21:06

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L