+ Responder ao Tópico



  1. #1
    roger_malk
    Visitante

    Padrão ncurses no slack

    tarde *nixers.

    Bom, tava tentando ativar quotas e depois de muito apanhar descobri que não tava ativado no kernel (instalado pelo slack), ai fui tentar recompilar o kernel para ativar e sempre q faço "~# make menuconfig" ele diz que preciso do ncurses instalado. Só q eu ja instalei, e pelo oldconfig eu consigo iniciar mais não ativar as quotas.

    alguém pode me dar alguma luz...

    roger_malk

  2. #2
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão ncurses no slack

    Poste o erro inteiro que ele volta por favor.



  3. #3
    roger_malk
    Visitante

    Padrão ncurses no slack

    Desculpe a demora, é q passei alguns dias longe do pc comlinux....
    Vou explicar desde o comeco.
    Instalei o Slack 9.1 tirando apenas X11, gnome, kde e tudo q fosse grafico.
    Depois configurei o quotas no /etc/fstab, numa partição reiserfs montada como /home (/dev/hda9). dai ele não monta mais a partição. Formatei como ext3, ele monta, mais na hora de habilitar quota ele diz q quota num ta habilitado no kernel.
    Bom....imaginei q ":~# make menuconfig" resolveria o problema.
    Mais na hora que faço, ele da erro dizendo que preciso instalar ncurses.
    Instalei de novo e ainda assim continua dando erro.
    [email protected]:~# make menuconfig &> ~/saida_erro
    rm -f include/asm
    ( cd include ; ln -sf asm-i386 asm)
    make -C scripts/lxdialog all
    make[1]: Entering directory `/usr/src/linux-2.4.22/scripts/lxdialog'
    /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/../../../../i486-slackware-linux/bin/ld: cannot open crt1.o: No such file or directory
    collect2: ld returned 1 exit status
    ^G
    >> Unable to find the Ncurses libraries.
    >>
    >> You must have Ncurses installed in order
    >> to use 'make menuconfig'

    make[1]:***[ncurses] Error 1
    make[1]: Leaving directory `/usr/src/linux-2.4.22/scripts/lxdialog'
    make: *** [menuconfig] Error 2