+ Responder ao Tópico



  1. #1

    Padrão Erro ./configure

    Pessoal da lista, boa noite a todos .....
    Estou tentando configurar um pacote de vpn para o Linux Conectiva 8.
    Peguei o pacote openvpn-1.4.3.tar.gz e fiz o seguinte :
    tar -zxvf openvpn-1.4.3.tar.gz e após isso ele criou o diretório openvpn-1.4.3
    Fui executar o comando ./configure e a medida que vai compilando, aparece a seguinte mensagem, quase já no final :

    checking for gcc... gcc
    checking for C compiler default output ... configure: error: C compiler cannot create executables

    Pelo que entendi ele parece procurar uma saida default e depois diz que não pode criar executáveis. E eu estou usando gcc-2.95.

    Desculpe-me pessoal, eu nunca compilei nada no Linux, é a primeira vez. Alguém poderia por favor, me dar alguma dica de como resolver isso ???
    Desde já, agradeço a todos ....

  2. #2
    estanisgeyer
    Visitante

    Padrão Erro ./configure

    Não mostra outros tipos de erros?
    sugiro que instale todos os aplicativos de desenvolvimento do conectiva 8.
    Como GCC, autoconf, make, etc...

    Att.



  3. #3

    Padrão Erro ./configure

    deve ta faltando algum pacote do gcc

  4. #4

    Padrão Erro ./configure

    SDM, no cd do Conectiva 8 tem 2 pacotes gcc para instalação. Eu instalei os 2 pacotes. Mas valeu. Eu vou dar olhada nos pacotes que o Marcelo sugeriu.

    De qualquer obrigado pela ajuda. Qualquer outra dúvida eu posto aqui para vocês darem uma olhada ....

    Inté + :wink:



  5. #5
    marcelloduarte
    Visitante

    Padrão ...

    Cara ja tive esse mesmo problema, só que no Conectiva 9. Para resolver tive que instalar esse pacotes:

    glibc-devel
    glibc-devel-static

    Coso de o mesmo erro, só que ao inves de gcc seja c++ instale esses:

    task-c++-devel
    task-c-devel
    task-kernel-compiling

    Falo isso pois depois de resolver o gcc, tive o mesmo erro com o C .

    Mas isso foi no Conectiva 9, não sei se no 8 vai funcionar.

  6. #6

    Padrão Erro ./configure

    Pessoal, boa noite ....
    Valeu pelas dicas aqui listadas. Eu instalei o pacote task-c-devel e ele vai pedindo a instalação de outros tantos pacotes. Instalei os pacotes solicitados e depois instalei o task-c-devel.
    Funcionou belezinha ......

    Obrigado galera ......... valeu ......... :wink: