+ Responder ao Tópico



  1. #1
    paradadura
    Visitante

    Padrão Amavis+RedHat9

    Quando estou tentanto instalar o Archive Zip da o seguinte erro

    Archive-Zip-1.09/INSTALL
    Archive-Zip-1.09/Makefile.PL
    Archive-Zip-1.09/README
    Removing previously used /root/.cpan/build/Archive-Zip-1.09

    CPAN.pm: Going to build N/NE/NEDKONZ/Archive-Zip-1.09.tar.gz

    Checking if your kit is complete...
    Looks good

    Warning: I could not locate your pod2man program. Please make sure,
    your pod2man program is in your PATH before you execute 'make'

    Writing Makefile for Archive::Zip
    Makefile:88: *** missing separator. Stop.
    /usr/bin/make -- NOT OK
    Running make test
    Can't test without successful make
    Running make install
    make had returned bad status, install seems impossible

    alguem ja passou por istou ou sabe como eu posso resolver p/ concluir a instalação
    At.
    Alex

  2. #2

    Padrão Amavis+RedHat9

    ele procura pelo pod2man program e não está achando,
    vc tem instalado o pod2man ??



  3. #3
    estanisgeyer
    Visitante

    Padrão Amavis+RedHat9

    Seu problema está com o idioma do seu sistema.
    Verifique a variável $LANG

    echo $LANG

    Provavelmente ele está como pt_BR.UTF-8
    Com este padrão, o script do perl não funcionará pois ele não reconhece alguns caracteres.
    Sete a variável LANG para apenas pt_BR

    LANG=pt_BR

    Depois tente novamente, com certeza vc conseguirá...

    Att.

  4. #4
    paradadura
    Visitante

    Padrão Amavis+RedHat9

    Marcelo era a linguagem mesmo muito obridado...
    At.
    Alex



  5. #5
    bestwest
    Visitante

    Padrão Amavis+RedHat9

    AMigo, vc naum teve problema com o arc pra pode instala o Amavis? PO aki ele pede esse tal de arc.. eu ja baixei um mas num consigo compilar...

  6. #6
    estanisgeyer
    Visitante

    Padrão Amavis+RedHat9

    O problema do Perl em todas as distros é com relação ao charset, por isso é bom ter atenção na variável de ambiente $LANG e setá-lo sem charset ou com ISO8859-1.

    Eu tive problemas em compilar o ARC.
    Sabe o que fiz? Editei o arquivo "configure" e comentei as linhas do ARC. O Amavis funcionou legal, porém estou com problemas em fazer roda-lo funcional no postfix, que não tem nada a ver com o ARC.