+ Responder ao Tópico



  1. Oi pessoal blz !! eu estou instalando um gerenciador de relatorio do squid o nome do programa é SQUID-GRAPH e quando vou executar o programa ele me da esta messagem olhei no help nele , ele nao me ajudou alguem aqui ja passou por isto !! obrigado ai pessoal pela atencao o estou usando o Redhat 8 com squid
    Squid Cache: Version 2.4.STABLE7 blz !! pessoal obrigado ai pela ajuda


    h-2.05b# /usr/local/squid-graph
    Can't locate GD.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i486-linux /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i486-linux /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/local/squid-graph line 16.
    BEGIN failed--compilation aborted at /usr/local/squid-graph line 16.

  2. #2
    Mav3r1ck
    Olá aspenbr,

    Ele está dizendo que não encontrou o módulo GD.pm. Tente instalar alguns pacotes do perl. Não me lembro exatamente o nome, mas é algo como perl-libwww... esse tipo de coisa. Tente procurar no www.cpan.org, te ajudará bastante.

    T+

    Mav3r1ck



  3. #3
    RafaelMonteiro
    ola verifica se a lib GD ta instalada corretamente, mas pelo erro creio que nem está, pois essa biblioteca é essencial para geração de graficos...

    [ ]s


    Rafael Monteiro

  4. #4
    RafaelMonteiro
    ola verifica se a lib GD ta instalada corretamente, mas pelo erro creio que nem está, pois essa biblioteca é essencial para geração de graficos...

    [ ]s


    Rafael Monteiro



  5. entrei dentro desta pasta ela possui (eu acho) a biblioteca grafica

    /programas/super/squid/squid-graph-3.1/extras/GD-1.33
    executei o comando o README mandava

    ---------------------->bash-2.05b# perl Makefile.PL <---------------------------
    NOTICE: This module requires libgd 1.8.3 or higher (shared library version 4.X).

    Please choose the features that match how libgd was built:
    Build JPEG support? [y] y
    Build FreeType support? [y] y
    Build XPM support? [y] n

    If you experience compile problems, please check the @INC, @LIBPATH and @LIBS
    arrays defined in Makefile.PL and manually adjust, if necessary.

    WARNING: CAPI is not a known parameter.
    Note (probably harmless): No library found for -lttf
    Writing Makefile for GD

    ele gerou esta menssagem acima executei outro comando agora estatico

    --->>>>bash-2.05b# perl Makefile.PL LINKTYPE=static<<<<---------------

    NOTICE: This module requires libgd 1.8.3 or higher (shared library version 4.X).

    Please choose the features that match how libgd was built:
    Build JPEG support? [y] y
    Build FreeType support? [y] y
    Build XPM support? [y] y

    If you experience compile problems, please check the @INC, @LIBPATH and @LIBS
    arrays defined in Makefile.PL and manually adjust, if necessary.

    WARNING: CAPI is not a known parameter.
    Note (probably harmless): No library found for -lttf <-- ele ta apontado que esta biblioteca esta faltando alguem sabe onde anrrajo um biblioteca parecida

    Writing Makefile for GD


    Ta complicado para resolver este problema , to usando o slackware 9.1 !!! falow pessoal espero te ajudado vc a entender melhor este problema e valeu pela dica anterior !! fui .......................................






Tópicos Similares

  1. Squid Graph, GD apresentando problemas
    Por Wins no fórum Servidores de Rede
    Respostas: 5
    Último Post: 15-08-2006, 13:24
  2. squid
    Por rosane no fórum Servidores de Rede
    Respostas: 3
    Último Post: 26-05-2006, 18:11
  3. Bridge + Iptables + Squid Remoto
    Por Machado no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-08-2003, 09:04
  4. Bloquear sites no squid - urgente
    Por bauer no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-05-2002, 22:53
  5. Squid
    Por luiz_nando no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-05-2002, 19:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L