+ Responder ao Tópico



  1. #1
    c0dek
    Visitante

    Padrão Openoffice sem acentos e tiu

    Instalei o open office 1.1 em portugues, configurei os idiomas e tudo, porem ele num fas " ´ " ou " ~ ", por exemplo, se eu tento fazert um "á" NUM APARECE NDA alguem já teve esse problema????

  2. #2
    jghellere
    Visitante

    Padrão Openoffice sem acentos e tiu

    No sistema ele faz acentos ?

    Tá, tive o mesmo problema, e para resolver, fiz o seguinte:

    Abri o openofice e fui em:

    Tools ->
    Options... ->

    Depois em:

    Language settings ->
    Languages

    Depois é só colocar tudo Portuguese (Brazil)

    O openoffice pega as configs locais do sistema, então, se vc tiver com seu sistema português Brasil, ele tbm seta o locale dele para pt-BR.



  3. #3
    c0dek
    Visitante

    Padrão Openoffice sem acentos e tiu

    No sistema faz acentos e eu já fiz isso...

  4. #4

    Padrão Openoffice sem acentos e tiu

    Aqui eu resolvi assim :

    Criei um script em /usr/bin com o seguinte conteúdo :

    #Inicio Open Office acentos-pr-BR
    export LANG=pt_BR
    ~/OpenOffice.org1.1.1a/soffice
    #Fim

    chmod +x /usr/bin/openoffice

    Depois eh soh executar ele pra chamar o OpenOffice...

    Detalhe : as instalacoes que tnho aqui saum todas locais...

    Falow !!!



  5. #5
    jghellere
    Visitante

    Padrão Openoffice sem acentos e tiu

    Funcionou ?
    Nossa, que gambiarra, marcio =)
    Para ter o sistema funcionando pt_BR(usando slackware), edite o /etc/profile.d/lang.sh e edite a linha:

    export LANG=C

    para

    export LANG=pt_BR

    pronto !

    execute o openoffice:

    $ soffice

    Antes que falem, sim, é soffice.

  6. #6

    Padrão Openoffice sem acentos e tiu

    poisé...

    Gambiarrao !!! Mas funciona...

    Mas com sua dica vai ficar mais facil agora...

    Valew !!!



  7. #7
    c0dek
    Visitante

    Padrão Openoffice sem acentos e tiu

    esse skema de /etc/profile.d/lang.sh eu já sabia mais sempre usei em ingles mesmo, mais eu não sabvia que o problema do open office estava relacionado a isso...vou testar e depois posto os resultados

  8. #8
    c0dek
    Visitante

    Padrão Openoffice sem acentos e tiu

    alterei o /etc/profile.d/lang.sh e não resolveu o problema ñ



  9. #9
    jghellere
    Visitante

    Padrão Openoffice sem acentos e tiu

    Então veja se o seu X está correto:

    # vi /etc/X11/XF86Config

    na seção:

    # caso for abnt2, altere:

    Option "XkbRules" "xfree86"
    Option "XkbModel" "abnt2"
    Option "XkbLayout" "br"

    # caso for us-acentos, altere:

    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us_intl"

    Se nenhuima das 3 alternativas que passei anteriormente deu certo, não tenho mais idéia.

    1- mudar a config do Openoffice
    2- mudar a config do sistema
    3- mudar a config do X

  10. #10
    slice
    Visitante

    Padrão Acentos no Open Office

    vo cê precisa editar o arquivo /etc/profile.d/lang.sh como root, para que sirva para todos os usuários, e após esta configuração, faça logoff e logon novamente.

    Troque o export LANG=C pelo export LANG=pt_BR e não se esqueça de verificar no KDE se seu teclado está configurado corretamente, o que não vem por default.

    qualquer coisa grita aê!

    []'s

    Slice



  11. #11
    Raziell2003
    Visitante

    Padrão Re: Acentos no Open Office

    Citação Postado originalmente por slice
    vo cê precisa editar o arquivo /etc/profile.d/lang.sh como root, para que sirva para todos os usuários, e após esta configuração, faça logoff e logon novamente.

    Troque o export LANG=C pelo export LANG=pt_BR e não se esqueça de verificar no KDE se seu teclado está configurado corretamente, o que não vem por default.

    qualquer coisa grita aê!

    []'s

    Slice
    essa dica ae funcionou corretamente aqui em casa valeus mermo =)