Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Salatiel
    Tudo bem pessoal, Feito Inedito, acesso o winxp pro no linux.
    Tenho samba e 10 maquinas win98 acessa normalmente o linux sem pedir senha etc, beleza.

    O windows xp pro está acessando o linux, so que pede o usuario e senha, quando coloco, acessa normalmente o servidor linux.

    O que eu quero eh o seguinte: Windows XP acessar o linux sem pedir o nome e senha do usuario, ou seja, acessar diretamente como faz no windows 98. Jah fiz quase tudo, mas ateh agora nada, inclusive executei os arquivos reg. mas infelismente nada.

    Penso que nao se trata de linux, mas winxp, alguma configuracao etc


    Aguardo ajudas

    :? ops:

  2. Amigo eu não tenho certeza mas tenta!
    com smbpasswd -a user
    e não coloca nada na senha
    ai ele entra normal sem pedir senha mas só usei isso com 98 ok.
    tenta pode ser que funcione.
    [ ] os



  3. para entender melhor essa sua configuracao do seu samba, ele é PDC?
    que tipo de acesso vc configurou? se vc der mais detalhes vc vai obter uma resposta direta para a sua duvida!

    []´s

    Vicente

  4. se vc esta usando o samba como PDC é só seguir os passos abaixo...

    1-) Cadastrar senha de root no samba:

    # smbpasswd -a root

    Obs: faça o mesmo processo para todos os usuários da sua rede

    2-) Cadastrar máquina XP:

    Observe que a conta criada tem um sheel invalido (/bin/false) e também um home nulo (/dev/null) para que nenhum engraçadinho faça login usando essa conta :-)

    # useradd -d /dev/null -c linux055 -m -s /bin/false linux055$
    # smbpassword -m -a linux055


    3-) Alterar Registro da estação:

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesNetlogonParameters]
    "DisablePasswordChange"=dword:00000000
    "maximumpasswordage"=dword:0000001e
    "requiresignorseal"=dword:00000000
    "requirestrongkey"=dword:00000000
    "sealsecurechannel"=dword:00000001
    "signsecurechannel"=dword:00000001
    "Update"="no"


    4-) Entrar em:

    Painel de Controle->Ferramentas Administrativas->Politica de Segurança Local e depois em Politicas Locais->Opções de Segurança

    Dentro dessa janela, desabilite as opções abaixo. Não quer quer eu traduza para você, certo? :-)

    Domain member: Digitally encrypt or sign secure channel (always)
    Domain member: Disable machine account password changes
    Domain member: Require strong (Windows 2000 or later) session key


    5-) Depois em:

    Botão Direito em Meu Computador->Propriedades->Nome do Computador->Alterar

    Nome do computador: linux055
    Membro de: Informar Dominio Samba
    Entre com o username e password de Root, depois reinicie o micro



  5. se vc esta usando o samba como PDC é só seguir os passos abaixo...

    1-) Cadastrar senha de root no samba:

    # smbpasswd -a root

    Obs: faça o mesmo processo para todos os usuários da sua rede

    2-) Cadastrar máquina XP:

    Observe que a conta criada tem um sheel invalido (/bin/false) e também um home nulo (/dev/null) para que nenhum engraçadinho faça login usando essa conta :-)

    # useradd -d /dev/null -c linux055 -m -s /bin/false linux055$
    # smbpassword -m -a linux055


    3-) Alterar Registro da estação:

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesNetlogonParameters]
    "DisablePasswordChange"=dword:00000000
    "maximumpasswordage"=dword:0000001e
    "requiresignorseal"=dword:00000000
    "requirestrongkey"=dword:00000000
    "sealsecurechannel"=dword:00000001
    "signsecurechannel"=dword:00000001
    "Update"="no"


    4-) Entrar em:

    Painel de Controle->Ferramentas Administrativas->Politica de Segurança Local e depois em Politicas Locais->Opções de Segurança

    Dentro dessa janela, desabilite as opções abaixo. Não quer quer eu traduza para você, certo? :-)

    Domain member: Digitally encrypt or sign secure channel (always)
    Domain member: Disable machine account password changes
    Domain member: Require strong (Windows 2000 or later) session key


    5-) Depois em:

    Botão Direito em Meu Computador->Propriedades->Nome do Computador->Alterar

    Nome do computador: linux055
    Membro de: Informar Dominio Samba
    Entre com o username e password de Root, depois reinicie o micro






Tópicos Similares

  1. Erro intermitente no login do XP com o Samba
    Por edinr no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-02-2009, 16:57
  2. Windows Xp logando no samba do Red hat enterprise
    Por FabioBC no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-10-2005, 10:08
  3. Samba Win2K e XP (logando como outros usuarios também)
    Por Leleko no fórum Servidores de Rede
    Respostas: 0
    Último Post: 18-02-2004, 09:26
  4. Problema com o samba quando se utiliza o konqueror
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 13-02-2003, 16:19
  5. Squid com autenticação Samba automatica!
    Por sublinux no fórum Servidores de Rede
    Respostas: 0
    Último Post: 21-01-2003, 08:41

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L