+ Responder ao Tópico



  1. #1
    epf
    Visitante

    Padrão Erro de Comprtilhamento - Adsl

    Cara Comunidade,
    Eu estou tentando configurar um servidor de internet , com a distro slackware. A conexao e speed router, com ip fixo, os numeros sao o seguinte:
    ip 201.0.51.88
    gateway 201.0.51.65
    DNS 200.204.0.10
    dns 200.204.0.138

    as minhas configuracoes atuais do sistema sao a seguinte:
    em /etc/HOSTNAME esta:
    127.0.0.1 localhost
    192.168.0.1 servidor.dominio.com

    em /etc/resolv.conf esta:
    servidor 200.204.0.10
    servidor 200.204.0.138


    em /etc/dhcpd.conf esta:
    option domain-name "dominio.com";
    option domain-name-servers 200.204.0.10, 200.204.0.138;
    ddns-update-style ad-hoc;
    default-lease-time 600;
    max-lease-time 7200;
    log-facility local7;
    subnet 192.168.0.0 netmask 255.255.255.0 {
    range 192.168.0.2 192.168.0.255;
    option routers 192.168.0.1;
    option broadcast-address 192.168.0.255;
    default-lease-time 600;
    max-lease-time 7200;
    }


    em /etc/rc.d/rc.local esta
    /etc/rc.d/rc.inet1
    ifconfig eth0 up
    ifconfig eth1 up
    ifconfig eth0 201.0.51.88 netmask 255.255.255.0
    ifconfig eth1 192.168.0.1 netmask 255.255.255.0
    rout add default gw 201.0.051.65
    dhcpd eth1
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUNTING -s 192.168.0.0/24 -o eth0 -j MASQUERADE

    Assim que estao minhas configuracoes, a questao e:
    Eu consigo navegar perfeitamente, consigo pingar fora da rede, so que as estacoes (em windows98 com ip dinamico) nao conseguem achar a conexao.

    Eu nao sei mais o que fazer, alguem tem alguma solucao?
    Abracos
    Atenciosamente
    Eder Pires da Fonseca

  2. #2
    lss
    Visitante

    Padrão Erro de Comprtilhamento - Adsl

    o problema deve estar na regra de iptables
    iptables -t nat -A POSTROUNTING -s 192.168.0.0/24 -o eth0 -j MASQUERADE
    não seria -o eth1? já que é por ela que vc está compartilhando.



  3. #3

    Padrão Erro de Comprtilhamento - Adsl

    Cara... tenta a regra

    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    valeu...