Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    marceloals
    Olá Pessoal,

    Estou tendo uma grande dificuldade em utilizar o SSH do RH9, pois tenho um script que necessitara startar um outro em uma maquina remota, para isso eu deveria usar o SSH com chave de criptografia para realizar a tarefa. vou descrever o que fiz e até agora não deu certo:

    - Criei um usuário chamado kuser nas duas máquinas;
    - Na máquina cliente logado como kuser gerei as chaves usando:
    ssh-keygen -b 1024 -P '' -t dsa
    ssh-keygen -b 1024 -P '' -t rsa
    - Copiei as chaves publicas em disquete e coloquei seu conteudo nos arquivos da máquina remota:
    #### Na máquina cliente #####
    mount /dev/fd0 /mnt/floppy
    cd .ssh
    cp identity.pub /mnt/floppy/
    cp id_rsa.pub /mnt/floppy/
    umount /mnt/floppy
    #### Na máquina servidor #####
    ## Logado como kuser
    mount /dev/fd0 /mnt/floppy
    mkdir .ssh
    cat /mnt/floppy/identity.pub >> /home/kuser/.ssh/autorized_keys
    cat /mnt/floppy/identity.pub >> /home/kuser/.ssh/autorized_keys
    chmod 600 /home/kuser/autorized_keys
    #### Voltando à máquina cliente
    ssh -i /home/kuser/.ssh/identity servidor #### me retorna permission denied
    ssh -i /home/kuser/.ssh/id_rsa servidor #### me retorna permission denied

    As permissões dos arquivos estão:
    autorized_keys 600
    identity 600
    id_rsa 600
    identity.pub 644
    id_rsa.pub 644
    know_hosts 644

    Meus aquivos de configuracao estao assim:

    >>>>>>>>>>>>>>>>>>>>>>>/etc/ssh/ssh_config:<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    # $OpenBSD: ssh_config,v 1.16 2002/07/03 14:21:05 markus Exp $

    # This is the ssh client system-wide configuration file. See
    # ssh_config(5) for more information. This file provides defaults for
    # users, and the values can be changed in per-user configuration files
    # or on the command line.

    # Configuration data is parsed as follows:
    # 1. command line options
    # 2. user-specific file
    # 3. system-wide file
    # Any configuration value is only changed the first time it is set.
    # Thus, host-specific definitions should be at the beginning of the
    # configuration file, and defaults at the end.

    # Site-wide defaults for various options

    # Host *
    # ForwardAgent no
    # ForwardX11 no
    # RhostsAuthentication no
    # RhostsRSAAuthentication no
    # RSAAuthentication yes
    PasswordAuthentication no
    # HostbasedAuthentication no
    # BatchMode no
    # CheckHostIP yes
    # StrictHostKeyChecking ask
    # IdentityFile ~/.ssh/identity
    # IdentityFile ~/.ssh/id_rsa
    # IdentityFile ~/.ssh/id_dsa
    # Port 22
    # Protocol 2,1
    # Cipher 3des
    # Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
    # EscapeChar ~
    Host *
    ForwardX11 yes


    >>>>>>>>>>>>>>>>>>>>>>>/etc/ssh/sshd_config:<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    # $OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #Protocol 2,1
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 3600
    #ServerKeyBits 768

    # Logging
    #obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    SyslogFacility AUTHPRIV
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 120
    #PermitRootLogin yes
    #StrictModes yes

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # rhosts authentication should not be used
    #RhostsAuthentication no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes

    #AFSTokenPassing no

    # Kerberos TGT Passing only works with the AFS kaserver
    #KerberosTgtPassing no

    # Set this to 'yes' to enable PAM keyboard-interactive authentication
    # Warning: enabling this may bypass the setting of 'PasswordAuthentication'
    #PAMAuthenticationViaKbdInt no

    #X11Forwarding no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #KeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression yes

    #MaxStartups 10
    # no default banner path
    #Banner /some/path
    #VerifyReverseMapping no

    # override default of no subsystems
    Subsystem sftp /usr/libexec/openssh/sftp-server

    ----------------------------------------------------------------------------
    Isto em ambas as máquinas

    Se alguem puder me ajudar, por favor me socorra.

    Grato,

    Marcelo Lopes
    Refife/PE.

  2. #2
    jghellere
    O arquivo que deve virar o authorized_keys é o id_rsa.pub e não o identity.pub.

    soh isso.

    O resto dos arquivos estão corretos.



  3. #3
    marceloals
    Já utilizei tanto o id_rsa.pub gerado pelo ssh-keygen -t rsa e passada ao autorized_keys do servidor mas ocorre o mesmo erro. Seria possível que o problema esteja nas configurações do PAM no que se refere ao sshd lá no etc/pam.d ??? Quanto as regras de filtro de pacotes estas foram setadas como iptables -A INPUT -p tcp -s 0.0.0.0/0.0.0.0 -d maq/masc --dport 22 -j ACCEPT.

    No mais, não faço idéia do que poderia ser. Por isso continuo contando com a ajuda de vocês.

    Obrigado.

  4. #4
    Spelk
    Citação Postado originalmente por jghellere
    O arquivo que deve virar o authorized_keys é o id_rsa.pub e não o identity.pub.

    soh isso.

    O resto dos arquivos estão corretos.
    Se eu não me engano, é necessário reiniciar o computator para que as alterações tenham efeito, acho q só reiniciar o serviço não funciona.

    Depois de feito isso é só logar normalmente via ssh só especificando o usuário correto:

    #ssh xxx.xxx.xxx.xxx -l kuser

    onde, xxx.xxx.xxx.xxx é o IP remoto
    o "-l" (traço éle) é para especificar o usuário, "login"



  5. #5
    marceloals
    Continua não funcionando. Será que vou ter que reinstalar tudo novamente??? Se for isso, quer dizer que o RH-9 não é estavel???






Tópicos Similares

  1. Problemas com chaves no OpenSSH
    Por marceloals no fórum Servidores de Rede
    Respostas: 4
    Último Post: 01-04-2004, 00:12
  2. PHP com Apche no RH 8.0
    Por no fórum Servidores de Rede
    Respostas: 15
    Último Post: 09-04-2003, 14:02
  3. problemas com dhcp no redhat 8
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-04-2003, 07:17
  4. Problemas com mouse no KDE
    Por Francisco no fórum Servidores de Rede
    Respostas: 12
    Último Post: 14-11-2002, 11:49
  5. probls com samba no RH 8 - Parte 2
    Por joe_fox no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-11-2002, 17:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L