+ Responder ao Tópico



  1. #1

    Padrão Forbidden no Apache 2

    Estou com um problema no Apache 2 do Fedora....

    no httpd.conf eu mando ele exibir o conteudo da pasta /var/www/html/ (padrão dele)

    ok.. tem um site q tá rodando de boa no /var/www/html/site/

    ai qdo digito no navegador ip/site/ ok..funciona legal...

    só q eu adicionei uma outra pasta lá... o site2 em /var/www/html/site2/

    ok mas qdo digito no navegador ip/site2/
    aparece o erro de Forbidden e q eu não tenho acesso..

    mas como q isso é possivel??

    nota: nas 2 pastas eu dei chmod -R 777

    o q acontece????

    Obrigado

  2. #2
    slice
    Visitante

    Padrão forbidden no httpd

    verifique quem é o proprietário do arquivos (ls -l) dê preferência por usar o mesmo user/group que o apache está rodando (nobody.nobody é o default) , normalmente eu uso user httpd e grupo httpd (user add httpd; groupadd httpd) e altero o httpd.conf para conter User httpd e Group httpd (+- linha 320) e seto o diretório dos arquivos para o mesmo user/group do apache, ou seja chown -R httpd.httpd /diretorio/htdocs/site

    Acho que isto resolve...

    Qualquer coisa grita aê!

    []'s



  3. #3
    ozzymaia
    Visitante

    Padrão Forbidden no Apache 2

    vc tem configurado esse site no seu APACHE?
    Ele é o que? Um domínio Virtual?
    Não entendi qual está sendo o seu problema, pois se está setado permissão 777, vc pode acessar com qualquer usuário ou dono do arquivo que vai abrir de qualquer jeito!!!! afinal está totalmente liberado!!!

  4. #4

    Padrão Forbidden no Apache 2

    Obrigado pela resposta...

    Citação Postado originalmente por ozzymaia
    vc tem configurado esse site no seu APACHE?
    Ele é o que? Um domínio Virtual?
    Sim é onde esta o meu site..... e não possui dominio virtual

    Citação Postado originalmente por ozzymaia
    Não entendi qual está sendo o seu problema, pois se está setado permissão 777, vc pode acessar com qualquer usuário ou dono do arquivo que vai abrir de qualquer jeito!!!! afinal está totalmente liberado!!!
    Então... é o q eu penso.. não sei pq deu isso... antes qdo tava no Red Hat e Apache 1.3 funcionava... passei pro Fedora e Apache 2.. apareceu esse problema chato.....

    Abraços



  5. #5

    Padrão Forbidden no Apache 2

    ls -l dentro da pasta... veja se sua index está com permissões 755

  6. #6
    ozzymaia
    Visitante

    Padrão Forbidden no Apache 2

    Bom...
    - verifique se o nome da pasta esta escrito certo?!!
    - Tente criar uma outra pasta e ver se funciona;
    - quem acessa estes sites??
    ...
    bom o q eu imagino e q vc tenha d criar dominio virtuais para conseguir fazer fucionar....



  7. #7

    Padrão Forbidden no Apache 2

    Citação Postado originalmente por Jim
    ls -l dentro da pasta... veja se sua index está com permissões 755
    NOTA-SE que ele já deu permissão total recursivamente pra todos os arquivos,pelo chmod -R 777 dir do site....

  8. #8

    Padrão Forbidden no Apache 2

    Citação Postado originalmente por tronx
    Citação Postado originalmente por Jim
    ls -l dentro da pasta... veja se sua index está com permissões 755
    NOTA-SE que ele já deu permissão total recursivamente pra todos os arquivos,pelo chmod -R 777 dir do site....
    '

    Ainda bem que o Tronx não deixa escapar uma bola fora minha... :-D

    Valeu cara!



  9. #9

    Padrão Forbidden no Apache 2

    Já to FULO da vida com esse Apache 2 ....

    já fiz chmod... chown...
    mexi no User do httpd.conf

    e nada...... ma pasta onde eu direciono.. o index funciona.. e tudo vai bunitim...

    e só colocar ip/diretorio.... nem arvore d arquivo aparece.....
    dá logo forbiden.......

    q doidera.... agora no Apache 1.3 funcionava legal....

  10. #10
    Geraldo B Foscaches Filho
    Visitante

    Padrão Tente isto

    # chown -R nobody.nobody /var/www/html

    # vi /etc/httdpd/conf/httpd.conf
    User nobody
    Group nobody
    ###### Creio que até aqui já funcione. ######
    DocumentRoot "/var/www/html/seu_site" (Não lembro a linha)
    <Directory "/var/www/html/seu_site"> (Um pouco mais para baixo)


    Passei pelo mesmo problema que você, e ao fuçar im pouco o httpd.conf consegui fazer o Apache funcionar.

    Espero ter ajudado,

    Geraldo Barbosa Foscaches Filho