Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Estou com um problema no Apache 2 do Fedora....

    no httpd.conf eu mando ele exibir o conteudo da pasta /var/www/html/ (padrão dele)

    ok.. tem um site q tá rodando de boa no /var/www/html/site/

    ai qdo digito no navegador ip/site/ ok..funciona legal...

    só q eu adicionei uma outra pasta lá... o site2 em /var/www/html/site2/

    ok mas qdo digito no navegador ip/site2/
    aparece o erro de Forbidden e q eu não tenho acesso..

    mas como q isso é possivel??

    nota: nas 2 pastas eu dei chmod -R 777

    o q acontece????

    Obrigado

  2. #2
    slice
    verifique quem é o proprietário do arquivos (ls -l) dê preferência por usar o mesmo user/group que o apache está rodando (nobody.nobody é o default) , normalmente eu uso user httpd e grupo httpd (user add httpd; groupadd httpd) e altero o httpd.conf para conter User httpd e Group httpd (+- linha 320) e seto o diretório dos arquivos para o mesmo user/group do apache, ou seja chown -R httpd.httpd /diretorio/htdocs/site

    Acho que isto resolve...

    Qualquer coisa grita aê!

    []'s



  3. #3
    ozzymaia
    vc tem configurado esse site no seu APACHE?
    Ele é o que? Um domínio Virtual?
    Não entendi qual está sendo o seu problema, pois se está setado permissão 777, vc pode acessar com qualquer usuário ou dono do arquivo que vai abrir de qualquer jeito!!!! afinal está totalmente liberado!!!

  4. Obrigado pela resposta...

    Citação Postado originalmente por ozzymaia
    vc tem configurado esse site no seu APACHE?
    Ele é o que? Um domínio Virtual?
    Sim é onde esta o meu site..... e não possui dominio virtual

    Citação Postado originalmente por ozzymaia
    Não entendi qual está sendo o seu problema, pois se está setado permissão 777, vc pode acessar com qualquer usuário ou dono do arquivo que vai abrir de qualquer jeito!!!! afinal está totalmente liberado!!!
    Então... é o q eu penso.. não sei pq deu isso... antes qdo tava no Red Hat e Apache 1.3 funcionava... passei pro Fedora e Apache 2.. apareceu esse problema chato.....

    Abraços



  5. ls -l dentro da pasta... veja se sua index está com permissões 755






Tópicos Similares

  1. 403 Forbidden no Apache
    Por cintiars no fórum Servidores de Rede
    Respostas: 1
    Último Post: 24-02-2005, 13:38
  2. Qtos dominios virtuaai no apache?
    Por augustolynx no fórum Servidores de Rede
    Respostas: 8
    Último Post: 06-12-2002, 19:31
  3. DUVIDA, SOBRE DYNAMIC DNS NO APACHE ???
    Por _Luigi_ no fórum Servidores de Rede
    Respostas: 4
    Último Post: 13-10-2002, 08:07
  4. Estatísticas no apache
    Por ediguedes no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-07-2002, 10:56
  5. Mod_SSL No apache 2.0.36
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-04-2002, 01:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L