+ Responder ao Tópico



  1. #1
    giunr
    Visitante

    Padrão Erro ao inicializar o squid

    Ola colegas,

    estou usando o Slackware 9.1 e instalei o squid 2.5

    quando eu inicio o squid da o seguinte erro no /var/log/messages

    squid[5104]: Squid Parent: child process 5117 exited due to signal

    Alguem pode me dar uma dica do que esta acontecendo?

    Agradeço qualquer ajuda

    Falow

    Giu

  2. #2
    Abutre
    Visitante

    Padrão Erro ao inicializar o squid

    Olha amigo...
    Alguma regra sua não está legal !!
    Poste seu squid.conf !

    Abraço,

    Abutre



  3. #3
    slake
    Visitante

    Padrão :-(

    caros colegas, tbm estou com esse problema, isso so acontece no slackware 9.0 e 9.1
    sei la o q eh ..se eh algum erro no kernel ou alguma outra configuração q vem como padrão que esta errada, mas so sei q ele naum fica nem alguns segundos carregado como modulo.
    e concerteza naum eh o squid.conf pois peguei de uma maquina red hat q o squid estava carregado e com o mesmo squid.conf ...continua dando esse mesmo problema de levar um kill em processos filhos.

    se alguem souber a resposta pra isso , plz help us !

  4. #4
    slake
    Visitante

    Padrão Erro ao inicializar o squid

    mas por duvidas vou ate por meu squid.conf aki

    http_port 8080
    cache_mem 100 MB
    cache_swap_low 95
    cache_swap_high 98
    maximum_object_size 61440 KB
    maximum_object_size_in_memory 4096 KB
    cache_dir ufs /usr/local/squid/var/cache 10000 16 256
    cache_access_log /usr/local/squid/var/logs/access.log
    cache_log /var/log/squid/cache.log
    emulate_httpd_log on
    log_fqdn on
    ftp_passive on
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl nossa src 192.168.1.0/255.255.255.0
    acl SSL_ports port 443 563
    acl Safe_ports port 80 21 443 563 70 210 1025-65535
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    #acl blacklist url_regex "/etc/squid/blacklist"
    #acl whitelist url_regex "/etc/squid/whitelist"
    acl download urlpath_regex .exe$ .zip$ .arj$ .tar.gz$ .tgz$ .rpm$ .mp3$
    http_access allow manager localhost all
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    #http_access deny !blacklist
    #http_access allow whitelist
    http_access allow nossa
    http_access deny all
    icp_access allow all
    miss_access allow all
    cache_effective_user squid
    cache_effective_group squid
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    cache_mgr [email protected]



  5. #5
    giunr
    Visitante

    Padrão Squid

    Bom eu consegui revolver meu problema da seguinte forma. Eu inicializava o squid e por algum motivo ele parava e nao gerava os aquivos de log pra poder ver qual o erro. Ai utilizei o seguinte comando

    [email protected]:~#./squid -NCd1

    com esse comando o squid acabou me mostrando que eu nao tinha permissao pra criar os log no diretorio cache e consequentemente ele nao iniciava.

    Tente usar o squid com esse parametros ai pra ver qual o problema.

    É isso ai! ;-)

  6. #6

    Padrão Erro ao inicializar o squid

    Tente mudar o usuario e grupo do diretorio de cache do squid

    exemplo


    chowm -R proxy.proxy /caminho da cache/squid


    e tente reinicializar o squid novamente, blz..


    OBS.: proxy.proxy são o usuario e grupo que o squid utiliza para inicializar, verifique se os mesmos existem, se não existirem crios e acrescente no seu squid.conf as linhas
    cache_effective_user proxy
    cache_effective_group proxy



  7. #7
    smyows
    Visitante

    Padrão tb dando erros

    grupo e user proxy ok .. conf tb... sexta funcionava.. cheguei hj e nada...

    2004/04/26 09:51:07| Starting Squid Cache version 2.5.STABLE5 for i686-pc-linux-gnu...
    2004/04/26 09:51:07| Process ID 2000
    2004/04/26 09:51:07| With 1024 file descriptors available
    2004/04/26 09:51:07| Performing DNS Tests...
    2004/04/26 09:51:07| Successful DNS name lookup tests...
    2004/04/26 09:51:07| DNS Socket created at 0.0.0.0, port 32847, FD 4
    2004/04/26 09:51:07| Adding nameserver 127.0.0.1 from /etc/resolv.conf
    2004/04/26 09:51:07| helperOpenServers: Starting 5 'pam_auth' processes
    2004/04/26 09:51:08| Unlinkd pipe opened on FD 14
    2004/04/26 09:51:08| Swap maxSize 563200 KB, estimated 43323 objects
    2004/04/26 09:51:08| Target number of buckets: 2166
    2004/04/26 09:51:08| Using 8192 Store buckets
    2004/04/26 09:51:08| Max Mem size: 32768 KB
    2004/04/26 09:51:08| Max Swap size: 563200 KB
    2004/04/26 09:51:08| Rebuilding storage in /var/cache/squid (DIRTY)
    2004/04/26 09:51:08| Using Least Load store dir selection
    2004/04/26 09:51:08| Set Current Directory to /var/cache/squid
    2004/04/26 09:51:08| Loaded Icons.
    2004/04/26 09:51:08| Accepting HTTP connections at 0.0.0.0, port 3128, FD 16.
    2004/04/26 09:51:08| Accepting ICP messages at 0.0.0.0, port 3130, FD 17.
    2004/04/26 09:51:08| Accepting HTCP messages on port 4827, FD 18.
    2004/04/26 09:51:08| Accepting SNMP messages on port 3401, FD 19.
    2004/04/26 09:51:08| WCCP Disabled.
    2004/04/26 09:51:08| Pinger socket opened on FD 21
    Segmentation fault