+ Responder ao Tópico



  1. #1
    markcom
    Visitante

    Padrão sarg nao gera relatorio

    Pessoal ja tenho o squid instalado e rodando bonitinho e o squid está registrando os sites acessados no /usr/local/squid/var/logs/access.log (já foi verificado), e o problema todo agora é com o sarg pois ele nao está gerando relatório algum o comando dado é:

    sarg -f /usr/local/sarg/sarg.conf -d 10/04/2004-12/04/2004

    E O COMANDO APRESENTADO É:

    SARG: Nao ha registros
    SARG: Fim

    SENDO QUE O ARQUIVO "access.log" está cheio de registros dos sites acessados. Estou postando abaixo o aquivo "/usr/local/sarg/sarg.conf"

    ###############################################

    language English
    access_log /usr/local/squid/var/logs/access.log
    title "Relatório Diário do Proxy"
    font_face Arial
    header_color darkblue
    header_bgcolor blanchedalmond
    header_font_size -1
    background_color white
    text_color black
    text_bgcolor beige
    title_color green
    temporary_dir /tmp
    output_dir /var/www/htdocs/squidmon/dia
    topuser_sort_field BYTES reverse
    user_sort_field BYTES reverse
    exclude_users /usr/local/sarg/exclude.users
    exclude_hosts /usr/local/sarg/exclude.hosts

    # Formato da data (e=dd/mm/yy, u=mm/dd/yy, w=yy/ww)
    date_format e

    lastlog 0
    remove_temp_files yes
    index yes
    overwrite_report yes
    records_without_userid ignore
    use_comma no
    topsites_num 100
    topsites_sort_order BYTES D
    exclude_codes /usr/local/sarg/exclude_codes
    max_elapsed 28800000

    # -- Tipo de Relatorio a ser gerado --
    # + topsites - Mostra o site, conexão e bytes
    # + sites_users - Mostra que usuários estavam acessando um site
    # + users_sites - Mostra sites acessados pelo usuário
    # + date_time - Mostra quantidade de bytes usados por dia e hora
    # + denied - Mostra todos os sites negados com URL completa
    # + auth_failures - Mostra falhas de autentificação
    report_typie topsites users_sites sites_users date_time denied auth_failures site_user_time_date

    long_url yes

    exclude_string /usr/local/sarg/exclude.strings

    show_successful_message no

    topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE

    topuser_num 100

    ###############################################

    Marcelo...

  2. #2
    markcom
    Visitante

    Padrão Alguem Pode Me Ajudar com Sarg ??

    ************************************************************
    VEJAM O RETANTE NO TÓPICO ACIMA: Enviada: Mon Apr 12, 2004 12:05 pm Assunto: SARG NAO GERA
    RELATORIO

    ************************************************************

    --------------------------------------------------------------------------------

    Pessoal ja tenho o squid instalado e rodando bonitinho e o squid está registrando os sites acessados no /usr/local/squid/var/logs/access.log (já foi verificado), e o problema todo agora é com o sarg pois ele nao está gerando relatório algum o comando dado é:

    sarg -f /usr/local/sarg/sarg.conf -d 10/04/2004-12/04/2004

    E O COMANDO APRESENTADO É:

    SARG: Nao ha registros
    SARG: Fim



  3. #3
    Visitante

    Padrão sarg nao gera relatorio

    O caminho onde se encontram os arquivos de log gerados pelo squid(access.log) é realmente esse? /usr/local/squid/var/logs/access.log

    Se sim, as configurações estarão ok!!!

    Verifica se a data do seu computador está correta!

  4. #4
    markcom
    Visitante

    Padrão observei mais uma coisa

    OBSERVEI QUE MAIS UMA, SEMPRE QUE EU TENTO GERAR OS RELATÓRIO DO SARG ELE CRIA DOIS ARQUIVOS COM NOMES UM TANTO INTERESSANTES MAS COMO EU NÃO CONHECO BEM O SERVICO NAO CONSIGO VERIFICAR SE É ALGUM PROBLEMA OU SOLUÇÃO.

    /tmp/authfail.log.unsort
    /tmp/denied.log.unsort

    Marcelo Souza.



  5. #5

    Padrão sarg nao gera relatorio

    Caro colega!

    O sarg é bem simples de ser implementado, na verdade é só vc ter o arquivo access.log no local indicado no sarg.conf e pronto; segue o link abaixo que não tem erro, eu configurei me baseando nele.

    http://www.devin.com.br/eitch/sarg/

    Abraços.
    Boa sorte!

  6. #6

    Padrão sarg nao gera relatorio

    Eu também estou com o mesmo problema.
    Ja revisei varias vezes as configurações e todas estão OK



  7. #7
    jeanop
    Visitante

    Padrão sarg nao gera relatorio

    Eu também estou com mesmo problema não gera, e da um erro de falha de segmentação, as configuração estão todas certas ...

  8. #8
    pflamellas
    Visitante

    Padrão sarg nao gera relatorio

    Caros Amigos,
    caso vcs estejam usando o squid que veio junto com suas distros...conectiva e RedHat o caminho dos logs do squid estão em:
    /var/log/squid/access.log
    /var/log/squid/cache.log
    /var/log/squid/store.log


    é bom dar uma verifica no squid.conf para ver onde ele coloca os arquivos de log...e depois é só colocar o caminho no sarg.conf

    Abraços
    Paulo Fernando Lamellas



  9. #9
    guardian_metal
    Visitante

    Padrão sarg nao gera relatorio

    Ja tive esse problema e uso RH9.. o problema é o sarg.conf, se vc tirar essas linha:

    "
    lastlog 0
    remove_temp_files yes
    index yes
    overwrite_report yes
    records_without_userid ignore
    use_comma no
    topsites_num 100
    topsites_sort_order BYTES D
    exclude_codes /usr/local/sarg/exclude_codes
    max_elapsed 28800000

    # -- Tipo de Relatorio a ser gerado --
    # + topsites - Mostra o site, conexão e bytes
    # + sites_users - Mostra que usuários estavam acessando um site
    # + users_sites - Mostra sites acessados pelo usuário
    # + date_time - Mostra quantidade de bytes usados por dia e hora
    # + denied - Mostra todos os sites negados com URL completa
    # + auth_failures - Mostra falhas de autentificação
    report_typie topsites users_sites sites_users date_time denied auth_failures site_user_time_date

    long_url yes

    exclude_string /usr/local/sarg/exclude.strings

    show_successful_message no

    topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE

    topuser_num 100
    "

    e rodar o comando para gerar o relatório, ele funciona. Do contrário não e nem sei porque. Testa ae.

  10. #10
    pflamellas
    Visitante

    Padrão sarg nao gera relatorio

    Amigos,
    vai uma copia domeu sarg.conf...estou usando o RH9 e tá funfa legal....

    sarg.conf
    ********************
    language Portuguese
    access_log /var/log/squid/access.log
    title "Relatório de uso da Internet"
    output_dir /var/www/html/squid
    resolve_ip yes
    date_format e
    index yes
    topsites_num 100
    topsites_sort_order CONNECT D
    index_sort_order D
    max_elapsed 28800000
    report_type topsites sites_users users_sites date_time denied auth_failures site_user_time_date
    topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE
    user_report_fields CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE
    topuser_num 0
    datafile_fields user;date;time;url;connect;bytes;in_cache;out_cache;elapsed
    weekdays 0-6
    hours 0-23
    show_sarg_info no
    displayed_values abbreviation
    *******************



  11. #11
    Visitante

    Padrão sarg nao gera relatorio

    pessoal quanto a questão do RH 9 (que eu já usei e recomendo) no próprio site do sarg tem uma linha onde está escrito que o RH9 tem um bugzinha e que o comando export LC_ALL=C deve ser executado antes do sarg...

    já passei pelo mesmo problema

    SARG: Nao ha registros
    SARG: Fim

    em suas situações:

    primeiramente quando o destino não existia (a pasta onde ele ia colocar os relatórios não existiam)
    e segundo, quando a pasta não tinha permissão de escrita...

    a obeservação quanto à origem do access.log também é válida, verifique se o log está lá mesmo...

    espero ter ajudado

  12. #12
    Visitante

    Padrão Re: SARG NAO GERA RELATORIO

    Citação Postado originalmente por markcom
    Pessoal ja tenho o squid instalado e rodando bonitinho e o squid está registrando os sites acessados no /usr/local/squid/var/logs/access.log (já foi verificado), e o problema todo agora é com o sarg pois ele nao está gerando relatório algum o comando dado é:

    sarg -f /usr/local/sarg/sarg.conf -d 10/04/2004-12/04/2004

    E O COMANDO APRESENTADO É:

    SARG: Nao ha registros
    SARG: Fim

    SENDO QUE O ARQUIVO "access.log" está cheio de registros dos sites acessados. Estou postando abaixo o aquivo "/usr/local/sarg/sarg.conf"

    ###############################################

    language English
    access_log /usr/local/squid/var/logs/access.log
    title "Relatório Diário do Proxy"
    font_face Arial
    header_color darkblue
    header_bgcolor blanchedalmond
    header_font_size -1
    background_color white
    text_color black
    text_bgcolor beige
    title_color green
    temporary_dir /tmp
    output_dir /var/www/htdocs/squidmon/dia
    topuser_sort_field BYTES reverse
    user_sort_field BYTES reverse
    exclude_users /usr/local/sarg/exclude.users
    exclude_hosts /usr/local/sarg/exclude.hosts

    # Formato da data (e=dd/mm/yy, u=mm/dd/yy, w=yy/ww)
    date_format e

    lastlog 0
    remove_temp_files yes
    index yes
    overwrite_report yes
    records_without_userid ignore
    use_comma no
    topsites_num 100
    topsites_sort_order BYTES D
    exclude_codes /usr/local/sarg/exclude_codes
    max_elapsed 28800000

    # -- Tipo de Relatorio a ser gerado --
    # + topsites - Mostra o site, conexão e bytes
    # + sites_users - Mostra que usuários estavam acessando um site
    # + users_sites - Mostra sites acessados pelo usuário
    # + date_time - Mostra quantidade de bytes usados por dia e hora
    # + denied - Mostra todos os sites negados com URL completa
    # + auth_failures - Mostra falhas de autentificação
    report_typie topsites users_sites sites_users date_time denied auth_failures site_user_time_date

    long_url yes

    exclude_string /usr/local/sarg/exclude.strings

    show_successful_message no

    topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE

    topuser_num 100

    ###############################################

    Marcelo...



  13. #13
    Visitante

    Padrão RESPOSTA PARA RELATÓRIOS SEM REGISTRO NO SARG!

    O que pode acontecer é você não fazer autenticação por usuário, no caso de proxy transparente ou proxy sem autenticação, você deve informar para o sarg como proceder com os registros sem usuário através da linha:

    records_without_userid ip

    Passe o parâmetro "IP" e ele gera o relatório com i ip da máquina no campo usuário.

    Rafael Cardoso

    [email protected]

    Citação Postado originalmente por pflamellas
    Caros Amigos,
    caso vcs estejam usando o squid que veio junto com suas distros...conectiva e RedHat o caminho dos logs do squid estão em:
    /var/log/squid/access.log
    /var/log/squid/cache.log
    /var/log/squid/store.log


    é bom dar uma verifica no squid.conf para ver onde ele coloca os arquivos de log...e depois é só colocar o caminho no sarg.conf

    Abraços
    Paulo Fernando Lamellas