+ Responder ao Tópico



  1. #1
    Retamero
    Visitante

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    Olá pessoal, esse é meu primeiro post aqui...

    Seguinte, tenho configurado na minha maquina o Slackware9.1 +Apache+Mysql+php
    e funciona perfeito a algum tempo

    http://sumare.homelinux.org:2380/mega.php (script de teste)

    porem, fiz a instalação identica num slack 9.0 >> atualizado p/ 9.1

    e o php naum atualiza as telas

    vejam no link, o relogio marca a data da instalação
    e os scripts funcionam parciamente...
    http://marcosound.homelinux.org
    http://marcosound.homelinux.org/mega.php (mesmo script do primeiro server)


    jah fiz de tudo, compilei o php e apache

    imagino q seja algo do slack9.0, pois foi a unica difrença entre os 2
    , como disse antes, as configurações, estaum identicas
    fiz e refiz nos dois, e soh nesse segundo a naum funciona

  2. #2

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    cara....sinseramente eu nao intendi nada....abri as paginas tds e num vi nada de errado, como assim "o php naum atualiza as telas" ?? ainda nao intendi...



  3. #3
    Retamero
    Visitante

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    Desculpe acho q naum fui claro:

    Servidor 1 (funciona perfeitamente)
    Servidor 2 (abre a pagina, mas o php naum atualiza)
    naquele primeiro link (mega-sena) se vc dar "reload"
    as dezenas saum re-sorteadas

    no segundo link
    repare na data do relogio, ele esta para em:
    26 - 03 - 2004 14:56:28 (q por sinal foi o dia e hora q eu instalei o lah php)

    no terceiro link eh o da mega-sena de novo (soh que no server ruim)

    repare q as dezenas nunca mudam (atualizam)

    26 9 58 46 45 54

    o estranho q alguns testes funcionam (aquele famoso teste.php)

  4. #4

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    aannnn sim....agora intendi.....bom isso pode ser problema nao no server web, mas sim no php, vc ja comparou os dois??? se tiver como vc postar parte do codigo fica mais facil pra gente te ajudar... :wink:

    para ser problema na instalacao soh seria se vc nao tivesse usado as opcoes corretas no ./configure dos dois ou no php.ini ou no httpd.conf



  5. #5
    Retamero
    Visitante

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    pois é a uinca diferença que vi, foi a versaum do bison...

    de resto a compilação foi identica

    server "bom"
    log.txt

    server "ruim"

    configure.log


    eu fiz um backup de servidor bom (dados) e copiei (via wget) p/ o server "ruim"
    usando o mesmo http.conf (apache 1.3 e agora 2.0)
    sera q alguma coisa c/ premissoes de executar scripts???


    obrigado, pela atenção

  6. #6
    Retamero
    Visitante

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    putz.. testei tando permissoes e nada...
    mas, olha q curioso:
    usando p comando php no terminal
    (mesmo sem estar rodando o apache..)
    o script mega.php tb naum atualiza!!

    # php mega.php
    <HTML><HEAD><TITLE>Brincando com os números da MEGA-SENA</TITLE></HEAD><BODY BGCOLOR=#1991bd TEXT=white LINK=yellow ALINK=yellow VLINK=orange><CENTER><IMG SRC=mega01.png BORDER=0><BR><FONT SIZE=7>Brincando com os 6 números da Mega-Sena</FONT></CENTER><P><HR SIZE=5><P><CENTER><TABLE BORDER=2 CELLSPACING=7 CELLPADDING=8><TBODY><TR><TD><CENTER>1.º número<BR><FONT SIZE=7 COLOR=yellow>26</FONT></CENTER></TD><TD><CENTER>2.º número<BR><FONT SIZE=7 COLOR=yellow>9</FONT></CENTER></TD><TD><CENTER>3.º número<BR><FONT SIZE=7 COLOR=yellow>58</FONT></CENTER></TD><TD><CENTER>4.º número<BR><FONT SIZE=7 COLOR=yellow>46</FONT></CENTER></TD><TD><CENTER>5.º número<BR><FONT SIZE=7 COLOR=yellow>45</FONT></CENTER></TD><TD><CENTER>6.º número<BR><FONT SIZE=7 COLOR=yellow>54</FONT></CENTER></TD></TR></TBODY></TABLE></CENTER><P><HR SIZE=5><P><CENTER><FONT SIZE=5>Para SORTEAR 6 NOVOS números da MEGA-SENA, clique no botão ATUALIZAR (RELOAD) do seu navegador web (browser).</FONT></CENTER><P><HR SIZE=5><P>
    <PRE>
    DADOS DO AUTOR DESTA PÁGINA (WEBMASTER):

    --
    Eder S. G. - [email protected]: [email protected]
    ESG Computação - Serviços gerais em Informática & Tecnologia
    WebSite: http://www.esg-computacao.eti.br
    Usuário Linux Registrado: 179086 - Telefone: 0(xx)(32)-9112-7504
    Técnico em Processamento de Dados - Estudante/graduação em Informática
    Paz, Justiça, Honra, Lealdade, Ética, Responsabilidade, Honestidade
    </PRE>

    </BODY></HTML>
    esse teste prova q o problemas esta mesmo com o php e naum o apache

    outra coisa q notei, o servidor c/ problema, usa uma lib a mais

    # ldd /usr/local/bin/php
    /lib/libsafe.so.2 => /lib/libsafe.so.2 (0x40017000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x40039000)
    libmysqlclient.so.12 => /usr/lib/libmysqlclient.so.12 (0x40066000)
    libresolv.so.2 => /lib/libresolv.so.2 (0x4009d000)
    libm.so.6 => /lib/libm.so.6 (0x400af000)
    libdl.so.2 => /lib/libdl.so.2 (0x400d1000)
    libnsl.so.1 => /lib/libnsl.so.1 (0x400d4000)
    libz.so.1 => /usr/lib/libz.so.1 (0x400e9000)
    libxml2.so.2 => /usr/lib/libxml2.so.2 (0x400f6000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x401ee000)
    libc.so.6 => /lib/libc.so.6 (0x4023f000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
    servidor bom

    # ldd /usr/local/bin/php
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x4002e000)
    libmysqlclient.so.12 => /usr/lib/libmysqlclient.so.12 (0x4005b000)
    libresolv.so.2 => /lib/libresolv.so.2 (0x40092000)
    libm.so.6 => /lib/libm.so.6 (0x400a4000)
    libdl.so.2 => /lib/libdl.so.2 (0x400c7000)
    libnsl.so.1 => /lib/libnsl.so.1 (0x400ca000)
    libz.so.1 => /usr/lib/libz.so.1 (0x400df000)
    libxml2.so.2 => /usr/lib/libxml2.so.2 (0x400ec000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x401e4000)
    libc.so.6 => /lib/libc.so.6 (0x40235000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
    :?



  7. #7

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    como vc ta fazendo pra gerar esses numeros?? eh usando q funcao?? a funcao rand(), a mt_rand, ou qual???talvez seja um problema expecifico na sua funcao com relacao a instalacao do php....roda a funcao phpinfo() nos dois computadores e ve se vc vai encontrar alguma diferenca bizarra entre elas

  8. #8
    Retamero
    Visitante

    Padrão Problemas no PHP :: abre mas naum atualiza as paginas

    Citação Postado originalmente por SDM
    como vc ta fazendo pra gerar esses numeros??
    Fiz no terminal (shell)

    # php [caminho] [script]

    exemplo

    # php /home/www/server2/testes/mega.php

    (aprendi isso no manual do php)

    blz.. vou testar sua dica. qq coisa "post" aqui :?