Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    schiavi
    Fala galera blz...

    Deve ver uma pergunta meuio besta essa mais ai vai:
    Eu istalei o SuSE 9.0 e na hora da instalação eu coloquei para ele istalar um WebSever Simples, q tinha Apache+MySQL+PHP e mais algumas outras coisas... isso significa q o apache já esta funcionando? COmo eu faço pra ver minhas pginas feitas em PHP no Browser?, eu tenho já laguma noção de Apache só q no Windows...

    Desde já agradeço
    Carlos

  2. Amigo... para ver suas págnas, basta que vc as coloque dentro da pasta no qual o apache está buscando os sites, geralmente em /var/www/html
    Você precisa iniciar o apache sempre que o micro for ligado, para isso use uma das opções:
    - comando ntsysv, marque a opção de webserver
    - chkconfig httpd on
    - Adicionar dentro de rc.local o comando service httpd start

    Depois é só abrir o browser e digitar o IP do servidor...



  3. #3
    schiavi
    Cara eu fui no console e digitei o comando "ntsysv" q vc falou, ai deu "Command not found" ai eu fui tentar o outro comando o "chkconfig httpd on" e deu "httpd: unknow service"...

    oq faço??

    ps no meu caso o o diretorio do apache esta como "/srv/www/htdocs"...
    eu olhei isso no httpd.conf

    Grato..

  4. algum desses comandos deveria funcionar, estou estranhando... o apache está mesmo instalado? service httpd start não funcionou?



  5. #5
    schiavi
    O comando httpd start funcioniu!, ai eu fui no brownser e digitei http://127.0.0.1 ai apreceu uma pagina do apache, isso significa q o apache ta funcionando certo?... ai eu fui no arquivo httpd.conf tava assim:

    DocumentRoot /srv/www

    e depois no DocumentIndex (eu acho)

    DocumentIndex /srv/www/htdocs

    ai eu alteria para

    DocumentRoot /home/carlos
    DocumentIndex /home/carlos/website

    mas se eu for em /home/carlos/website e colocar alguma pagina htm la ele nao abre por exemplo:

    eu fui no brownser e digitei http://127.0.0.1/teste.htm mas ele abre a pagina de erro do apache... sendo q la no /home/carlos/website eu coloquei o arquivo teste.htm...

    Alguma ideia??

    Valew pela auda cara!






Tópicos Similares

  1. Não consigo instalar Apache no Linux (Suse 10.0)
    Por ester no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-10-2007, 18:23
  2. Apache + PHP + Joomla: Configuração no Suse Linux
    Por mrpostiga no fórum Servidores de Rede
    Respostas: 1
    Último Post: 08-01-2007, 21:01
  3. Problemas com Apache no Suse Linux 9.0
    Por danmusic no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-09-2004, 16:10
  4. Redirecionamento com apache
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 04-08-2002, 15:24
  5. Mod_SSL No apache 2.0.36
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-04-2002, 01:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L