+ Responder ao Tópico



  1. #1
    Trojahn
    Estou me deparando com um erro estranho... Jah uso Qmail ha anos e esta maquina eh uma na qual eu recentemente instalei o Qmail (leia-se neste domingo)...

    Acontece que para algumas contas locais o qmail esta dizendo que a conta nao existe... Verifiquei coisas como espaco em disco, quota, permissao na mailbox, etc... Nada anormal...

    Utilizo qmail + maildrop... Mas isso eh antes do maildrop jah que quem verifica se a conta existe ou nao eh o qmail-local... O estranho eh que varias contas funcionam e somente algumas retornam como inexistentes... Alguem jah passou por isso?

  2. #2
    Trojahn
    Bem,

    Pesquisei... Pesquisei... E descobri a solucao e resolvi coloca-la aqui para ajudar os proximos que possam ter o mesmo problema...

    O problema era do qmail-getpw... Ele considera um usuario mesmo aqueles que tem:
    1 - uid diferente de zero
    2 - tenham um diretorio home
    3 - sejam donos de seu home...

    O meu problema estava no terceiro requerimento... Alguns usuarios, sabe-se lah porque, nao eram donos de seus homes... Fiz um pequeno script e acertei as permissoes e agora esta tudo na santa paz



  3. #3
    estanisgeyer
    Provavelmente o diretório de alguns usuários foram criados manualmente, isso já aconteceu comigo.






Tópicos Similares

  1. qmail no vmware
    Por cezarpardal no fórum Servidores de Rede
    Respostas: 1
    Último Post: 24-10-2008, 09:05
  2. Instalando Qmail no Debian
    Por niggas no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-01-2006, 06:19
  3. Servidor Qmail no RedHat 7.2 dá???
    Por elton no fórum Servidores de Rede
    Respostas: 0
    Último Post: 03-09-2004, 14:30
  4. Qmail no DEBIAN
    Por gerusso no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-07-2004, 12:06
  5. Instalação de qmail no redhat 8.0
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-06-2003, 04:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L