Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Placa de som ac97!

    Como configurar corretamente a palca de som ac97? Porque é o seguinte. Primeiro eu fui lá no /etc/rd.d/rc.modules e descomentei a minha placa de som. Até aí tudo blz! O problema é que quando eu ligava o pc aparecia um monte de erros quando tentava carregar o modulo da placa, apesar disso o som funcionava perfeitamente. Aí eu fui tentar configurar a placa pelo ALSA, para ver se tirava os erros da inicialização! Nesse quesito tudo bem ... não existem mais erros na inicialização e talz. Pus um cd pra tocar .. ai o som ficou perfeito! Mas quando fui tocar mp3 .. o som ficou xiando pakas! =/ ... Ai queria saber se alguem ja passou por isso ... e/ou sabe como resolver. Pois não queria ficar cheio de erro na inicialização do pc, e muito menos ficar com o som xiando! .. Ah! Os volumes estão ok! Agradeço ...

  2. #2

    Padrão Placa de som ac97!

    ja tentou regular com o alsamixer?



  3. #3

    Padrão Placa de som ac97!

    jah! os volumes tao oks! ja tentei tantas combinaçãoes quanto possiveis e nda! hauhau
    Agora ta td no verdinhu e soh!

  4. #4
    Visitante

    Padrão Placa de som ac97!

    Amigo eu tenho essa placa e uso slackware 9.1 e precisei fazer isso
    [[email protected] root]# modprobe ac97_codec
    [[email protected] root]# modprobe via82cxxx_audio

    Confira com lsmod
    [[email protected] root]# lsmod

    Module Size Used by
    ppp_async 6160 0 (autoclean)
    ppp_generic 15968 0 (autoclean) [ppp_async]
    sr_mod 13952 1 (autoclean)
    via82cxxx_audio 16800 0
    soundcore 3504 2 [via82cxxx_audio]
    ac97_codec 8688 0 [via82cxxx_audio]
    nls_iso8859-1 2848 1 (autoclean)
    nls_cp850 3584 1 (autoclean)
    vfat 9040 1 (autoclean)
    fat 30720 0 (autoclean) [vfat]
    supermount 32496 4 (autoclean)
    fdomain 12360 1
    sd_mod 11048 0 (unused)
    scsi_mod 86036 3 [sr_mod fdomain sd_mod]

    Bom tenta ai qualquer coisa veja se num tem modulos levantado que não corresponda com a sua placa aconteceu comigo, e meu som não funcionava.

    T+
    [ ] os



  5. #5

    Padrão Placa de som ac97!

    kra ... nem da aqui ... tem como tu me mandar teu /etc/modules.conf?

  6. #6



  7. #7

    Padrão Placa de som ac97!

    Tem sim mas qual distro vc está usando ?

  8. #8

    Padrão Placa de som ac97!

    Citação Postado originalmente por Anonymous
    ppp_async 6160 0 (autoclean)
    ppp_generic 15968 0 (autoclean) [ppp_async]
    sr_mod 13952 1 (autoclean)
    via82cxxx_audio 16800 0
    soundcore 3504 2 [via82cxxx_audio]
    ac97_codec 8688 0 [via82cxxx_audio]
    nls_iso8859-1 2848 1 (autoclean)
    nls_cp850 3584 1 (autoclean)
    vfat 9040 1 (autoclean)
    fat 30720 0 (autoclean) [vfat]
    supermount 32496 4 (autoclean)
    fdomain 12360 1
    sd_mod 11048 0 (unused)
    scsi_mod 86036 3 [sr_mod fdomain sd_mod]

    Este é o modules.conf do cara



  9. #9

    Padrão Placa de som ac97!

    Quando eu dou modprobe via82cxxx_audio aparece o seguinte:

    /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o: init_module: No such device
    /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o: insmod /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o failed
    /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o.gz: init_module: No such device
    /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o.gz: insmod /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o.gz failed
    /lib/modules/2.4.22/kernel/drivers/sound/via82cxxx_audio.o.gz: insmod via82cxxx_audio failed

  10. #10



  11. #11

    Padrão Placa de som ac97!

    Talvez a placa do colega que falou isso tenha um chipset da Via, e a sua não....
    posta um cat /proc/pci pra nós ai

  12. #12

    Padrão Placa de som ac97!

    PCI devices found:
    Bus 0, device 0, function 0:
    Host bridge: VIA Technologies, Inc. VT8375 [KM266/KL266] Host Bridge (rev 0).
    Master Capable. Latency=8.
    Prefetchable 32 bit memory at 0xe0000000 [0xe7ffffff].
    Bus 0, device 1, function 0:
    PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP] (rev 0).
    Master Capable. No bursts. Min Gnt=12.
    Bus 0, device 16, function 2:
    USB Controller: VIA Technologies, Inc. USB (#3) (rev 128).
    IRQ 5.
    Master Capable. Latency=32.
    I/O at 0xec00 [0xec1f].
    Bus 0, device 16, function 1:
    USB Controller: VIA Technologies, Inc. USB (#2) (rev 128).
    IRQ 5.
    Master Capable. Latency=32.
    I/O at 0xe800 [0xe81f].
    Bus 0, device 16, function 0:
    USB Controller: VIA Technologies, Inc. USB (rev 128).
    IRQ 11.
    Master Capable. Latency=32.
    I/O at 0xe400 [0xe41f].
    Bus 0, device 16, function 3:
    USB Controller: VIA Technologies, Inc. USB 2.0 (rev 130).
    IRQ 10.
    Master Capable. Latency=32.
    Non-prefetchable 32 bit memory at 0xdfffff00 [0xdfffffff].
    Bus 0, device 17, function 0:
    ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge (rev 0).
    Bus 0, device 17, function 1:
    IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 6).
    IRQ 14.
    Master Capable. Latency=32.
    I/O at 0xfc00 [0xfc0f].
    Bus 0, device 17, function 5:
    Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235 AC97 Audio Controller (rev 80).
    IRQ 5.
    I/O at 0xe000 [0xe0ff].
    Bus 0, device 18, function 0:
    Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 116).
    IRQ 11.
    Master Capable. Latency=32. Min Gnt=3.Max Lat=8.
    I/O at 0xdc00 [0xdcff].
    Non-prefetchable 32 bit memory at 0xdffffe00 [0xdffffeff].
    Bus 1, device 0, function 0:
    VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266] (rev 0).
    IRQ 11.
    Master Capable. Latency=32. Min Gnt=4.Max Lat=255.
    Non-prefetchable 32 bit memory at 0xdfe80000 [0xdfefffff].
    Prefetchable 32 bit memory at 0xd0000000 [0xd7ffffff].



  13. #13
    asclows
    Visitante

    Padrão Placa de som ac97!

    Oua!!!

    Quêêê isso...??

    Configurei minha placa na boua com um simples alsaconf .
    Não entendo o que causou tanto reboliço!

    # alsaconf

    E pronto, se auto-configura, não precisa ficar penando!
    O script está dentro do dir /usr/sbin ou /usr/bin.

  14. #14
    asclows
    Visitante

    Padrão Placa de som ac97!

    ah! Não esqueça de ajustar o volume com kmixer ou algo do gênero, por default o som está ajustado para mudo!



  15. #15

    Padrão Placa de som ac97!

    Cara ... ja tentei pelo alsa(o som ficou xiando) ... ja tentei descomentando o /etc/rc.d/rc.modules (desse jeito o som ficou perfeito ... mas aparece um monte de erro na inicialização do linux). Ja tentei de um monte de jeito ...

  16. #16
    asclows
    Visitante

    Padrão Placa de som ac97!

    Já deu uma olhada no slackwarezine.com.br na edição nº 1 há uma abordagem sobre configuração alsa feita pelo PiterPunk....

    Dá uma olhada, pode ajudar....



  17. #17

    Padrão Placa de som ac97!

    Será que não é o seu codec de mp3 que tá bichado???
    Teste a configuração do alsa, com arquivos mid e wav e veja se eles ficam ruins também...

  18. #18

    Padrão Placa de som ac97!

    tao! Hj eu fiz uma loucura aqui e funcionou! So que quando reiniciei v]o som voltou a xiar ... ki porra ... o pior eh ki eu nem sei direito o ki fiz! Vo tentar fazer outra loucura aqui .. huhu huh... tomara que esteja bem inspirado!



  19. #19

    Padrão Placa de som ac97!

    Defina loucura???
    Se foi no terminal é só usar a setinha pra cima...

    Agora, da próxima vez você vai ter que executar estes comandos na inicialização do sistema

  20. #20

    Padrão Placa de som ac97!

    hauhuaha
    Setinha pra cima ... isso eu sei =P
    O pro ... eh saber qual das acoes que eu fiz concertou o erro saka ...vo ficar testando aqui ... qualquer coisa aviso =*